Download it now!
Bug 74323 - change case
Summary: change case
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.2.0.4 release
Hardware: All Windows (All)
: medium normal
Assignee: Kohei Yoshida
URL:
Whiteboard: target:4.3.0 target:4.2.1
Keywords: regression
: 74461 74989 75105 (view as bug list)
Depends on:
Blocks:
 
Reported: 2014-02-01 15:26 UTC by Luca
Modified: 2014-11-05 20:06 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Luca 2014-02-01 15:26:52 UTC
Calc: commands in menu Format | Change case don't work anymore.
Comment 1 m.a.riosv 2014-02-01 22:38:50 UTC
Hi @Luca, thanks for reporting.

Reproducible
Win7x64Ultimate
Version: 4.2.0.4 Build ID: 05dceb5d363845f2cf968344d7adab8dcfb2ba71

With some tries seems that if you select a range only the last cell in the range is not change, in one cell range nothing is changed.

As workaround select one cell more that the range you want change.
Comment 2 Jean-Baptiste Faure 2014-02-02 08:57:32 UTC
Tested with LO 4.2.1.0.0+ and the master updated 10 hours ago (Build ID: 6ebd7992ae774c7eb96b55c1cf39fbd922f66878) on Ubuntu 13.10 x86-64

If you select a range of cells, the command works for all rows but the last row of the range.
So it does not work at all for a single cell.

Best regards. JBF
Comment 3 m.a.riosv 2014-02-04 01:06:34 UTC
*** Bug 74461 has been marked as a duplicate of this bug. ***
Comment 4 Kohei Yoshida 2014-02-10 03:04:32 UTC
I'll take it.
Comment 5 Commit Notification 2014-02-10 03:07:13 UTC
Kohei Yoshida committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=e041a1bfef98b54656cfaafcb0f586867a21edf1

fdo#74323: Add unit test for changing cases of text cells.



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 6 Commit Notification 2014-02-10 03:07:27 UTC
Kohei Yoshida committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=b6378a1651e7157063746d7001ef566545338bd0

fdo#74323: The end position is inclusive.



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 7 Kohei Yoshida 2014-02-10 03:08:37 UTC
4.2 backport request: https://gerrit.libreoffice.org/7961
Comment 8 Commit Notification 2014-02-10 03:14:00 UTC
Kohei Yoshida committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=863f1bfca71a5eb084931b49393fb7a9c5a0deaf

fdo#74323: Test the undo and redo as well.



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 9 Commit Notification 2014-02-10 08:12:01 UTC
Kohei Yoshida committed a patch related to this issue.
It has been pushed to "libreoffice-4-2":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=6a27efa43b2181599fb92ed99061e5b491dfd4a2&h=libreoffice-4-2

fdo#74323: The end position is inclusive.


It will be available in LibreOffice 4.2.1.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 10 Kohei Yoshida 2014-02-10 13:56:19 UTC
Fixed.
Comment 11 m.a.riosv 2014-02-11 02:49:54 UTC
Verified fixed.
Version: 4.2.1.0.0+ Build ID: 684a0308dcb847f816967202ba87f536b83dcb4e
TinderBox: Win-x86@42, Branch:libreoffice-4-2, Time: 2014-02-10_23:09:14
Comment 12 m.a.riosv 2014-02-15 13:57:27 UTC
*** Bug 74989 has been marked as a duplicate of this bug. ***
Comment 13 Kohei Yoshida 2014-02-17 20:30:29 UTC
*** Bug 75105 has been marked as a duplicate of this bug. ***