Bug 74375 - EDITING: Option to enable editing keys (cursor, Home, etc.) on first entry of text into cell (without the need to start editing mode with F2)
Summary: EDITING: Option to enable editing keys (cursor, Home, etc.) on first entry of...
Status: NEW
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
: 34688 98840 122857 (view as bug list)
Depends on:
Blocks: Cell-Edit-Mode
  Show dependency treegraph
 
Reported: 2014-02-02 13:35 UTC by dg1727
Modified: 2019-01-27 16:46 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description dg1727 2014-02-02 13:35:09 UTC
LibreOffice 4.1.4.2 on Ubuntu 13.04.  

1.  Create a new Calc document.  
2.  Enter a value in a cell not in the 1st or 2nd column, say cell E1.  The reason for this will be stated in a later paragraph.  
3.  Double-click a cell in an intermediate column, say cell B1.  
4.  Type 2 words of text (with a space between them), but don't press Enter yet.  
5.  Press one of the editing keys, say, CursorLeft.  
6.  Issue:  Calc will stop editing the cell, and the cell cursor (the thick black rectangle) will move to a different cell.  
7.  Double-click cell B1 again to resume editing it.  
8.  Now the editing keys (Home, End, cursor keys, whatever) work within the text in the active cell.  The difference seems to be that step 5 is during the first entry of a value into the cell, whereas step 8 is in editing a cell that already has a value.  Typing the space in step 4 seems to trigger this difference in behaviour.  

Please add an option to allow editing keys (step 5) to work as in step 8.  

The current behaviour can be very annoying when entering lots of text into a spreadsheet, since almost every cell can have a typing mistake at first, so cell editing will get interrupted in almost every cell when the user reflexively presses an editing key to fix the typing mistake.  

The reason for step 2 is to show that the End key in step 5 has the same problem as the cursor keys.  (If the End key is pressed in step 5, the cell cursor will move to column E.)  

The reason for editing text not in the first column is to show that the Home and CursorLeft keys have the same problem as the other keys (moving the cell cursor to column A).  

The requested feature will cause cell editing to be different than in Microsoft Office.  (In my opinion, having the editing keys work differently on the first edit to a cell than on later edits is a misfeature which LO, or really OOo, duplicated from MS Office.)
Comment 1 m.a.riosv 2014-02-02 22:57:19 UTC
Hi  dg1727, thanks for reporting.

I think [F2] to start the edition or while editing, does what you want.

Changed status to RESOLVED NOTABUG, please if you are not agree reopen it.
Comment 2 dg1727 2014-02-03 00:04:02 UTC
mariosv, 

Thanks for helping with this.  Yes, there are at least 3 ways to start entering a value into a cell:  

A.  Double-click the cell.  

B.  Move the cell cursor to the cell (either using the editing keys or a single-click) and press F2.  

C.  Move the cell cursor to the cell (either using the editing keys or a single-click) and start typing.  

Only case C has the issue.  Step 3 in my original description is wrong:  if you double-click the cell like I said, the issue doesn't happen.  Sorry for writing "Double-click" when I didn't actually double-click the cell.  

I think my issue report is valid except for that mistake, though.  AFAICT there is nothing about case C that makes evident why it is different from cases A & B.  Also, a user who is doing a lot of cell-to-cell navigation using the keyboard may not want to use methods A or B even if (s)he knows the difference between them:  

F2 is out of the usual touch-typing area on many keyboards, so method B may be undesired during heavy use of the keyboard.  The cursor keys are also out of the touch-typing area, but:  
  (a) Tab, Shift+Tab, and Enter can be used for some navigation for case C, and those keys are in the touch-typing area; 
  (b) the location of the cursor keys IMO is more standardised than of the function keys, including on laptops (multimedia keys etc. may relocate or shrink the function keys); 
  (c) sometimes there is a shelf or other object that makes it awkward for a user to reach the function keys, but I think this is less common with the cursor keys.  

If there are users who want the existing behaviour of the editing keys in case C, then maybe a Tools > Options > LibreOffice Calc setting can be made (in the General > "Input settings" section?) to keep the existing method.
Comment 3 m.a.riosv 2014-02-03 00:13:22 UTC
I think it was a choice to facilitate a quick editing through cells, at least for me is much more usual enter a number or short text data in cells than a lot of text.

As there is not a bug but a request for enhancement, please change the status from normal to an enhancement.
Comment 4 dg1727 2014-02-03 02:59:15 UTC
OK.
Comment 5 Cor Nouws 2014-02-03 09:50:14 UTC
Hi dg,

thanks for this issue...
The option you ask for, already exists: hit F2
If the navigation keys would work immediately, I could not use them to leave the cell. SO this is a valid exception on the other cases.

But then, this issue is related to bug 70129 : "Hitting F2 when a cell is in editing mode, should not leave editing mode"

IMO, we indees should set this one to WorksForMe...

Cor
Comment 6 dg1727 2014-02-04 02:58:10 UTC
Cor, thank you for your very helpful comment.  

Following the link in it, I found bug 63374, "calc gives no visual clue about enter/edit cell mode".  

I agree with the submitter of that bug:  
> Calc mimics the behavior of MS Excel: 
> start typing into a cell, and you get into 'Enter' mode 
> (enter/tab/cursor keys commit and step to an other cell), and 
> F2 activates 'Edit' mode (only enter/tab commit changes).
> Excel shows the current state in the status bar

> this whole Enter/Edit distinction seems totally wrong to me

Thank you for pointing out that pressing F2 during cell editing will switch to Edit mode so that the cursor & editing keys move the text cursor within the cell, instead of moving the cell cursor to other cells.  

As with the whole fact of having separate Enter and Edit modes in the first place, I think it is too hard for a user to learn this about the F2 key.  

The mention in Tools > Customize... > Keyboard tab of "F2 - Toggle Edit Mode" is somewhat unlikely for a user to notice.  Even if they do notice it, toggling edit mode to "off" will easily be assumed by a user (who doesn't try it, because they assume they know what "Toggle Edit Mode" means) to refer to returning to the state in which there is a black cell-cursor around the cell, and there is no blinking text cursor.  

The description of F2 in the help is also not easy to find:  It's below a whole screenful (on a high-resolution monitor; more than a screenful on a low-res monitor) of navigation keys, and is under the heading "Function Keys," which doesn't say anything to the user about entering or editing data in a cell.  

Some users use Calc as a mathematical notebook, with extensive text annotation, making the editing of text in a cell a more often desired use of the cursor & editing keys than moving from cell to cell.  Users in these cases are typically fine with needing to use Tab, instead of the cursor or editing keys, to move to a different cell once the user has started entering data into the cell.  

As mentioned in comment 2, Tab (to enable use of cursor keys for cell-to-cell navigation) is generally easier to reach than F2 (to enable use of cursor keys for intra-cell editing).  

I clarify my proposal to:  

Add a checkbox, in Tools > Options > LibreOffice Calc > General > "Input settings" group, similar to:  "Entry of data into cell starts Enter mode."  This could default to enabled for compatibility with Excel.  A user browsing through Tools > Options would then wonder what Enter mode is, look up this checkbox in the help, and be enlightened about this feature of Excel.  

I chose my suggested checkbox text to mention Enter mode, rather than Edit mode, because there is already a checkbox next to it that mentions Edit mode, and I want to give users the hint that Enter mode and Edit mode are different.  

By the way, I thought I had changed the severity of this bug to "enhancement" at mariosv's request.  I'll try it again now.
Comment 7 almos 2014-02-04 10:08:03 UTC
The current behavior mimics that of MS Excel. I think it should remain like this for compatibility. The only problem is that Excel displays the current enter/edit state, while LO doesn't (see 63374).
Comment 8 dg1727 2014-02-04 18:13:37 UTC
I'm proposing to leave the existing behavior by default BUT allow users the option of making Calc's enter/edit-mode behavior less confusing.  

I believe a number of existing Calc options (in Tools > Options...) are similar to this (giving users the option of having Calc act differently than Excel).  

I know for a fact there are aspects of Calc that are more user-friendly than the corresponding aspects of Excel (at least the version of Excel that was current when the feature was added to Calc), and that don't even have options to turn them off.  

I think that for inexperienced users, even showing Enter vs. Edit mode in the status bar is likely to be (a) unnoticed for a long time; and (b) once it is noticed, still confusing.  Item (a) can be addressed by their sysadmin (who is familiar with the user's experience level) by disabling the requested checkbox on installation of LibreOffice; (b) can be addressed by the user or sysadmin by disabling the requested checkbox once the default inconsistent behavior dawns on them.
Comment 9 Cor Nouws 2014-11-04 21:42:33 UTC
(In reply to dg1727 from comment #8)
> I'm proposing to leave the existing behavior by default BUT allow users the
> option of making Calc's enter/edit-mode behavior less confusing.  


More options to become less confusing? How to find that when you don't know the application :)

IMO NotABug. I really do not believe in this.
But if you really insist, we can set an enhancement.
Comment 10 dg1727 2014-12-01 10:29:40 UTC
(In reply to Cor Nouws from comment #9)
> (In reply to dg1727 from comment #8)
> > I'm proposing to leave the existing behavior by default BUT allow users the
> > option of making Calc's enter/edit-mode behavior less confusing.  
> 
> More options to become less confusing? How to find that when you don't know
> the application :)
> 
> IMO NotABug. I really do not believe in this.
> But if you really insist, we can set an enhancement.

Some users simply don't expect Calc to make a distinction between Enter & Edit mode (and don't see value in it once they are informed about it).  For these users, the distinction is confusing no matter how familiar these users are with the application.  

Enter mode (the one in which cursor keys move from cell to cell, invoked in Excel by just typing into a cell) seems to assume (falsely) that users catch only typing mistakes that are just to the left of the text cursor (in left-to-right text) so the Backspace key is the best way to correct them.
Comment 11 dg1727 2014-12-01 12:14:37 UTC
I think I should have set this to UNCONFIRMED instead of NEW.  Now I'm not able to change it to UNCONFIRMED, though.  Sorry for the mistake.
Comment 12 almos 2014-12-06 13:59:07 UTC
I think the correct fix is to display the current mode just like Excel does.
Comment 13 Cor Nouws 2016-01-08 23:08:19 UTC
*** Bug 34688 has been marked as a duplicate of this bug. ***
Comment 14 Dakov 2016-01-09 01:35:30 UTC
I'm in favor of adding these options:


"Typing into a cell...

... works like Excel (default)
... does nothing (tap F2 to edit).

or

... enters editing mode (like double-click) and
... overwrites/replaces its content.
... puts the cursor where it was left off.
... puts the cursor at the end of content.
... puts the cursor at the start of content."


I agree it's an enhancement - not a bug.

As you might know a basic UI rule is the less modes the better. Modes are harder for the brain to adapt to since habits will work against you (like tapping Home or arrow left to fix a typo).

Excel's different editing modes are simply counter-intuitive but I see its advantages when quickly entering several numbers (which I do quite rarely).
Comment 15 Cor Nouws 2016-03-23 13:43:15 UTC
*** Bug 98840 has been marked as a duplicate of this bug. ***
Comment 16 Buovjaga 2019-01-27 16:46:14 UTC
*** Bug 122857 has been marked as a duplicate of this bug. ***