Bug Hunting Session
Bug 74385 - Error 6025 pure virtual function call on Shutdown from SvxAutoCorrCfg
Summary: Error 6025 pure virtual function call on Shutdown from SvxAutoCorrCfg
Status: RESOLVED DUPLICATE of bug 86494
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
4.1.1.2 release
Hardware: x86 (IA32) Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-02-02 15:55 UTC by cloclo2014
Modified: 2015-04-07 14:16 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:


Attachments
WinDbg Logfile with errorcode but without backtrace (17.94 KB, text/plain)
2014-12-01 10:14 UTC, bugzilla2
Details
WinDbg Log with (hopefully valid) backtrace and analysis (43.29 KB, text/plain)
2014-12-09 14:55 UTC, bugzilla2
Details

Note You need to log in before you can comment on or make changes to this bug.
Description cloclo2014 2014-02-02 15:55:12 UTC
Windows 8.1 - Libre office 4.1


Microsoft Visual C++ Runtime Library
Runtime error !
Program: C:\program Files (x86)\LibreOffice4\program\soffice.bin
R6025
- pure virtual function call
Comment 1 Maxim Monastirsky 2014-02-02 16:07:12 UTC
Hi,

4.1.0 is really old and unsupported, so please try with the latest versions (4.2.0 or 4.1.4). You can get them from http://www.libreoffice.org/download.

Also please provide step by step instruction on how to reproduce this bug. Otherwise we can't do much about it. When done, set the bug status back to UNCONFIRMED. Thanks.
Comment 2 cloclo2014 2014-02-02 17:36:49 UTC
Hi

I downloaded the latest french 4.2.LibreOffice
But I recieve the same error 6025 By closing LibreOffice
Comment 3 Julien Nabet 2014-02-02 20:52:45 UTC
cloclo:
- on which module do you have this? Base, Writer, Calc, Impress, all?
- do you reproduce this with a brand new file?
- did you install any LO specific extensions?
- could you rename your LO directory profile (see https://wiki.documentfoundation.org/UserProfile) and give it a new try?
- what Java precise version do you have (32 or 64 bits)?
Comment 4 cloclo2014 2014-02-03 05:11:24 UTC
HI,

I recieve this error on leaving WRITTER. Only writter was installated. No LO extension was added. i will try your proposition
Best regard
Comment 5 Julien Nabet 2014-02-03 06:37:27 UTC
cloclo2014: I wonder too if it could be due to the fact you installed only Writer. Could you give a try after having installed the whole pack?
Comment 6 Maxim Monastirsky 2014-02-03 07:29:12 UTC
(In reply to comment #4)
> Only writter was installated.
How did you do it? 4.2 installation doesn't have the option to not install some of the components, see release notes.

Anyway, would be great if you provide a backtrace as described at https://wiki.documentfoundation.org/How_to_get_a_backtrace_with_WinDbg. Basically you need to attach WinDbg to 'soffice.bin' process before you click on the 'OK' button of the error message, and then click it to reproduce the crash.
Comment 7 czieschla 2014-02-25 14:33:10 UTC
Same issue with 4.2 on windows 8.1 while closing writer. java32 is actual.
after install 64bit java the bug seems so be gone.
Comment 8 Makrea 2014-03-31 11:59:14 UTC
Please say the steps to reproduce.
It shows the error by simply closing writer? With a document opened? Without a document opened? Was the document opened through another app?

I'm having the same error while closing but when doing a more specific operation. See https://www.libreoffice.org/bugzilla/show_bug.cgi?id=76830
Comment 9 Julien Nabet 2014-03-31 18:24:41 UTC
Stephan: it seems Java 64bits might be used/searched in Windows whereas we only build in 32bits for Windows.
I asked to reporter of fdo#69004 to give it a try.
I thought you might be interested in this one.
Comment 10 Makrea 2014-04-01 15:06:37 UTC
Hi Julien, see the new comments on https://www.libreoffice.org/bugzilla/show_bug.cgi?id=76830

The error is back and using procdump and WinDbg didn't worked well. Maybe you can help me.
Comment 11 Julien Nabet 2014-04-10 18:12:03 UTC
cloclo: any update? Do you reproduce this if the whole LO package is installed?
Makrea: like fdo#69004, it could be an extension problem (so rename your LO directory profile to give it a try).
Comment 12 Makrea 2014-04-11 10:19:08 UTC
Didn't solved the problem.
Also having the error on documents opened without being read-only.

The error only happens when closing LibreOffice Writer using X closing button of the window.
When doing File -> Exit LibreOffice the error doesn't appear.

Something must be done differently between the two!
Comment 13 Julien Nabet 2014-04-11 11:12:20 UTC
Makrea: it could be useful we keep on your case only in fdo#76830 for the moment.
Indeed, perhaps you're in a specific case with PowerBuilder use.
For this one, let's wait cloclos's answer for the moment.
Comment 14 QA Administrators 2014-11-02 16:46:37 UTC
Dear Bug Submitter,

This bug has been in NEEDINFO status with no change for at least 6 months. Please provide the requested information as soon as possible and mark the bug as UNCONFIRMED. Due to regular bug tracker maintenance, if the bug is still in NEEDINFO status with no change in 30 days the QA team will close the bug as INVALID due to lack of needed information.

For more information about our NEEDINFO policy please read the wiki located here: 
https://wiki.documentfoundation.org/QA/FDO/NEEDINFO

If you have already provided the requested information, please mark the bug as UNCONFIRMED so that the QA team knows that the bug is ready to be confirmed.


Thank you for helping us make LibreOffice even better for everyone!


Warm Regards,
QA Team
Comment 15 bugzilla2 2014-11-27 10:52:22 UTC
I had the exact same error two times on shutting down my pc so far. Actually this stopped my pc from shuting down, when the errormessage opens. I never had that problem with versions prior 4.4. Now I'm testing the 4.4 beta 1, and that problem showed very early. Sadly its not reproducible, I just tried to shutdown the pc, or exit LibO only, without the error appear.

This was the bugreport, that was most similar to my experience, so I added a comment here instead of opening a new bug.
Comment 16 bugzilla2 2014-11-30 12:33:12 UTC
I had the problem again the last two nights.

I was doing some test trying to get a traceback from another user (User A logging off, User B having WinDbg connected to soffice.bin) now, but that doesn't seem to work (debugee doesn't stop running). I'll try again at night.

I already tried adjusting the clock, and having it set short before midnight then passing midnight with LibO running, but I cant reproduce it. It seems to only happen at night, after some hours of uptime.

Anybody an idea, how to get a traceback from an process, when the user that started the process is logging off? I also tried "procdump soffice.bin -e -h -t" without success.
Comment 17 bugzilla2 2014-12-01 10:14:31 UTC
Created attachment 110291 [details]
WinDbg Logfile with errorcode but without backtrace
Comment 18 bugzilla2 2014-12-01 10:25:11 UTC
Last night the error happened again. Seems like its quiet reliable to happen at night. I guess its due to some kind of "sleepmodes" inside LibO? Since it not seems to be a date-change-issue that it happens only at night, I guess its due to lots of time doing nothing at night, before I turn the pc off.

As told before, I tried to capture a backtrace from another user, but as expected that didn't workout. If nobody else is coming up with an better idea how to get a backtrace from a process started by a user that is logging off, I'll try to simply exit quickstarter manually tonight (with WinDbg connected of course). Hopefully the issues comes up that way too, otherwise one day is lost again :/

Or does anybody know, how to send the same "we are going down" signal to LibO, as if the user would log off?

I set the status of the bug back to unconfirmed, as told by QA Administrators in a previous comment. Hopefully that way the bug gets a bit more attention, as I feel a bit lonely here ;)
Comment 19 bugzilla2 2014-12-01 23:37:37 UTC
Tried to capture a trace directly from the current user, with only exiting the quickstarter -> no error :/

Again: Anybody an idea, how to:

a: capture a backtrace from an process, when the user who started the process is logging of?

or

b: send the "the user is logging off" signal to LibO without actually logging off?
Comment 20 Julien Nabet 2014-12-02 06:38:29 UTC
bugzilla2:
- did you rename your LO directory profile (see https://wiki.documentfoundation.org/UserProfile#Windows) to have a clean env?
- do you confirm you've got Java 32 bits?

Tor: I'm not accustomed at all for retrieving a bt on Windows env, it seems the https://wiki.documentfoundation.org/QA/BugReport/Debug_Information#Windows:_How_to_get_a_backtrace process doesn't work for this case, any thoughts?
Comment 21 bugzilla2 2014-12-02 10:41:09 UTC
(In reply to Julien Nabet from comment #20)
> bugzilla2:
> - did you rename your LO directory profile (see
> https://wiki.documentfoundation.org/UserProfile#Windows) to have a clean env?
> - do you confirm you've got Java 32 bits?

Yes: LibO-Install- and Profile-Directories were cleaned before installing the 4.4 beta.
Yes: current Java 32Bit is installed (same setup worked well with 4.3.4 and earlier)
Comment 22 Maxim Monastirsky 2014-12-02 11:46:23 UTC
(In reply to Julien Nabet from comment #20)
> Tor: I'm not accustomed at all for retrieving a bt on Windows env, it seems
> the
> https://wiki.documentfoundation.org/QA/BugReport/Debug_Information#Windows:
> _How_to_get_a_backtrace process doesn't work for this case, any thoughts?
Could it be that a release build, even with debug symbols, doesn't allow breaking to the debugger from this error message, and just quits?

@bugzilla2: Anyway, 4.4beta is just a development snapshot, and it doesn't make sense to continue testing it. Instead I'll suggest you to try a fresh snapshot from http://dev-builds.libreoffice.org/daily/, to see whether that bug was sorted there.
Comment 23 bugzilla2 2014-12-02 12:09:18 UTC
(In reply to Maxim Monastirsky from comment #22)
> Could it be that a release build, even with debug symbols, doesn't allow
> breaking to the debugger from this error message, and just quits?

If I'm running WinDbg from the same user, that started the process, I can connect successfully. So I don't think its a general problem with the build.

Anyway, I found a tool to send the "shutdown" signal to applications:
http://stackoverflow.com/questions/520910/how-to-simulate-windows-shutdown-for-debugging
I'll try that tonight.


> @bugzilla2: Anyway, 4.4beta is just a development snapshot, and it doesn't
> make sense to continue testing it. Instead I'll suggest you to try a fresh
> snapshot from http://dev-builds.libreoffice.org/daily/, to see whether that
> bug was sorted there.

I wanna give the tool mentioned above a try this night, and then upgrade to current daily tomorrow.
Comment 24 bugzilla2 2014-12-04 10:59:55 UTC
Error didn't come up with official beta 1 and the Microsoft Tool to simmulate Shutdowns :/

As requested, upgraded to current daily, but error is still there. Will try the Shutdown-simmulation with WinDbg connected to current daily again this night.
Still open for alternate methods to get a backtrace from soffice.bin on Shutdown ;)

Btw: Has anobody of the guys who can "interprete" a backtrace already had an eye on the WinDbg-Log I already uploadet? Even if it doesn't contain a real backtrace - maybe it gives some clue's?
Comment 25 Stephan Bergmann 2014-12-04 11:01:41 UTC
(In reply to bugzilla2 from comment #24)
> Btw: Has anobody of the guys who can "interprete" a backtrace already had an
> eye on the WinDbg-Log I already uploadet? Even if it doesn't contain a real
> backtrace - maybe it gives some clue's?

It's unfortunately completely useless.
Comment 26 Jean-Philippe MENGUAL 2014-12-07 16:34:46 UTC
Hi,

This bug appears especially in Windows 8.1 and is still presemt with LibreOffice 4.3.4. Is there a workaround?

Regards,
Comment 27 bugzilla2 2014-12-08 13:45:56 UTC
(In reply to Jean-Philippe MENGUAL from comment #26)
> This bug appears especially in Windows 8.1 and is still presemt with
> LibreOffice 4.3.4. Is there a workaround?

When exactly does this error show up on your system? Can you reproduce it? For me its only on Shutdown/Logoff, but I never had this with 4.3.4 or an earlier build. Only 4.4.x series shows that behaviour on my system.
Comment 28 bugzilla2 2014-12-09 14:52:25 UTC
I finally was able to get a backtrace! At least I hope it's a working one, because due to the problems I already wrote so much about, I only could attach the debugger AFTER the (aborted) Shutdown.

I never thought I could get a backtrace AFTER the error appeared, but after I was back on the desktop, I was able to connect WinDbg to soffice.bin without an issue, and get a backtrace AND automated exeption analysis (both in the attached file). Before that, I captured a dump of soffice.bin via taskmanager. If a developer needs that 416MB file (129MB zipped) please pm me.

I hope the new WinDbg-Logfile contains the needed information to analyse the error...
Comment 29 bugzilla2 2014-12-09 14:55:58 UTC
Created attachment 110632 [details]
WinDbg Log with (hopefully valid) backtrace and analysis
Comment 30 Stephan Bergmann 2014-12-09 15:07:36 UTC
(In reply to bugzilla2 from comment #29)
> WinDbg Log with (hopefully valid) backtrace and analysis

At least the top part of the stack appears to show accurate enough symbols to actually be useful, repeating that here for easier reference:

> 00000000`00a2f188 00000000`6ffa326c msvcr110!abort+0x28
> 00000000`00a2f18c 00000000`6ed2afd3 svllo!SfxItemPool::Put+0x1a3
> 00000000`00a2f1dc 00000000`6ed41035 svllo!SfxItemSet::Put+0x145
> 00000000`00a2f200 00000000`6ed263b2 svllo!SfxItemSet::Put+0x12
> 00000000`00a2f214 00000000`5622ae81 swlo!SwDoc::SetDefault+0xd1
> 00000000`00a2f2e8 00000000`5622b2be swlo!SwDoc::SetDefault+0x6e
> 00000000`00a2f328 00000000`5624195b swlo!SwDoc::~SwDoc+0x8b
> 00000000`00a2f3c0 00000000`56242be2 swlo!SwLineNumberInfo::~SwLineNumberInfo+0x4d2
> 00000000`00a2f3d0 00000000`5644ea7c swlo!cppu::WeakImplHelper1<com::sun::star::xml::sax::XFastContextHandler>::release+0x1f2c
> 00000000`00a2f3f8 00000000`5644edbb swlo!cppu::WeakImplHelper1<com::sun::star::xml::sax::XFastContextHandler>::release+0x226b
> 00000000`00a2f404 00000000`56449e13 swlo!sw3io_ConvertFromOldField+0x3e3
> 00000000`00a2f428 00000000`55f3d49d editenglo!SvxAutoCorrCfg::SetAutoCorrect+0x3d
> 00000000`00a2f43c 00000000`567c5059 swlo!SwModule::~SwModule+0x79
> 00000000`00a2f468 00000000`567c51e2 swlo!SwModule::~SwModule+0x202
> 00000000`00a2f478 00000000`6df8aef9 sfxlo!SfxModule::DestroyModules_Impl+0x39
Comment 31 Jean-Philippe MENGUAL 2014-12-10 02:52:06 UTC
H(In reply to bugzilla2 from comment #28)

Hi,

The message appears when I exit. I save, exit, then the message pop-ups, I do OK, then "the app stopped working".

Regards

> I finally was able to get a backtrace! At least I hope it's a working one,
> because due to the problems I already wrote so much about, I only could
> attach the debugger AFTER the (aborted) Shutdown.
> 
> I never thought I could get a backtrace AFTER the error appeared, but after
> I was back on the desktop, I was able to connect WinDbg to soffice.bin
> without an issue, and get a backtrace AND automated exeption analysis (both
> in the attached file). Before that, I captured a dump of soffice.bin via
> taskmanager. If a developer needs that 416MB file (129MB zipped) please pm
> me.
> 
> I hope the new WinDbg-Logfile contains the needed information to analyse the
> error...
Comment 32 bugzilla2 2014-12-10 09:17:19 UTC
(In reply to Jean-Philippe MENGUAL from comment #31)
> Hi,
> The message appears when I exit. I save, exit, then the message pop-ups, I
> do OK, then "the app stopped working".
> Regards
> 
Did you follow Julien Nabet's instructions from comment 20?
Clean Install/Profile and current 32Bit Java?
Comment 33 bugzilla2 2014-12-18 12:00:50 UTC
Seems like the bug (at least the one I was suffering from) is gone in 4.4.0 Beta 2. No more errors on Shutdown/Logoff so far.
Will change to 4.3.5 testing now, and back to 4.4 when 4.3.5 is released...
Comment 34 Michael Stahl (CIB) 2015-04-07 14:14:30 UTC
stack in comment #30 is the same as bug 86494

*** This bug has been marked as a duplicate of bug 86494 ***