Bug Hunting Session
Bug 74458 - UI Insert Special Character selected item changes with keyboard navigation - but then OK inserts character that was first activated by a mouse click
Summary: UI Insert Special Character selected item changes with keyboard navigation - ...
Status: RESOLVED NOTABUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
3.5.7.2 release
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-02-03 17:02 UTC by Cor Nouws
Modified: 2015-05-03 10:29 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Cor Nouws 2014-02-03 17:02:33 UTC
Writer
Instert > Special Character
Click in list to get focus there
Move focus with keyboard two lines down
Enter for OK
 > Character that has been clicked upon is inserted
Comment 1 Cor Nouws 2014-02-03 17:06:58 UTC
hmm already a problem in 3.5.7 - stop searching in older versions..
Comment 2 Jean-Baptiste Faure 2014-02-05 05:40:22 UTC
IMHO it is not a bug but a feature ©  ;-)

Each time you click a special character you add it to the list at the bottom of the dialog. This dialog worked that way already in the OOo time.

Best regards. JBF
Comment 3 Joel Madero 2015-05-02 15:41:15 UTC
** Please read this message in its entirety before responding **

To make sure we're focusing on the bugs that affect our users today, LibreOffice QA is asking bug reporters and confirmers to retest open, confirmed bugs which have not been touched for over a year.

There have been thousands of bug fixes and commits since anyone checked on this bug report. During that time, it's possible that the bug has been fixed, or the details of the problem have changed. We'd really appreciate your help in getting confirmation that the bug is still present.

If you have time, please do the following:

   Test to see if the bug is still present on a currently supported version of LibreOffice (4.4.2 or later)
   https://www.libreoffice.org/download/

   If the bug is present, please leave a comment that includes the version of LibreOffice and your operating system, and any changes you see in the bug behavior
 
 If the bug is NOT present, please set the bug's Status field to RESOLVED-WORKSFORME and leave a short comment that includes your version of LibreOffice and Operating System

Please DO NOT

   Update the version field
   Reply via email (please reply directly on the bug tracker)
   Set the bug's Status field to RESOLVED - FIXED (this status has a particular meaning that is not appropriate in this case)


If you want to do more to help you can test to see if your issue is a REGRESSION. To do so: 1. Download and install oldest version of LibreOffice (usually 3.3 unless your bug pertains to a feature added after 3.3)

http://downloadarchive.documentfoundation.org/libreoffice/old/

2. Test your bug 3. Leave a comment with your results. 4a. If the bug was present with 3.3 - set version to "inherited from OOo"; 4b. If the bug was not present in 3.3 - add "regression" to keyword


Feel free to come ask questions or to say hello in our QA chat: http://webchat.freenode.net/?channels=libreoffice-qa

Thank you for your help!

-- The LibreOffice QA Team This NEW Message was generated on: 2015-05-02
Comment 4 Cor Nouws 2015-05-03 10:29:22 UTC
(In reply to Jean-Baptiste Faure from comment #2)
> IMHO it is not a bug but a feature ©  ;-)
> 
> Each time you click a special character you add it to the list at the bottom
> of the dialog. This dialog worked that way already in the OOo time.
> 
> Best regards. JBF

Thanks. SO the proper workflow is
tab to the list, arrows to select the character, space to add it to the input line and Enter to confirm & close. OK :) !

Thanks Jean-Baptiste,
Cor