Bug 74489 - No space between multiline heading in chapter name field
Summary: No space between multiline heading in chapter name field
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: Other All
: medium normal
Assignee: Andras Timar
URL:
Whiteboard: target:4.3.0 target:4.2.1
Keywords:
Depends on:
Blocks:
 
Reported: 2014-02-04 06:10 UTC by safa alfulaij
Modified: 2014-02-06 15:27 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
an odt file contains the bug (15.28 KB, application/vnd.oasis.opendocument.text)
2014-02-04 06:10 UTC, safa alfulaij
Details
Where is the bug (20.74 KB, image/png)
2014-02-04 06:11 UTC, safa alfulaij
Details
an odt file contains the bug (14.00 KB, application/vnd.oasis.opendocument.text)
2014-02-04 09:08 UTC, libreoffice user
Details

Note You need to log in before you can comment on or make changes to this bug.
Description safa alfulaij 2014-02-04 06:10:26 UTC
Created attachment 93336 [details]
an odt file contains the bug

When I apply a heading style to a multiline heading, And add a chapter name field, I don't see any space between the two line headings.
Comment 1 safa alfulaij 2014-02-04 06:11:07 UTC
Created attachment 93337 [details]
Where is the bug
Comment 2 libreoffice user 2014-02-04 09:08:56 UTC
Created attachment 93348 [details]
an odt file contains the bug

I have uploaded the .odt file, because the original one has been marked as "text/plain"
Comment 3 libreoffice user 2014-02-04 09:09:51 UTC
I can confirm this bug, there is a space between the two lines in table of contents, and in bookmarks when exporting to pdf. but not in the header.
Comment 4 Cor Nouws 2014-02-04 09:38:28 UTC
Hi Safa,

thanks for the issue. I can confirm this.
It's already like this since OOo...
(So there's possibly already another issue for it too..)
best,
Cor
Comment 5 Commit Notification 2014-02-04 19:07:46 UTC
Andras Timar committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=57f10ec58c5be97ca7f66850c53a0d04c9885942

fdo#74489 replace '\n' to ' ' in fields (e.g. multiline headings)



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 6 Cor Nouws 2014-02-04 19:37:39 UTC
(In reply to comment #5)
> Andras Timar committed a patch related to this issue.

Wow.. top ! :)
Comment 7 Commit Notification 2014-02-06 15:20:24 UTC
Andras Timar committed a patch related to this issue.
It has been pushed to "libreoffice-4-2":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=107241c5e2a7b08bab676732ed0185fa843df025&h=libreoffice-4-2

fdo#74489 replace '\n' to ' ' in fields (e.g. multiline headings)


It will be available in LibreOffice 4.2.1.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 8 Commit Notification 2014-02-06 15:20:54 UTC
Andras Timar committed a patch related to this issue.
It has been pushed to "libreoffice-4-2":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=107241c5e2a7b08bab676732ed0185fa843df025&h=libreoffice-4-2

fdo#74489 replace '\n' to ' ' in fields (e.g. multiline headings)


It will be available in LibreOffice 4.2.1.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.