Bug Hunting Session
Bug 74504 - [Template Manager] Folders can't be removed consistently - remove button hides now and then
Summary: [Template Manager] Folders can't be removed consistently - remove button hide...
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
4.0.2.2 release
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-02-04 13:17 UTC by Cor Nouws
Modified: 2015-05-03 10:14 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
Template manager window (39.54 KB, image/png)
2014-02-05 11:53 UTC, Dominique Boutry
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Cor Nouws 2014-02-04 13:17:19 UTC
Open template manager
Click New folder "foo folder" OK
Select folder
 > Button Remove is not available
Select different folder
 > Button Remove ís available ..

Fiddle around a bit, close, open, select this and that folder ...
Mostly the Remove button is there, sometimes it isn't

When I have my "foo folder" displayed as the only one, Remove seems to be available consistently ..
Comment 1 Dominique Boutry 2014-02-05 11:53:41 UTC
Created attachment 93441 [details]
Template manager window

LibO 4.2.0.4 on Win7, freshly donwloaded : I can't manage to get a "new folder" command...
Comment 2 Jorendc 2014-02-06 16:08:15 UTC
I can reproduce this behavior, tested using LibreOffice 4.1.4.2.

(In reply to comment #1)
> LibO 4.2.0.4 on Win7, freshly downloaded : I can't manage to get a "new
> folder" command...

@Dominique Boutry: that's due the fact you're not in the Root folder (you're currently in 'Presentation Backgrounds'. Try to click on 'All templates'.
Comment 3 Jorendc 2014-02-06 18:32:05 UTC
@Cor: isn't this bug a dupe of Bug 70692 ?
Looks like you have to click twice in some situations, before continuing.

Kind regards,
Joren
Comment 4 Cor Nouws 2014-02-07 13:33:52 UTC
(In reply to comment #3)
> @Cor: isn't this bug a dupe of Bug 70692 ?
> Looks like you have to click twice in some situations, before continuing.


Well, it does give the pop-up, asking for confirmation...
But definitely, the code lost it's way to the right view ;)
Comment 5 Joel Madero 2015-05-02 15:41:09 UTC
** Please read this message in its entirety before responding **

To make sure we're focusing on the bugs that affect our users today, LibreOffice QA is asking bug reporters and confirmers to retest open, confirmed bugs which have not been touched for over a year.

There have been thousands of bug fixes and commits since anyone checked on this bug report. During that time, it's possible that the bug has been fixed, or the details of the problem have changed. We'd really appreciate your help in getting confirmation that the bug is still present.

If you have time, please do the following:

   Test to see if the bug is still present on a currently supported version of LibreOffice (4.4.2 or later)
   https://www.libreoffice.org/download/

   If the bug is present, please leave a comment that includes the version of LibreOffice and your operating system, and any changes you see in the bug behavior
 
 If the bug is NOT present, please set the bug's Status field to RESOLVED-WORKSFORME and leave a short comment that includes your version of LibreOffice and Operating System

Please DO NOT

   Update the version field
   Reply via email (please reply directly on the bug tracker)
   Set the bug's Status field to RESOLVED - FIXED (this status has a particular meaning that is not appropriate in this case)


If you want to do more to help you can test to see if your issue is a REGRESSION. To do so: 1. Download and install oldest version of LibreOffice (usually 3.3 unless your bug pertains to a feature added after 3.3)

http://downloadarchive.documentfoundation.org/libreoffice/old/

2. Test your bug 3. Leave a comment with your results. 4a. If the bug was present with 3.3 - set version to "inherited from OOo"; 4b. If the bug was not present in 3.3 - add "regression" to keyword


Feel free to come ask questions or to say hello in our QA chat: http://webchat.freenode.net/?channels=libreoffice-qa

Thank you for your help!

-- The LibreOffice QA Team This NEW Message was generated on: 2015-05-02
Comment 6 Cor Nouws 2015-05-03 10:14:24 UTC
Currently I only reproduce that after creating a new folder, another has to be selected first, before Delete becomes available for the new folder.
That's a minor minor issue, so I close this as WorksForMe