Download it now!
Bug 74506 - [Template Manager] Saving as template fails without a warning when a folder is selected but not opened
Summary: [Template Manager] Saving as template fails without a warning when a folder i...
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
4.0.2.2 release
Hardware: Other All
: medium normal
Assignee: Jorendc
URL:
Whiteboard: target:4.3.0 target:4.2.1
Keywords:
: 74542 (view as bug list)
Depends on:
Blocks:
 
Reported: 2014-02-04 14:11 UTC by Cor Nouws
Modified: 2014-03-07 09:27 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Cor Nouws 2014-02-04 14:11:34 UTC
writer, type 'la la la'
File > Template > Save as template
Click on a folder
CLick Save
'test save', OK

( Close window - will be solved with other issue)

Ctrl+Shft+N (open template manager)
Open folder that was selected 
  > no new template

One would expect that either the button Save is disabled if no folder is open (better way) or that there is a warning about what is going on...
Comment 1 Cor Nouws 2014-02-05 09:16:47 UTC
*** Bug 74542 has been marked as a duplicate of this bug. ***
Comment 2 Jorendc 2014-02-06 16:08:56 UTC
https://gerrit.libreoffice.org/#/c/7902/ patch under review
Comment 3 Commit Notification 2014-02-07 15:09:44 UTC
Joren De Cuyper committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=a411bf38da3668094698c06c8424aa9d68c85702

fdo#74506 fdo#74291 -Template manager-store selection before calling dialog



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 4 Commit Notification 2014-02-07 20:16:18 UTC
Joren De Cuyper committed a patch related to this issue.
It has been pushed to "libreoffice-4-2":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=57df90332e823d501744a87c8c94ad51ed5aead6&h=libreoffice-4-2

fdo#74506 fdo#74291 -Template manager-store selection before calling dialog


It will be available in LibreOffice 4.2.1.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 5 Jorendc 2014-02-10 10:49:13 UTC
Should be fixed
Comment 6 Commit Notification 2014-03-07 09:27:56 UTC
Zolnai Tamas committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=fa173ce679235e3a8378ccffcff5d767f97375b2

Revert "fdo#74506 fdo#74291 -Template manager-store selection before calling dialog"



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.