Bug 74816 - Writer stops responding if an online image in the document cannot be loaded
Summary: Writer stops responding if an online image in the document cannot be loaded
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.1.3.2 release
Hardware: All Linux (All)
: medium normal
Assignee: Not Assigned
URL: https://bugs.launchpad.net/ubuntu/+so...
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-02-11 00:17 UTC by Alberto Salvia Novella
Modified: 2014-05-09 00:28 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Alberto Salvia Novella 2014-02-11 00:17:53 UTC
****************
HOW TO REPRODUCE
****************

1. From your web browser, copy the "http://cdn.acidcow.com/pics/20110408/smiles_21.jpg" image.
2. Paste the image into a LibreOffice Writer document.

******************
EXPECTED BEHAVIOUR
******************

- The image to be pasted and shown.

**************
REAL BEHAVIOUR
**************

- LibreOffice Writer shows a square with the image's web link into it.
- If you click or drag the square, LibreOffice Writer hangs.

***********
WORK-AROUND
***********

- If you see that the image is not being loaded, to undo the paste before doing anything else.

**************
TECHNICAL INFO
**************

ProblemType: Bug
DistroRelease: Ubuntu 13.10
Package: libreoffice-writer 1:4.1.3-0ubuntu1
ProcVersionSignature: Ubuntu 3.11.0-14.21-generic 3.11.7
Uname: Linux 3.11.0-14-generic x86_64
ApportVersion: 2.12.5-0ubuntu2.2
Architecture: amd64
Date: Tue Feb 11 00:50:02 2014
InstallationDate: Installed on 2013-05-21 (265 days ago)
InstallationMedia: Ubuntu 13.04 "Raring Ringtail" - Release amd64 (20130424)
MarkForUpload: True
SourcePackage: libreoffice
UpgradeStatus: Upgraded to saucy on 2013-10-18 (115 days ago)
Comment 1 Christopher M. Penalver 2014-02-15 11:14:20 UTC
Not reproducible in MASTER:
Microsoft Windows Vista Business x86 6.0.6002 Service Pack 2 Build 6002
Version: 4.3.0.0.alpha0+
Build ID: ecf22894f522374cbdb8196d3bdef88e2fba7af9
TinderBox: Win-x86@47-TDF, Branch:MASTER, Time: 2014-02-15_01:01:54
Comment 2 sophie 2014-02-17 16:56:11 UTC
Hi, under Debian 6 and LibreOffice 4.1.5.3, it takes a long time (almost 5 mn) to display the photo and if during this time you try to do something else, Writer is unresponsive. Did you wait until the picture is displayed? Sophie
Comment 3 Alberto Salvia Novella 2014-02-17 17:24:26 UTC
After 2 minutes the image is shown and LibreOffice Writer responds again.
Comment 4 tommy27 2014-05-03 13:05:36 UTC
I set status to NEW since issue has been confirmed in comment 2

however I do not reproduce bug under Win7x64 using LibO 4.2.3.3

I can open the website in IE 11 or Opera 12.16, then copy the image and immediately paste it into a Writer document with no freeze or hanging.

do you still see this issue with 4.2.x releases as well?
Comment 5 Christopher M. Penalver 2014-05-09 00:28:31 UTC
Not reproducible in:
lsb_release -rd
Description: Ubuntu 14.04 LTS
Release: 14.04

apt-cache policy libreoffice-writer
libreoffice-writer:
  Installed: 1:4.2.3~rc3-0ubuntu2
  Candidate: 1:4.2.3~rc3-0ubuntu2
  Version table:
 *** 1:4.2.3~rc3-0ubuntu2 0
        500 http://us.archive.ubuntu.com/ubuntu/ trusty/main amd64 Packages
        100 /var/lib/dpkg/status