Bug Hunting Session
Bug 74880 - [Memory leak] LibreOffice crashing when importing data from 8+ ods files, but doesn't crash on same xls files
Summary: [Memory leak] LibreOffice crashing when importing data from 8+ ods files, but...
Status: RESOLVED INSUFFICIENTDATA
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.0.6.2 release
Hardware: Other Windows (All)
: high critical
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: preBibisect, regression
Depends on:
Blocks:
 
Reported: 2014-02-12 09:06 UTC by Mikeyy - L10n HR
Modified: 2017-05-02 11:34 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
File which contains macro which will pull data from all other files. (13.92 KB, application/vnd.oasis.opendocument.spreadsheet)
2014-02-12 09:06 UTC, Mikeyy - L10n HR
Details
how the error looks in LibO 4.2 before it crashes (109.58 KB, image/jpeg)
2014-06-02 20:04 UTC, Yousuf Philips (jay) (retired)
Details
Error (101.19 KB, image/png)
2015-02-14 13:12 UTC, Mikeyy - L10n HR
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Mikeyy - L10n HR 2014-02-12 09:06:50 UTC
Created attachment 93920 [details]
File which contains macro which will pull data from all other files.

To reproduce:

1. Download ZIP from this link: https://copy.com/jfGZSp3GP6Crmzsr
2. Extract it and you will find 2 folders, TEST-ods and TEST-xls
3. Rename TEST-ods to TEST and save it to root of C: (C:/TEST)
4. Download and run TEST PULL FILE.ods (you have to enable macro).
5. Run macro (Tools - Macro - Run macro and select that file macro).

Expected:
Macro will generate filenames of all files in C:/TEST directory and formulas in columns B and C will pull data from those files.

Actual result:
LibreOffice crashes on 9th file. My guess is, memory leak.

Setup:
Win7 64bit
Intel i3 2,75ghz , 3GB ram, LO 4.1.5 (or 4.1.4)
Tested also with portable version of 4.2 and it also crashes.


Now do everything from start, but use files from TEST-xls folder. Those files are 100% identical, except they were saved as xls.
TEST PULL FILE.ods will pull data from all 15 files without problems.

I gave you only 15 test files, which are 100% indentical except filename, but I usually do this with 160+ files. With xls it passes, but with ods it crashes.
Comment 1 Mikeyy - L10n HR 2014-02-12 09:10:12 UTC
I should mention that macro pulls file names ONLY from C:/TEST.
If you want to change this to something else so you can test on linux, you should edit macro and formulas in B and C columns to pull from different location.
Comment 2 Yousuf Philips (jay) (retired) 2014-06-02 19:43:17 UTC
Confirmed the crash on Windows 7 with 4.0.6, 4.1.6, 4.2.4, and 4.2.6. It is fine in 3.5.7, 3.6.7, 4.4.
Comment 3 Yousuf Philips (jay) (retired) 2014-06-02 20:04:43 UTC
Created attachment 100331 [details]
how the error looks in LibO 4.2 before it crashes
Comment 4 Joel Madero 2014-06-09 01:37:30 UTC
Is this bug reproducible in Linux - if not bibisect is not possible and whiteboard status should be removed
Comment 5 Yousuf Philips (jay) (retired) 2014-06-09 13:37:50 UTC
Yes it wasnt possible to reproduce it in linux in 4.1.6 or 4.2.4, so bibisect was removed.
Comment 6 Björn Michaelsen 2014-08-21 12:21:15 UTC Comment hidden (obsolete)
Comment 7 Mikeyy - L10n HR 2015-02-14 11:43:22 UTC
I was testing again on win 8.1, i5 processor, 8GB of RAM with 180 files on LibreOffice 4.4.1.1
It finishes process, but when I mark columns A:C and press CTRL+C (copy) LibreOffice hangs and crashes. Tried 3 times, 3 times it crashed.
Comment 8 Mikeyy - L10n HR 2015-02-14 13:12:24 UTC
Created attachment 113377 [details]
Error

I marked B1. Scrooled down to C180 (which took some time), then SHIFT+click on C180. Then CTRL+C for copy.

All fine.

Then I pressed New spredsheet icon (first in toolbar) and bam... this error appears.
Sometimes it appears while I copy, sometimes when I try to create new spreadsheet to copy result to.

---------------------------
LibreOffice 4.4 - Fatal Error
---------------------------
osl::Thread::create failed
---------------------------
Comment 9 Robinson Tryon (qubit) 2015-12-10 01:26:27 UTC Comment hidden (obsolete)
Comment 10 Caolán McNamara 2016-08-19 14:40:33 UTC
I went to look at this problem today, but the original reproducer zip seems to be gone. Is there another copy of this anywhere, or another route to reproduce ?
Comment 11 Mikeyy - L10n HR 2016-08-19 14:58:58 UTC
(In reply to Caolán McNamara from comment #10)
> I went to look at this problem today, but the original reproducer zip seems
> to be gone. Is there another copy of this anywhere, or another route to
> reproduce ?

Luckily, I keept ZIP stored somewhere.
Won't share link here since it's my private cloud, but sent you copy via e-mail.
Comment 12 Xisco Faulí 2016-09-13 10:57:08 UTC
This regression was introduced before branch 4.4, thus it can't be bibisected with the current bibisect repositories. Changing keyword 'notBibisectable' to 'preBibisect'
Comment 13 QA Administrators 2017-03-28 08:18:10 UTC Comment hidden (obsolete)
Comment 14 QA Administrators 2017-05-02 11:34:30 UTC Comment hidden (obsolete)