Bug 74922 - FILEOPEN: When inserting images in Writer, the type of the image anchor and linking/embedding is not remembered
Summary: FILEOPEN: When inserting images in Writer, the type of the image anchor and l...
Status: RESOLVED DUPLICATE of bug 61358
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
4.1.5.1 rc
Hardware: Other All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2014-02-13 10:20 UTC by rbruenner
Modified: 2014-12-16 20:28 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description rbruenner 2014-02-13 10:20:57 UTC
Problem description: When you insert an image into Writer using "Insert -> Image -> From File" the image is always entered anchored to the paragraph. If you prefer, for instance, having the image treated as a character, you always have to remember to set this explicitly. You also have to always remember to check the "Link" checkbox if you do not want to save a copy of the image on disk in the document as well.

Steps to reproduce:
1. Choose "Insert -> Image -> From File" command
2. Select an image file
3. Check the Link checkbox if you only want to store a link
4. The image will be inserted with an anchor at the paragraph
5. Right click the image and invoke the properties dialogue
6. On the Type tab, select "As character", for instance, if you wish a different behaviour

Current behavior:
You have to always remember to click the "Link" checkbox and/or to select the anchoring for each and every image you are going to insert. This may be a minor annoyance for the anchoring, but a rather big one if you accidentally forgot to insert some files as a link and to find the respective files and correct your fault.

Expected behavior:
The software should remember the last settings the user has chosen and use it for all subsequent images inserted into a document. Both settings are typically the same for all pictures in a document and in many cases, users prefer either setting in all their documents.

              
Operating System: All
Version: 4.1.5.1 rc
Comment 1 sophie 2014-02-13 13:09:40 UTC
I find it safe to not have the setting remembered, most of the time users embed pictures instead of linking them. But that could be an option that you could set explicitly in Writer options. 
Set it as New - Sophie
Comment 2 Stanislav Horacek 2014-12-10 19:08:54 UTC
The link issue is described in bug 61358.

Type of anchor is something which should be handled by frame styles. It is possible to select a frame style in the Insert Image dialog, but anchoring cannot be chosen in frame styles currently - see bug 58890.
(Actually, it works for me somehow, for some styles I get pictures anchored to paragraph and for another anchored to page.)

So I would suggest to close this bug because its two issues are already covered.
Comment 3 Stanislav Horacek 2014-12-16 20:28:49 UTC
It seems there are no objections, so I'm closing this as duplicated of bug 61358 and bug 58890.

*** This bug has been marked as a duplicate of bug 61358 ***