Bug 75175 - UI: Options get cut off because window is too small
Summary: UI: Options get cut off because window is too small
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
4.2.0.4 release
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords: possibleRegression
Depends on:
Blocks:
 
Reported: 2014-02-18 21:03 UTC by Jeff
Modified: 2015-12-15 10:55 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Screenshots of windows where options get cut off (42.76 KB, image/png)
2014-02-18 21:03 UTC, Jeff
Details
Screenshots of windows where options get cut off (45.51 KB, image/png)
2014-02-18 21:04 UTC, Jeff
Details
PDF showing Option dialogs with cut off text lines. (246.42 KB, application/pdf)
2014-07-21 11:02 UTC, Benny
Details
Testing of themes, icons etc to see if anything changes. (680.46 KB, application/pdf)
2014-07-22 12:55 UTC, Benny
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jeff 2014-02-18 21:03:41 UTC
Created attachment 94309 [details]
Screenshots of windows where options get cut off

Problem description: Options that don't fit into the provided window space of the Options window are inaccessible and the text is partially cut off along the bottom of the window frame.

Steps to reproduce:
1. Open LibreOffice
2. Click Tools, then Options
3. Choose Print or General (those are the two where I can clearly see options getting cut off)

The options should be fully visible.


Version: 4.2.1.1
Build ID: 420m0(Build:1)
Operating System: Ubuntu
Version: 4.2.0.4 release
Last worked in: 4.1.5.1 rc
Comment 1 Jeff 2014-02-18 21:04:18 UTC
Created attachment 94310 [details]
Screenshots of windows where options get cut off
Comment 2 tommy27 2014-02-20 05:53:18 UTC
tested under Win7x64 with 4.2.0.4
options menus are not cut off
probably a Linux specific issue

> Version: 4.2.1.1
> Build ID: 420m0(Build:1)
> Operating System: Ubuntu
> Version: 4.2.0.4 release

are you reporting the bug against 4.2.1.1 or 4.2.0.4 or both?
Comment 3 tommy27 2014-02-20 06:00:31 UTC
see also Bug 73851
similar issue reproduced in Linux and Windows in 4.2.0.4 but in different Options dialogs than those of your screenshots.
Comment 4 Jeff 2014-02-20 08:19:16 UTC
(In reply to comment #2)
> tested under Win7x64 with 4.2.0.4
> options menus are not cut off
> probably a Linux specific issue
> 
> > Version: 4.2.1.1
> > Build ID: 420m0(Build:1)
> > Operating System: Ubuntu
> > Version: 4.2.0.4 release
> 
> are you reporting the bug against 4.2.1.1 or 4.2.0.4 or both?

I'm not sure why two versions were listed, but to clarify, the current installed version I have is 4.2.1.1 and that's what I'm reporting this bug from.

However, I've noticied this issue since I upgraded, so any version of 4.2.x that I had installed was affected.
Comment 5 Jean-Baptiste Faure 2014-04-19 19:20:24 UTC
Hi Jeff,

Please, what is the default font and what is the scale factor for the fonts you are using in Ubuntu?
Are you using the system font for the UI in LibreOffice (menu Tools > Options > LibreOffice > View)?

Best regards. JBF
Comment 6 Jeff 2014-04-22 02:12:58 UTC
(In reply to comment #5)
> Hi Jeff,
> 
> Please, what is the default font and what is the scale factor for the fonts
> you are using in Ubuntu?
> Are you using the system font for the UI in LibreOffice (menu Tools >
> Options > LibreOffice > View)?
> 
> Best regards. JBF

Yes, I'm using the System Font for the UI.

Default font = Droid Sans, 9
Text scaling factor = 1.00


Fyi- my OS and LibreOffice version info has been updated, and the problem still persists. New version info below:

Ubuntu 14.04 (64-bit)
LibreOffice Version: 4.2.3.3
LibreOffice Build ID: 420m0(Build:3)
Comment 7 Benny 2014-07-21 11:02:45 UTC
Created attachment 103185 [details]
PDF showing Option dialogs with cut off text lines.

This document shows the Bug on Linux Mint Qiana.
Comment 8 Jean-Baptiste Faure 2014-07-21 11:49:09 UTC
(In reply to comment #7)
> [...]
> This document shows the Bug on Linux Mint Qiana.

Thank you for the screenshots. Did you try with another theme?

Best regards. JBF
Comment 9 Benny 2014-07-21 15:39:19 UTC
I am not sur about themes. Is it a feature of LibreOffice or Linux Mint
(Cinnamon in my case)?
Best regards
Benny


On Mon, Jul 21, 2014 at 1:49 PM, <bugzilla-daemon@freedesktop.org> wrote:

>   *Comment # 8 <https://bugs.freedesktop.org/show_bug.cgi?id=75175#c8> on
> bug 75175 <https://bugs.freedesktop.org/show_bug.cgi?id=75175> from
> Jean-Baptiste Faure <jbf.faure@sud-ouest.org> *
>
> (In reply to comment #7 <https://bugs.freedesktop.org/show_bug.cgi?id=75175#c7>)> [...]
> > This document shows the Bug on Linux Mint Qiana.
>
> Thank you for the screenshots. Did you try with another theme?
>
> Best regards. JBF
>
>  ------------------------------
> You are receiving this mail because:
>
>    - You are on the CC list for the bug.
>
>
Comment 10 Jean-Baptiste Faure 2014-07-22 05:44:19 UTC
(In reply to comment #9)
> I am not sur about themes. Is it a feature of LibreOffice or Linux Mint
> (Cinnamon in my case)?
Both. You can change the icons set at system level and change the icons set used by LibreOffice (menu Tools > Options > LibreOffice > View).

I asked that because the checkboxes in your screencopies seems bigger as usual.

Please, do not not answer by email, write on the webpage instead.

Best regards. JBF
Comment 11 Benny 2014-07-22 12:52:23 UTC
(In reply to comment #10)
> (In reply to comment #9)
> > I am not sur about themes. Is it a feature of LibreOffice or Linux Mint
> > (Cinnamon in my case)?
> Both. You can change the icons set at system level and change the icons set
> used by LibreOffice (menu Tools > Options > LibreOffice > View).
> 
> I asked that because the checkboxes in your screencopies seems bigger as
> usual.
> 
> Please, do not not answer by email, write on the webpage instead.
> 
> Best regards. JBF

I have now tsted some cases of icons, themes etc. see attached PDF file.
I cannot get anything to change the look of the options Print dialog.
Hops this info helps a little.

Best regards BennyA
Comment 12 Benny 2014-07-22 12:55:08 UTC
Created attachment 103282 [details]
Testing of themes, icons etc to see if anything changes.

I have tested more Libreoffice settings, then some Linux Mint system settings, themes, icons sets etc. Nothing of this removes the problem in LO.
Comment 13 Adolfo Jayme Barrientos 2014-08-24 02:51:09 UTC
This seems solved in master (4.4). Can you try a daily build and confirm that the issue is solved?
Comment 14 bejectannt 2015-02-25 12:37:26 UTC
Avoiding duplicates:  Just as a note to people finding this bug, but not that other one ... there is also: bug 87876 ("Tools -> Options -> View tab crushed")
Comment 15 Adolfo Jayme Barrientos 2015-03-19 05:05:56 UTC
No feedback from OP, so closing this as WORKSFORME.
Comment 16 Robinson Tryon (qubit) 2015-12-15 10:55:04 UTC
Migrating Whiteboard tags to Keywords: (possibleRegression)
[NinjaEdit]