Download it now!
Bug 75242 - DOCX EXPORT: Unwanted new line/paragraph added in footnote, and more new line/paragraphs added after each edit-and-save (Steps in comment 9)
Summary: DOCX EXPORT: Unwanted new line/paragraph added in footnote, and more new line...
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.3.0 release
Hardware: All All
: high major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
: 92385 (view as bug list)
Depends on:
Blocks: Footnote-Endnote
  Show dependency treegraph
 
Reported: 2014-02-20 05:13 UTC by Kevin Suo
Modified: 2018-03-22 13:53 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:


Attachments
when save the attached odt file as docx, a new line is added. (9.29 KB, application/vnd.oasis.opendocument.text)
2014-02-20 05:13 UTC, Kevin Suo
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Kevin Suo 2014-02-20 05:13:00 UTC
Created attachment 94405 [details]
when save the attached odt file as docx, a new line is added.

Bug description:
Unwanted new line/paragraph added before footnote numbering when save as DOCX, and more new line/paragraphs added after each edit-and-save.

Steps to reproduce:
1. New Writer document, type some text;
2. Insert a footnote with a line break (Shift+Enter);
3. Insert a second footnote and save as .docx

Current behaviour:
When reopen the above .docx file, and new line/paragraph was added before footnote numbering "2". (I'm not sure whether it is a new line or new paragraph)

Expected:
No un-wanted new line/paragraph was added when export as .docx file.

Version:
LibreOffice 4.1.5.3 and 4.2.1.1, Ubuntu 13.10 x86.
Comment 1 Kevin Suo 2014-02-20 05:16:14 UTC
Some more info, when  EDIT-AND-SAVE the .docx file, more and more new lines/paragraphs are added.
Comment 2 sophie 2014-03-12 16:04:35 UTC
I could not reproduce using 4.1.5.3 under Debian 6. Try to edit/save several times and no line is added. Sophie
Comment 3 Kevin Suo 2014-03-13 01:42:24 UTC
Comment on attachment 94405 [details]
when save the attached odt file as docx, a new line is added.

corrected MIME TYPE
Comment 4 Kevin Suo 2014-03-13 01:53:10 UTC
I can not reproduce under Windows XP x86, LibreOffice 4.1.5.3 and 4.2.1.1.

Will try again under Ubuntu later.
Comment 5 Kevin Suo 2014-03-14 10:30:31 UTC
I tried again, and still reproducible in Ubuntu 13.10, with: LibreOffice 

4.1.5.3 Build ID: 1c1366bba2ba2b554cd2ca4d87c06da81c05d24
4.2.2.1 Build ID: 3be8cda0bddd8e430d8cda1ebfd581265cca5a0f

Maybe an Ubuntu-only problem? Could someone else test it with other OS, thanks.
Comment 6 Kevin Suo 2014-03-15 00:38:14 UTC
I tried in Fedora 20, with the following builds and can reproducible:
Lireoffice 4.2.2.1 Build ID: 3be8cda0bddd8e430d8cda1ebfd581265cca5a0f
Libreoffice 4.1.5.3 Build ID: 1c1366bba2ba2b554cd2ca4d87c06da81c05d24

Steps:
1. Just save the attached test odt file as docx (ms ofice 2007/10/13 xml), then reopen, and see the footnote. New unwanted line breaks (paragraphs) were added.
2. Do some editing-and-save of the above docx file, see te footnote. New unwanted line breaks (paragraphs) were added after each save.

It's wired, since I can reproduce in Ubuntu and Fedora, not repro in Win XP, so seems be a linux-only problem,
but sophie can not reproduce in Debian.

sophie could you please try again in Debian? or Someone else try in some other linux distrs?
Comment 7 Owen Genat (retired) 2014-03-31 00:27:59 UTC
This is almost certainly a duplicate of bug 39205 (carriage return) and bug 64026 (leading tab).
Comment 8 Kevin Suo 2014-03-31 01:47:28 UTC
(In reply to comment #7)
> This is almost certainly a duplicate of bug 39205 (carriage return) and bug
> 64026 (leading tab).

They are certainly related but I dont see it is a duplicate of any one of them. (This bug is only concerned on footnote with a line-break. For footnotes without line-breaks, everything goes fine for me.)
Adding to SEE ALSO.

If someone doing further research and sure about it's a duplicate, feel free to mark as dup.
Comment 9 Kevin Suo 2014-06-13 01:57:13 UTC
Reproduced in Windows XP SP3,
Version 4.2.5.1 and 4.3.0.0 beta2.
Set platform to all.

Steps to reproduce:
1. Open the test odt file in libreoffice, observe the footnote.
2. Save the test odt file as docx, observe the footnote. (Un-wanted new lines are added to the footnote.)
3. Do some editing to the docx file, save and reopen. Observe the footnote. (more new lines are added to footnote.)
Comment 10 Jacques Guilleron 2014-06-19 21:56:37 UTC
Hi suokunlong,

Confirm this behaviour with LO 4.2.4.2 and LO 4.4.0.0.alpha0+
Build ID: 3e82897353e576dc6e3fbf55371fda5a0c3415df
TinderBox: Win-x86@39, Branch:master, Time: 2014-06-17_08:55:34
& Windows 7 Home Premium.

Confirm also this differ from bug 39205 (carriage return) and bug 64026 (leading tab).

Set Status to NEW.

regards,

Jacques
Comment 11 Matthew Francis 2015-04-14 13:08:21 UTC
Also occurs in LO 3.3.0

-> Version: Inherited from OOo
Comment 12 Timur 2015-05-04 10:42:49 UTC
> Steps to reproduce:
> 1. Open the test odt file in libreoffice, observe the footnote.
> 2. Save the test odt file as docx, CLOSE&OPEN, observe the 2ND footnote. (Un-wanted new lines are added to the footnote.)
REPRODUCED WITH LO 4.4 AND 5.0-DEV.
> 3. Do some editing to the docx file, save and reopen. Observe the footnote.
> (more new lines are added to footnote.)
NOT REPRODUCED IN WINDOWS 7.
Comment 13 W. Lindsay Wheeler 2015-07-07 18:56:41 UTC
I just wanted to add that I had the same problem and want to link to the bug problem page that I started. Several people from here have already commented there. 

https://bugs.documentfoundation.org/show_bug.cgi?id=92385

I wrote a book and it went from 166 pages to 564 pages.
Comment 14 Timur 2016-01-19 18:26:25 UTC
Looks like resolved in 5.1.0.
Feel free to reopen if tested otherwise. 
Please do not reopen if reproduced in 5.0.
Comment 15 Timur 2017-04-18 08:16:09 UTC
*** Bug 92385 has been marked as a duplicate of this bug. ***