Bug 75337 - FILOPEN: LibO can't open .docx when attached to an email in Thunderbird
Summary: FILOPEN: LibO can't open .docx when attached to an email in Thunderbird
Status: RESOLVED NOTOURBUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.1.5.3 release
Hardware: IA64 (Itanium) Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-02-21 20:14 UTC by Les Kalmus
Modified: 2014-10-06 05:10 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Les Kalmus 2014-02-21 20:14:44 UTC
Double clicking on an attached docx file in Release 4.1.5.3 does not open the file which it did correctly in the previous release. 

It does open an attached doc file OK.

It will open the docx file if the file is first saved.
Comment 1 tommy27 2014-02-22 06:45:21 UTC
no attachment here. impossible to test. 
please attach file and then revert status from NEEDINFO to UNCONFIRMED
Comment 2 Les Kalmus 2014-03-07 21:16:04 UTC
I have three or four .docx files that came as an attachment to an email in Thunderbird, all from different senders. None will open on my PC. My wife also received one or two docx attachments from other people and they won't open either.
There is a very fast popup that is too fast to read when the docx is clicked on but the file does not open.

If one of these docx files are saved, it will open properly.
Comment 3 tommy27 2014-03-08 06:44:07 UTC
(In reply to comment #0)
> Double clicking on an attached docx file in Release 4.1.5.3 does not open
> the file which it did correctly in the previous release. 

which "previous release" did it work?

> It does open an attached doc file OK.
> 
> It will open the docx file if the file is first saved.

so you are saying that it does not open the .docx if it's clicked when still shown inside the Thunderbird GUI as an attachment?

but if you save that file on your hard disk, the file can be properly opened, right?

in the original description you also say that attached .doc files work, so the bug is limited to .docx, right?
Comment 4 Les Kalmus 2014-03-08 17:01:02 UTC
Yes, a docx will not open when clicked in the Thunderbird GUI as an attachment but it will open after being saved to disk.
The problem is limited to docx files.
The last version I used was most likely the previous release for Windows 7 64 bit. I always upgrade as soon as I can when a new release is available so it was probably the latest prior release.
Unfortunately I don't have notes on it. If there is somewhere in the profile, etc. I can look for history, I will be glad to do so.
Comment 5 QA Administrators 2014-10-05 23:05:38 UTC
Dear Bug Submitter,

This bug has been in NEEDINFO status with no change for at least 6 months. Please provide the requested information as soon as possible and mark the bug as UNCONFIRMED. Due to regular bug tracker maintenance, if the bug is still in NEEDINFO status with no change in 30 days the QA team will close the bug as INVALID due to lack of needed information.

For more information about our NEEDINFO policy please read the wiki located here: 
https://wiki.documentfoundation.org/QA/FDO/NEEDINFO

If you have already provided the requested information, please mark the bug as UNCONFIRMED so that the QA team knows that the bug is ready to be confirmed.


Thank you for helping us make LibreOffice even better for everyone!


Warm Regards,
QA Team
Comment 6 Les Kalmus 2014-10-06 01:33:18 UTC
Fixed the problem. It was a setting in Thunderbird that somehow got changed and is ok now.
Comment 7 tommy27 2014-10-06 05:10:55 UTC
nice to hear that. set status RESOLVED NOTOURBUG