Download it now!
Bug 75373 - PDF Export produces PDF but WMF images have missing elements
Summary: PDF Export produces PDF but WMF images have missing elements
Status: RESOLVED DUPLICATE of bug 104252
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.0.5.2 release
Hardware: All Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: Confirmed:4.3.0.0a0+:Win8.1
Keywords: filter:emf, filter:pdf
Depends on:
Blocks: PDF-Export
  Show dependency treegraph
 
Reported: 2014-02-22 16:13 UTC by Gibey
Modified: 2016-12-28 15:27 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Input file (29.00 KB, application/msword)
2014-02-22 16:13 UTC, Gibey
Details
Output file (182.25 KB, application/pdf)
2014-02-22 16:15 UTC, Gibey
Details
Test file (35.65 KB, application/vnd.oasis.opendocument.text)
2014-03-05 20:44 UTC, Gibey
Details
Input file (35.65 KB, application/vnd.oasis.opendocument.text)
2014-03-05 20:47 UTC, Gibey
Details
Output from TestExportPDF produced by LibreOffice Writer 5.1.1.1 (160.56 KB, application/pdf)
2016-02-21 15:07 UTC, Gibey
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Gibey 2014-02-22 16:13:58 UTC
Created attachment 94571 [details]
Input file
Comment 1 Gibey 2014-02-22 16:15:09 UTC
Created attachment 94572 [details]
Output file
Comment 2 Gibey 2014-02-23 18:28:17 UTC
Problem persist with any type (DOC or ODT).
Same problem with a PDF printer (exemple PDF Creator)
Comment 3 Cor Nouws 2014-02-23 22:35:30 UTC
Hi J Marc,

Thanks for the issue & the documents,

When exporting in 4211 on Ubuntu, I do not see the problem. Maybe Windows only?

regards,
Cor
Comment 4 Gibey 2014-03-03 06:59:20 UTC
Problem does not appear with LO 4.1.5 and OO 4.0.1
Comment 5 retired 2014-03-04 11:03:59 UTC
Open TestExport.doc with LO 4.3.0.0a0+ on Win 8.1 export to PDF all good.

NoRepro:4.3.0.0a0+:Win8.1

Although not suggested for daily use, you can try and see if this fixes it for you as well.

http://dev-builds.libreoffice.org/daily/master/

Please also try resetting your user profile and let us know if that helps: https://wiki.documentfoundation.org/UserProfile

Should this be still reproducible for you with the latest LO release please set this bug back to UNCONFIRMED. Should this issue be solved set it to WORKSFORME.

Setting to NEEDINFO until more detail is provided.
Comment 6 retired 2014-03-04 11:09:07 UTC
Scratch that. Totally see the missing info. adjusting title to be more informative.

Export to PDF produces PDF with missing info in images. see page 1 image of graph: info is complete in doc file but not in exported PDF.

NEW.
Comment 7 Gibey 2014-03-05 20:44:46 UTC
Created attachment 95190 [details]
Test file
Comment 8 Gibey 2014-03-05 20:47:28 UTC
Created attachment 95191 [details]
Input file
Comment 9 QA Administrators 2016-02-21 08:34:54 UTC Comment hidden (obsolete)
Comment 10 Gibey 2016-02-21 15:05:39 UTC Comment hidden (no-value)
Comment 11 Gibey 2016-02-21 15:07:23 UTC
Created attachment 122849 [details]
Output from TestExportPDF produced by LibreOffice Writer 5.1.1.1
Comment 12 Gibey 2016-02-21 15:09:35 UTC
(In reply to Gibey from comment #11)
> Created attachment 122849 [details]
> Output from TestExportPDF produced by LibreOffice Writer 5.1.1.1

Windows 7 (32-bits) SP1
Comment 13 Gibey 2016-02-21 15:10:41 UTC
In LibreOffice Writer 5.1.1.1 the problem persist.
Comment 14 Timur 2016-02-23 16:53:58 UTC
Looks like a duplicate of Bug 74686.

(In reply to Gibey from comment #4)
> Problem does not appear with LO 4.1.5 and OO 4.0.1
I don't find that LO ever worked fine with this one. 
Images appear only from LO 4.0.5, I guess it's from Bug 65502.
Comment 15 Timur 2016-11-17 08:36:30 UTC
I'll mark as a duplicate of Bug 77525 which seems to have been solved from 5.2.1. up to master 5.3, but then stopped to work again. If proved otherwise please reopen.
Tested with:
TinderBox: Win-x86@42, Branch:master, Time: 2016-10-26
TinderBox: Win-x86@39, Branch:master, Time: 2016-11-15

*** This bug has been marked as a duplicate of bug 77525 ***
Comment 16 V Stuart Foote 2016-12-28 15:27:21 UTC
Workaround 

disable Tools -> Options -> View: "Use hardware acceleration" (or enable "OpenGL rendering" if system supports).


=-=-=
QA clean up of 77525, splitting it to bug 104252 and bug 103833

*** This bug has been marked as a duplicate of bug 104252 ***