Bug 75398 - Repurpose Sifr as the new hicontrast theme
Summary: Repurpose Sifr as the new hicontrast theme
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
4.3.0.0.alpha0+ Master
Hardware: All All
: medium enhancement
Assignee: Heiko Tietze
URL:
Whiteboard: target:6.1.0
Keywords: accessibility
Depends on:
Blocks: High-Contrast
  Show dependency treegraph
 
Reported: 2014-02-23 12:40 UTC by Stefan Knorr (astron)
Modified: 2018-06-17 06:50 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:


Attachments
Windows 7 default HC mode themes available (4.31 KB, image/png)
2014-02-23 16:01 UTC, V Stuart Foote
Details
Current high contrast theme on default grey in gnome. (2.31 KB, image/png)
2014-03-10 21:59 UTC, Daniel Hulse
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Stefan Knorr (astron) 2014-02-23 12:40:30 UTC
Is it an option to ship the Sifr theme instead of the hicontrast theme?

The Sifr theme uses relatively simple shapes, is flat and should provide good contrast (at least on light backgrounds). Are there any reasons to keep the old hicontrast theme around?
Comment 1 Stefan Knorr (astron) 2014-02-23 12:41:16 UTC
Adding V. Stuart Foote for accessibility input.
Comment 2 V Stuart Foote 2014-02-23 16:01:33 UTC
Created attachment 94602 [details]
Windows 7 default HC mode themes available

Astron, Mirek

Reviewed related design discussions 

https://wiki.documentfoundation.org/Design/Meetings/2014-02-23
https://wiki.documentfoundation.org/Design/Meetings/2014-02-16

Attached is a snip of the MS Windows 7 default offerings for HC mode (OS X and Linux DTE's have many as well), the static bitmaps of the existing HC mode icon set is actually not optimal for a number of these HC 'themes'.  

IIRC current high contrast icon set was morphed from the Tango designs, see no reason not to do the same for a set of Sifr for use when OS shifts to its HighContrast mode.  

Am I correct in thinking that since Sifr is a dynamic 'flat' icons set, the OS HighContrast settings could be picked up to drive the Sifr color set as rendered for HC.

Unfortunately you can't switch OS (Windows 7) into a HighContrast mode, and have LibreOffice honor a Tools -> Options -> View setting of Sifr icons to see what it does with the existing renderings. When in Windows OS HC mode, LibreOffice switches to the HC icon set.

Can anyone think of a way to mock-up appearance of Sifr icons on the common HC layouts with dynamic color assignment?
Comment 3 Adolfo Jayme 2014-02-23 18:59:48 UTC
Sadly, Sift is still not “dynamic” (recolored by software so it looks good against background). It still relies on bitmaps, and until that gets fixed (i.e., LibreOffice starts parsing SVGs), this is kind of blocked.
Comment 4 Tin Man 2014-02-23 20:22:39 UTC
A much simpler solution would be to have one white Sifr set and one black Sifr set for HC themes, and have LibreOffice decide which one to use based on the colors in the theme.

I don't see a need to recolor the icons dynamically -- black or white should always give the highest contrast.
Comment 5 Tin Man 2014-02-23 20:23:41 UTC
BTW, if I'm not mistaken, the current HC theme is only suitable for dark HC themes. People using light HC themes are out of luck.
Comment 6 Daniel Hulse 2014-03-10 21:59:53 UTC
Created attachment 95560 [details]
Current high contrast theme on default grey in gnome.

The current high contrast theme really doesn't work for light themes. This is it shown on the default grey. Not exactly very usable.
Comment 7 Adolfo Jayme 2016-03-05 19:11:18 UTC
Tomaž added dynamic recoloring in October: https://cgit.freedesktop.org/libreoffice/core/commit/?id=78a4e9cb89830191e77c558759e845e5a15b9cc7

So that part of this bug’s technicalities is solved.
Comment 8 Robinson Tryon (qubit) 2016-08-25 05:49:47 UTC Comment hidden (obsolete)
Comment 9 Heiko Tietze 2017-11-27 10:27:12 UTC
Sifr has been implemented in bright and dark variants => WFM (actually fixed). Doubt that this icon theme is a good replacement for hicontrast.
Comment 10 V Stuart Foote 2017-11-27 13:47:20 UTC
Try it on a Windows system.

Reopening, os accessibility HC mode still picks up odd Galaxy derived icons--issue remains to provide a viable HC replacement. Sifr remains a valid choice (and simplest to implement without additional design work) with the dynamic recoloring as in comment 7.  As the os HC mode is fixed--we need fixed light or dark HC versions, ideally respond to the os Theme.


Back to NEW.
Comment 11 Heiko Tietze 2017-11-27 14:24:35 UTC
And I'm still voting against Sifr as 'High Contrast' alternative. Monochrome is the opposite of accessibility.
Comment 12 V Stuart Foote 2017-11-27 16:35:54 UTC
With a reduced palette (and picking up colors from DE theme) "monochrome" icons are the only way we can provide support for light and dark HC themes. We can not afford to design/deploy multiple icon sets, and would need additional logic for the HIGH_CONTRAST_ID to pick the "best" of several icon sets for a given HC theme.

IIRC the existing HC icon support uses a single unsupported Galaxy derived icon set that is of marginal use and is limited to Dark HC themes.

Dynamic icon coloring, even monochromatic, would meet our needs--and seems Sifr is the only supported icon set option we have as they were designed from the start to be intelligible as monochromatic (mostly). 

Using Sifr and dynamically assigning it a color (likely our FACECOLOR or DARKSHADOWCOLOR) as drawn from the os HC theme would be an efficient (and low effort) means of providing functional HC support for a11y.
Comment 13 Heiko Tietze 2018-04-09 09:45:50 UTC
Alex, you are the expert in this field. Advantage of shifting from the current out-dated and not maintained Hicontrast to Sifr is that we get an up-to-date icon theme.
Comment 14 Alex ARNAUD 2018-04-10 17:25:48 UTC
(In reply to Heiko Tietze from comment #13)
> Alex, you are the expert in this field. Advantage of shifting from the
> current out-dated and not maintained Hicontrast to Sifr is that we get an
> up-to-date icon theme.

After testing a bit, IMO the Sifr is really readable for me (I'm visual-impaired). As we'll only change the default, it's not a big issue for a user wanting to come back to High Contrast theme if he prefers.

99% of visual-impaired users I train LibreOffice don't customize the theme, they only use the reverse color (negative) feature of their screen magnifier software (ZoomText on Windows, Compiz/EZoom or GNOME Zoom on GNU/Linux for example) to improve the contrast.

Best regards,
Alex.
Comment 15 Heiko Tietze 2018-04-12 10:26:33 UTC
Patch at https://gerrit.libreoffice.org/#/c/52772/
Comment 16 Heiko Tietze 2018-04-14 18:12:33 UTC
*** Bug 117006 has been marked as a duplicate of this bug. ***
Comment 17 Commit Notification 2018-04-18 08:33:14 UTC
heiko tietze committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=12e3f64f270d464313176d4936ea811b45fb750e

tdf#75398 - Replace hicontrast by Sifr

It will be available in 6.1.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 18 Alex ARNAUD 2018-06-16 16:41:13 UTC
Hello all,

I cannot confirm the resolution on Windows 10 with High Contrast enabled. The default icon theme is Colibre.

@vstuart: Are you able to confirm the resolution ?

Best regards,
Alex.
Comment 19 V Stuart Foote 2018-06-16 18:31:55 UTC
(In reply to Alex ARNAUD from comment #18)
> Hello all,
> 
> I cannot confirm the resolution on Windows 10 with High Contrast enabled.
> The default icon theme is Colibre.
> 
> @vstuart: Are you able to confirm the resolution ?
> 

Works correctly for me.

Sifr icons are correctly swapped with OS/DE is in a HighContrast mode
On Windows 10 Pro 64-bit en-US in HighContrast mode
Version: 6.1.0.0.beta1 (x64)
Build ID: 8c76dfe1284e211954c30f219b3a38dcdd82f8a0
CPU threads: 8; OS: Windows 10.0; UI render: GL; 
Locale: en-US (en_US); Calc: group

or current master/6.2.0

Sifr is active and visible in each the MS default themes: High Contrast #1, High Contrast #2, High Contrast Black and High Contrast White.

Note: use of Sifr (replacing old Tango HC) has not been implemented for 6.0.5 release.
Comment 20 Alex ARNAUD 2018-06-16 20:04:48 UTC
(In reply to V Stuart Foote from comment #19)
> Works correctly for me.
> 
> Sifr icons are correctly swapped with OS/DE is in a HighContrast mode
> On Windows 10 Pro 64-bit en-US in HighContrast mode
> Version: 6.1.0.0.beta1 (x64)
> Build ID: 8c76dfe1284e211954c30f219b3a38dcdd82f8a0
> CPU threads: 8; OS: Windows 10.0; UI render: GL; 
> Locale: en-US (en_US); Calc: group
> 
> or current master/6.2.0
> 
> Sifr is active and visible in each the MS default themes: High Contrast #1,
> High Contrast #2, High Contrast Black and High Contrast White.
> 
> Note: use of Sifr (replacing old Tango HC) has not been implemented for
> 6.0.5 release.

Indeed, you're correct but it's not correctly reported on Tool, Options, View. It is mark as automatic (Colibre) instead of Automatic (Sifr).

I'm testing 6.2 on Windows 10 Family 1803. 

If High Contrast mode is enabled I couldn't change the icon theme, isn't the same for you ?

Best regards,
Alex.
Comment 21 V Stuart Foote 2018-06-16 20:59:49 UTC
(In reply to Alex ARNAUD from comment #20)
> Indeed, you're correct but it's not correctly reported on Tool, Options,
> View. It is mark as automatic (Colibre) instead of Automatic (Sifr).
> 
> I'm testing 6.2 on Windows 10 Family 1803. 
> 
> If High Contrast mode is enabled I couldn't change the icon theme, isn't the
> same for you ?
> 

The internal theme support for HC is hard coded, some adjustments were made to pick up more elements from an active DE theme, but this change in icons from the old Tango HC to Sifr is hard coded.

And on Windows 10 build with current master/6.2 opening in HC mode, I see Sifr showing as active. With this build, an icon selection from Tools -> Options -> View can be made while OS/DE is in HC mode but that selection does not have any affect until leaving HC mode.
Comment 22 Heiko Tietze 2018-06-17 06:50:56 UTC
(In reply to Alex ARNAUD from comment #20)
> If High Contrast mode is enabled I couldn't change the icon theme, isn't the
> same for you ?

Hard-coded, as Stuart explains, but we should change this. Worth a new ticket IMO.