Download it now!
Bug 75487 - Other: support for svgz
Summary: Other: support for svgz
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
4.2.0.4 release
Hardware: Other All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard: BSA target:4.3.0
Keywords:
: 113986 (view as bug list)
Depends on:
Blocks:
 
Reported: 2014-02-25 10:18 UTC by Nico Kruber
Modified: 2019-03-04 23:42 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Nico Kruber 2014-02-25 10:18:47 UTC
Problem description: 

trying to add a svgz image to e.g. a writer document does not work
also (probably as a consequence) gengal does not allow to create galleries from svgz images which become more important nowadays, e.g. in the openclipart library

Steps to reproduce:
1. in e.g. writer insert image from file
2. select a *.svgz file

Current behavior:
"not supported"

Expected behavior:
add the image just like an ordinary svg file
Operating System: openSUSE
Version: 4.2.0.4 release
Comment 1 Tomaz Vajngerl 2014-02-25 10:44:30 UTC
Thanks!
Comment 2 V Stuart Foote 2014-02-27 07:02:10 UTC
On Windows 7 sp1, 64-bit
Version: 4.3.0.0.alpha0+
Build ID: f839b5dd16c05c0eda21345ec36ec0cb024eb732
TinderBox: Win-x86@47-TDF, Branch:MASTER, Time: 2014-02-23_09:54:38

Confirming, no import filter support for .svgz format (which is a simple gzip of the svg file)

Also if attempting to open a *.svgz graphic in Draw results in "General Error. General input/output error." popup.
Comment 3 Commit Notification 2014-03-02 21:13:32 UTC
Tomaž Vajngerl committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=51e7a789a1345932eadb92dc1ef5ac5ecfe2d0c0

fdo#75487 Register svgz as a recognisable extension.



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 4 Commit Notification 2014-03-02 21:13:48 UTC
Tomaž Vajngerl committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=4f7aa27c6297453a348137bb99d1a28e3dfc5619

fdo#75487 Add support for svgz to SvgFilter and co.



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 5 Commit Notification 2014-03-03 21:43:02 UTC
Tomaž Vajngerl committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=115ae1259564a51a14a3363a00717b09882d55bf

fdo#75487 Store svgz decompressed (as plain svg) in the document.



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 6 V Stuart Foote 2017-11-23 03:33:19 UTC
*** Bug 113986 has been marked as a duplicate of this bug. ***