Download it now!
Bug 75805 - "Apply" button in "insert" -> "Hyperlink" closes dialog
Summary: "Apply" button in "insert" -> "Hyperlink" closes dialog
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.2.1.1 release
Hardware: Other All
: medium normal
Assignee: Thomas Arnhold
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-03-05 16:34 UTC by a07cd040897db54e103c
Modified: 2014-08-23 22:07 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
A screenshot of the insert-hyperlink dialog. (16.34 KB, image/png)
2014-03-05 16:34 UTC, a07cd040897db54e103c
Details

Note You need to log in before you can comment on or make changes to this bug.
Description a07cd040897db54e103c 2014-03-05 16:34:42 UTC
Created attachment 95175 [details]
A screenshot of the insert-hyperlink dialog.

The dialog that appears by clicking "Insert" -> "Hyperlink" is closed, when "Apply" is selected. I think a click on that button should only apply the changes made and *not* close the dialog at all.
Comment 1 Cor Nouws 2014-03-05 17:03:31 UTC

*** This bug has been marked as a duplicate of bug 63271 ***
Comment 2 a07cd040897db54e103c 2014-07-07 11:33:05 UTC
This is *not* a duplicate of bug 63271 it is the complete opposite. Furthermore i feel that "fixing" bug 63271 *introduced* the behaviour i am criticising.

Although 63271 is correctly marked as "RESOLVED WONTFIX" the "patch" seems to be included into the source.

The "Apply" button should *never* close a dialog window - it should only apply/adopt the changes made. And that's exactly how it worked *before* "fixing" bug 63271. Now - when applying the changes also closes the window - it feels broken.

May be an additional button "OK" is needed to solve this discrepancy.

"OK"    - Apply changes AND close the dialog
"Apply" - Only apply the changes
"Close" - Discard changes and close the dialog
Comment 3 penttila 2014-08-11 13:16:31 UTC
See also discussion about bug 56456 (added by felix.stadler in history)
Comment 4 Thomas Arnhold 2014-08-17 11:44:22 UTC
Proposed fix: https://gerrit.libreoffice.org/10946