Bug 76121 - FILEOPEN: crash in file picker with oxygen-gtk theme
Summary: FILEOPEN: crash in file picker with oxygen-gtk theme
Status: RESOLVED NOTOURBUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: graphics stack (show other bugs)
Version:
(earliest affected)
4.2.2.1 release
Hardware: Other Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
: 72565 76545 (view as bug list)
Depends on:
Blocks:
 
Reported: 2014-03-13 14:46 UTC by John Farrar
Modified: 2014-05-28 21:18 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
trace (42.79 KB, text/x-log)
2014-03-13 16:38 UTC, John Farrar
Details

Note You need to log in before you can comment on or make changes to this bug.
Description John Farrar 2014-03-13 14:46:42 UTC
Problem description: Program crash on trying to open or save a file

Steps to reproduce:
1. ....Open file
2. ....
3. ....

Current behavior: Program crash

Expected behavior:
Program works as normal after libobasis2.4-kde-integration-4.2.2.1-1.x86_64.rpm removed
              
Operating System: openSUSE
Version: 4.2.0.4 release
Comment 1 Maxim Monastirsky 2014-03-13 15:42:46 UTC
Hi,

From your report it's not clear what version you're using. You filled this bug against 4.2.0.4 version, but you mention a RPM file which belong to 4.2.2.1.

Also this RPM file is for KDE3 integration, and I guess it's not what you're using (I guess KDE4?). So it's not clear to me how this RPM can affect you.

Can you clarify please?
Comment 2 John Farrar 2014-03-13 16:12:28 UTC
Apologies - using 4.2.2.1

I do not know how the file affects the program, however, deleting both 
gnome and kde integration files stops the crashes.  I use KDE so I am 
not sure what the effect of the gnome intergration file could be, but an 
error in the terminal mentioned in in reference to a dbus conenction 
failure.

On 13/03/14 15:42, bugzilla-daemon@freedesktop.org wrote:
> Maxim Monastirsky <mailto:momonasmon@gmail.com> changed bug 76121
> <https://bugs.freedesktop.org/show_bug.cgi?id=76121>
> What 	Removed 	Added
> Status 	UNCONFIRMED 	NEEDINFO
> CC 		momonasmon@gmail.com
> Ever confirmed 		1
>
> *Comment # 1 <https://bugs.freedesktop.org/show_bug.cgi?id=76121#c1> on
> bug 76121 <https://bugs.freedesktop.org/show_bug.cgi?id=76121> from
> Maxim Monastirsky <mailto:momonasmon@gmail.com> *
>
> Hi,
>
>>From your report it's not clear what version you're using. You filled this bug
> against 4.2.0.4 version, but you mention a RPM file which belong to 4.2.2.1.
>
> Also this RPM file is for KDE3 integration, and I guess it's not what you're
> using (I guess KDE4?). So it's not clear to me how this RPM can affect you.
>
> Can you clarify please?
>
> ------------------------------------------------------------------------
> You are receiving this mail because:
>
>   * You reported the bug.
>
Comment 3 Maxim Monastirsky 2014-03-13 16:23:57 UTC
OK, Could you please attach a backtrace? Basically you need to open the terminal and run 'soffice --backtrace', then reproduce the crash. It will create a file named 'gdbtrace.log' in the current directory. Please attach here this file.

Please don't reply using your mail, use the web interface instead - https://bugs.freedesktop.org/show_bug.cgi?id=76121. Thanks.
Comment 4 John Farrar 2014-03-13 16:38:47 UTC
Created attachment 95727 [details]
trace
Comment 5 Maxim Monastirsky 2014-03-13 22:09:22 UTC
That crash is related only to GTK integration, not to the RPM file you mentioned. As you can see from the backtrace, the crash isn't in libreoffice code but in oxygen-gtk2/glib code. My guess is that if you try to use another gtk2 theme, it won't crash. Upgrading/downgrading oxygen-gtk2 might also help.

In the meanwhile, I'm closing this bug as NotOurBug.

(In reply to comment #2)
> I use KDE so I am 
> not sure what the effect of the gnome intergration file could be
That's because the official package from libreoffice.org doesn't ship the KDE4 integration (see Bug 48611), so you forced to use the GNOME one, or the generic one. Sure if you look at software.opensuse.org, you could find a build of v4.2 that is better integrated with your system.
Comment 6 John Farrar 2014-03-14 10:06:55 UTC
Thanks for that.  Changing the theme in KDE has indeed solved the issue.
Comment 7 Maxim Monastirsky 2014-04-16 12:18:30 UTC
*** Bug 76545 has been marked as a duplicate of this bug. ***
Comment 8 Terrence Enger 2014-04-22 16:51:45 UTC
*** Bug 72565 has been marked as a duplicate of this bug. ***