Bug Hunting Session
Bug 76255 - Styles not imported correctly when using CJK UI (zh_CN and JA at least)
Summary: Styles not imported correctly when using CJK UI (zh_CN and JA at least)
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: CJK
  Show dependency treegraph
 
Reported: 2014-03-17 08:48 UTC by Kevin Suo
Modified: 2017-11-29 03:47 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
the test doc file. (36.50 KB, application/msword)
2014-03-17 08:48 UTC, Kevin Suo
Details
a docx file saving from the above doc file (6.91 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2014-03-17 08:50 UTC, Kevin Suo
Details
Step by step screen in Fedora, with ZH_CN, JA, and EN UI, respectively. (612.00 KB, application/vnd.oasis.opendocument.text)
2014-03-18 15:27 UTC, Kevin Suo
Details
how it looks for me with zh-CN UI (147.81 KB, image/png)
2014-06-24 08:51 UTC, Yousuf Philips (jay) (retired)
Details
how it looks for me with arabic UI (142.66 KB, image/png)
2014-06-24 09:04 UTC, Yousuf Philips (jay) (retired)
Details
how it looks for me with KeyID UI (168.63 KB, image/png)
2014-06-24 09:05 UTC, Yousuf Philips (jay) (retired)
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Kevin Suo 2014-03-17 08:48:52 UTC
Created attachment 95915 [details]
the test doc file.

When open the attached doc file with LibreOffice under a non-English UI (I am using zh_CN), the styles hierarchical structure is not imported correctly.

Steps:
1. Enable a zh_CN UI (maybe other on-English UIs will also reproduce, which I did not test);
2. Open the attached doc file.

Current Result:
Style name for "A. Heading 2 " is under (based on) the "Default" style.

Expected:
tyle name for "A. Heading 2 " should be based on the "Heading" style. (This can be seen from the style editor).

Further bad behaviour:
When save the above doc file as docx, the style of Heading 2 is totally different.(text is align centered rather than left). This may be because of the un-properly imported styles.
Comment 1 Kevin Suo 2014-03-17 08:50:44 UTC
Created attachment 95916 [details]
a docx file saving from the above doc file

Notice the different formatting of heading 2.
Comment 2 sophie 2014-03-18 13:24:19 UTC
I can not reproduce, the two documents look the same and styles are correctly applied using Ubuntu 13.10, FR lang pack, Version: 4.2.3.1
Build ID: 3d4fc3d9dbf8f4c0aeb61498a81f91c5b7922f13. I'll ask our Chinese l10n team to have a look - Sophie
Comment 3 Kevin Suo 2014-03-18 14:43:31 UTC
I also reproduced this with Japanese UI, so changing the title to "CJK".
Comment 4 Kevin Suo 2014-03-18 15:27:13 UTC
Created attachment 96008 [details]
Step by step screen in Fedora, with ZH_CN, JA, and EN UI, respectively.

Sorry, in my Fedora machine I produce a different result than what I produced in my another machnine (heading 2 is within heading). But the style Hierarchical problem still exists, and save as docx still corrupt the styles.
See the step by step screen shots.

I will take further screenshots in my another machine tomorrow.
Comment 5 Joel Madero 2014-06-02 20:13:15 UTC
This is not a critical bug - critical means data loss/crashes/etc... this is just a normal bug. Marking accordingly. Please do not set to critical again. For more information feel free to email the QA list about priorities.
Comment 6 Yousuf Philips (jay) (retired) 2014-06-24 08:51:51 UTC
Created attachment 101650 [details]
how it looks for me with zh-CN UI
Comment 7 Yousuf Philips (jay) (retired) 2014-06-24 09:04:56 UTC
Created attachment 101653 [details]
how it looks for me with arabic UI
Comment 8 Yousuf Philips (jay) (retired) 2014-06-24 09:05:20 UTC
Created attachment 101655 [details]
how it looks for me with KeyID UI
Comment 9 Yousuf Philips (jay) (retired) 2014-06-24 09:15:26 UTC
When attachment 95915 [details] is opened in all UIs other than english, the 'Heading', 'Index', 'Quotations', and 'Table of Contents' appear in english rather than their localized version. If you look in the KeyID UI version, you will notice that these entries dont have string references and the string referenced version of 'Heading' appears as a sub-folder of the non-string referenced 'Heading' and the string referenced 'Heading' has Heading 7 to Heading 10 underneath it, in addition to others.

This was tested in 4.2 and 4.3 on Linux Mint.
Comment 10 Matthew Francis 2015-04-08 05:21:32 UTC
Also occurs on 3.3.0.4 with the zh_CN langpack (note that to reproduce that far back, you have to manually enable the "Hierarchical" view in Styles and Formatting)

-> Version: Inherited from OOo
Comment 11 tommy27 2016-04-16 07:28:08 UTC Comment hidden (obsolete)
Comment 12 QA Administrators 2017-05-22 13:25:52 UTC Comment hidden (obsolete)
Comment 13 Kevin Suo 2017-11-29 03:47:40 UTC
This may not be an issue in most recent versions.

Version: 6.0.0.0.beta1
Build ID:97471ab4eb4db4c487195658631696bb3238656c
CPU 线程:2; 操作系统:Linux 4.13; UI 渲染:默认; VCL: gtk2; 
Locale: zh-CN (zh_CN.UTF-8); Calc: group threaded