Bug 76283 - Try to send a file by email but my browser was opened nad not thunderbird
Summary: Try to send a file by email but my browser was opened nad not thunderbird
Status: RESOLVED NOTOURBUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.2.2.1 release
Hardware: x86 (IA32) Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-03-17 17:34 UTC by jcc.vanniel
Modified: 2014-03-24 13:45 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
attachment-21346-0.html (2.83 KB, text/html)
2014-03-21 21:37 UTC, jcc.vanniel
Details
attachment-21346-1.dat (1 bytes, multipart/alternative)
2014-03-21 21:37 UTC, jcc.vanniel
Details
log.txt (1.35 KB, text/plain)
2014-03-21 21:37 UTC, jcc.vanniel
Details

Note You need to log in before you can comment on or make changes to this bug.
Description jcc.vanniel 2014-03-17 17:34:10 UTC

    
Comment 1 sophie 2014-03-17 17:53:50 UTC
Please provide a step by step description of what you did in order for us to try to reproduce your problem, provide your Linux/distro version, your e-mail client and version - Thanks! - set as Needinfo - Sophie
Comment 2 jcc.vanniel 2014-03-17 21:44:19 UTC
Needinfo - Sophie

Dear Sophie,

I have:
Linux Mint 13 Maya Mate 32-bit
LibreOffice 4.2.2.1
With the dutch UI en dutch help.
Email client Thuderbird 24.3.0

I edited a spreadsheet and choose to send it with an email as a 
Microsoft Excel attachment .
Left menu, send file (don't know exact because I have the dutch version)
Choosing this, it did not start my Thunderbird email but Google Chrome 
Versie 33.0.1750.152
I also have installed Chromium and Firefox.

Kinds regards,

Jan van Niel

op 17-03-14 18:53, bugzilla-daemon@freedesktop.org schreef:
> sophie <mailto:gautier.sophie@gmail.com> changed bug 76283 
> <https://bugs.freedesktop.org/show_bug.cgi?id=76283>
> What 	Removed 	Added
> Status 	UNCONFIRMED 	NEEDINFO
> CC 		gautier.sophie@gmail.com
> Ever confirmed 		1
>
> *Comment # 1 <https://bugs.freedesktop.org/show_bug.cgi?id=76283#c1> 
> on bug 76283 <https://bugs.freedesktop.org/show_bug.cgi?id=76283> from 
> sophie <mailto:gautier.sophie@gmail.com> *
> Please provide a step by step description of what you did in order for us to
> try to reproduce your problem, provide your Linux/distro version, your e-mail
> client and version - Thanks! - set as Needinfo - Sophie
> ------------------------------------------------------------------------
> You are receiving this mail because:
>
>   * You reported the bug.
>
Comment 3 Stephan Bergmann 2014-03-18 10:40:47 UTC
LO uses a shell script senddoc, next to soffice.bin in the program directory, to actually invoke the mail program.  If you add the following two lines

set -x
echo "senddoc <$@>" 1>&2

directly after the first line ("#!/bin/sh") of that program/senddoc script, and run LO from a shell like

  soffice 2>log.txt

do the "Send as E-mail" steps, terminate LO, and attach the generated log.txt file here, that might be a quick way to get a better idea what's going wrong for you.
Comment 4 jcc.vanniel 2014-03-21 21:37:54 UTC
Created attachment 96188 [details]
attachment-21346-0.html

Stephan,
Coming from DOS > Windows > WindowsXP > Linux now and I enjoy it.
Did my best.
The log.txt file is attached.
Glad to hear from you.
Kind regards, Jan van Niel




2014-03-18 11:40 GMT+01:00 <bugzilla-daemon@freedesktop.org>:

>  Stephan Bergmann <sbergman@redhat.com> changed bug 76283<https://bugs.freedesktop.org/show_bug.cgi?id=76283>
>  What Removed Added  CC   sbergman@redhat.com
>
>  *Comment # 3 <https://bugs.freedesktop.org/show_bug.cgi?id=76283#c3> on
> bug 76283 <https://bugs.freedesktop.org/show_bug.cgi?id=76283> from Stephan
> Bergmann <sbergman@redhat.com> *
>
> LO uses a shell script senddoc, next to soffice.bin in the program directory,
> to actually invoke the mail program.  If you add the following two lines
>
> set -x
> echo "senddoc <$@>" 1>&2
>
> directly after the first line ("#!/bin/sh") of that program/senddoc script, and
> run LO from a shell like
>
>   soffice 2>log.txt
>
> do the "Send as E-mail" steps, terminate LO, and attach the generated log.txt
> file here, that might be a quick way to get a better idea what's going wrong
> for you.
>
>  ------------------------------
> You are receiving this mail because:
>
>    - You reported the bug.
>
>
Comment 5 jcc.vanniel 2014-03-21 21:37:55 UTC
Created attachment 96189 [details]
attachment-21346-1.dat
Comment 6 jcc.vanniel 2014-03-21 21:37:55 UTC
Created attachment 96190 [details]
log.txt
Comment 7 Stephan Bergmann 2014-03-24 11:35:22 UTC
You have probably not specified a mail program to use in LibreOffice at "Tools - Options... - Internet - E-mail - E-mail program" (right?), so senddoc is called without a --mailclient argument; your MAILER environment variable is probably unset (what does "echo $MAILER" output in a shell?); so senddoc falls back to calling /usr/bin/xdg-open.  And for whatever reason (beyond the scope of LibreOffice), xdg-open on your system will open a browser when given a mailto URL.

Thus closing as NOTOURBUG for now.  Feel free to reopen if this is something that could be fixed on the LibreOffice end after all (i.e., you did provide a "Tools - Options... - Internet - E-mail - E-mail program", or have a MAILER environment variable that LibreOffice should handle properly).
Comment 8 jcc.vanniel 2014-03-24 13:45:19 UTC
Stephan.
Thx for the help.
This gave the solution.
Indeed not an BUG.
Kind regards, Jan van Niel

op 24-03-14 12:35, bugzilla-daemon@freedesktop.org schreef:
> Stephan Bergmann <mailto:sbergman@redhat.com> changed bug 76283 
> <https://bugs.freedesktop.org/show_bug.cgi?id=76283>
> What 	Removed 	Added
> Status 	NEEDINFO 	RESOLVED
> Resolution 	--- 	NOTOURBUG
>
> *Comment # 7 <https://bugs.freedesktop.org/show_bug.cgi?id=76283#c7> 
> on bug 76283 <https://bugs.freedesktop.org/show_bug.cgi?id=76283> from 
> Stephan Bergmann <mailto:sbergman@redhat.com> *
> You have probably not specified a mail program to use in LibreOffice at "Tools
> - Options... - Internet - E-mail - E-mail program" (right?), so senddoc is
> called without a --mailclient argument; your MAILER environment variable is
> probably unset (what does "echo $MAILER" output in a shell?); so senddoc falls
> back to calling /usr/bin/xdg-open.  And for whatever reason (beyond the scope
> of LibreOffice), xdg-open on your system will open a browser when given a
> mailto URL.
>
> Thus closing as NOTOURBUG for now.  Feel free to reopen if this is something
> that could be fixed on the LibreOffice end after all (i.e., you did provide a
> "Tools - Options... - Internet - E-mail - E-mail program", or have a MAILER
> environment variable that LibreOffice should handle properly).
> ------------------------------------------------------------------------
> You are receiving this mail because:
>
>   * You reported the bug.
>