Download it now!
Bug 76332 - Same Strings Shared between Impress and Draw: Problem in some Localizations
Summary: Same Strings Shared between Impress and Draw: Problem in some Localizations
Status: RESOLVED DUPLICATE of bug 84208
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: SD-Shared-Code
  Show dependency treegraph
 
Reported: 2014-03-18 19:14 UTC by Valter Mura
Modified: 2017-11-30 14:16 UTC (History)
9 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Valter Mura 2014-03-18 19:14:11 UTC
As anticipated in the Localization mailing list, Draw and Impress shares the same strings for most part of their interface.

Our problem is that, specifically, we need to render (translate) the same word in different ways:

- Slide > Diapositiva (in Impress)

- Slide > Pagina (in Draw)

But we cannot get that, due to the two programs share the same strings.
Comment 1 Cor Nouws 2014-03-18 22:28:22 UTC
Hi Valter

Indeed, in the Dutch language interface it would be more logic to have 'Dia' and 'Pagina' too.
But we live with 'Dia' for both since a long time..

Cor
Comment 2 Dennis Roczek 2014-03-23 12:09:06 UTC
Just for the reference: at discuss@de.libreoffice.org is a discussion ongoing to split these two term (or better saying requesting the split) as the actual translation is not optimal and can be confusing...
Comment 3 Jochen 2014-03-23 13:05:46 UTC
IMHO not a "localization"-problem but a "UI"-problem.
I´ve changed component to "UI"
Comment 4 Harald Koester 2014-03-24 21:22:07 UTC
Hence not only an Italian problem, summary changed.

In Draw I found the term "slide" at these occurrances:
(1) Menu: Edit > Undo|Redo > (if page has been inserted, deleted or renamed)
(2) Menu: Edit > Delete Slide
(3) Menu: Insert > Slide
(4) Menu: Insert > Duplicate Slide
(5) If you create new pages the assigned default name are Slide 1, Slide 2,...

In Impress I found the term "Page" at one occurrance, where it should be changed: Menu: Insert > Fields > Page number, Page Count

But for both cases there may be more occurrances.
Comment 5 Harald Koester 2014-03-25 11:29:29 UTC
Another occurrence of "Slides" in Draw:
Open Navigator and move cursor above symbols at the top of the Navigator Dialog. In both, tips and extended tips, the term "slide" is used.
Comment 6 Joel Madero 2015-05-02 15:40:53 UTC Comment hidden (obsolete)
Comment 7 Adolfo Jayme 2015-05-07 22:48:09 UTC
Still a problem in 4.4.
Comment 8 QA Administrators 2016-09-20 09:36:43 UTC Comment hidden (obsolete)
Comment 9 Harald Koester 2016-09-23 21:11:27 UTC
(In reply to Harald Koester from comment #4)

The behaviour has changed (version 5.2.1):

> In Draw I found the term "slide" at these occurrances:
> (1) Menu: Edit > Undo|Redo > (if page has been inserted, deleted or renamed)
"Slide" still exist here.

> (2) Menu: Edit > Delete Slide
Now "Delete Page". OK.

> (3) Menu: Insert > Slide
Now "New Page". OK.

> (4) Menu: Insert > Duplicate Slide
Now "Duplicate Page" OK.

> (5) If you create new pages the assigned default name are Slide 1, Slide
> 2,...
"Slide" still exists here. Slide is also used in Navigator as tipp if you move the mouse pointer above the page symbols.


> In Impress I found the term "Page" at one occurrance, where it should be
> changed: Menu: Insert > Fields > Page number, Page Count
"Page" still exists here.

Hence some improvements but not all occurances are corrected.
Comment 10 Xisco Faulí 2017-09-29 08:48:05 UTC Comment hidden (obsolete)
Comment 11 Harald Koester 2017-10-31 16:43:20 UTC
Checked again with version 5.4.2 (64 bit, Win10). The occurences mentioned in comment 9 are still not correct.
Comment 12 Heiko Tietze 2017-11-01 12:07:30 UTC
(In reply to Dennis Roczek from comment #2)
> Just for the reference: at discuss@de.libreoffice.org is a discussion
> ongoing to split these two term (or better saying requesting the split) as
> the actual translation is not optimal and can be confusing...

Please summarize the outcome of this discussion.
Comment 13 Dennis Roczek 2017-11-01 13:14:21 UTC
@heiko: http://nabble.documentfoundation.org/Verwendung-des-Begriffs-quot-Folie-quot-in-Draw-td4102456.html

Short summary: split the translation where it is possible.
Comment 14 Heiko Tietze 2017-11-01 14:14:21 UTC
(In reply to Dennis Roczek from comment #13)
> @heiko:
> http://nabble.documentfoundation.org/Verwendung-des-Begriffs-quot-Folie-quot-
> in-Draw-td4102456.html
> 
> Short summary: split the translation where it is possible.

For example, we should label the slides in Impress as this and pages in Draw. That should be the fact, another example that would need a solution is 'master' (master slide vs. master pages). 

But I wonder if this discussion is still relevant after strings have been moved into extra resources (https://opengrok.libreoffice.org/xref/core/sd/inc/strings.hrc)
Comment 15 Sophia Schroeder 2017-11-01 15:06:37 UTC
Just opened LO Draw 5.4.2.2 German (Windows 10 1709 64Bit) and can still confirm this issue. Menu "Einfügen" (Insert): First two entries: "Folie einfügen" (Insert Slide) and "Folie doppeln" (Duplicate Slide). Were good to distinguish between Impress and Draw better to make translator's and user's life easier. Don't know what to do on technical side but happy and willing to help in later correct translation. Added me to cc.
Comment 16 Yousuf Philips (jay) (retired) 2017-11-15 20:10:58 UTC
This has been fixed and any other remaining issues that havent been should be filed as new bugs.

*** This bug has been marked as a duplicate of bug 84208 ***
Comment 17 Harald Koester 2017-11-30 14:16:55 UTC
(In reply to Yousuf Philips (jay) from comment #16)
> This has been fixed and any other remaining issues that havent been should
> be filed as new bugs.

Done: Remaining issues filed in new bug 114175.