Download it now!
Bug 76349 - FILEOPEN: DOCX : 'Page Break - Column Break' (in 1 column per page) not correctly imported
Summary: FILEOPEN: DOCX : 'Page Break - Column Break' (in 1 column per page) not corre...
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: Other All
: medium normal
Assignee: Justin L
URL:
Whiteboard: target:5.3.0 target:5.2.1 target:5.2.2
Keywords:
Depends on: 74153
Blocks:
  Show dependency treegraph
 
Reported: 2014-03-19 10:04 UTC by Jorendc
Modified: 2020-05-24 14:02 UTC (History)
8 users (show)

See Also:
Crash report or crash signature:


Attachments
patch which converts column-break to page-break (documenting alternative fix) (3.98 KB, patch)
2016-06-13 09:40 UTC, Justin L
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jorendc 2014-03-19 10:04:53 UTC
This bug is about the FILEOPEN part of bug 74153. Thanks to the fix of bug 74153, the column break is being preserved during roundtrip. Only issue left is the fact it isn't imported correctly in LibreOffice.

+++ This bug was initially created as a clone of Bug #74153 +++

Steps to reproduce :
1] Open attached document in LO 

Current behavior :
Document containing Column break(1 column per page) is displayed as a document without a Column break.

Expected behavior :
Text 'This is text in the 2nd page (after a column break).' should be on the second page.

Tested using Windows 8.1 with LibreOffice Version: 4.3.0.0.alpha0+
Build ID: 87efec9cc27b18aa09e50c289b503ba1127eb0b8
TinderBox: Win-x86@39, Branch:master, Time: 2014-03-18_02:50:50

Kind regards,
Joren
Comment 1 Jorendc 2014-03-19 10:05:40 UTC
Already confirmed in bug 74153 thanks to Thomas.
Comment 2 Jorendc 2014-07-18 19:09:25 UTC
"attached document" is refering to https://bugs.freedesktop.org/attachment.cgi?id=92925
Comment 3 Jorendc 2014-07-18 19:10:27 UTC
Still repro Version: 4.4.0.0.alpha0+
Build ID: eddd7646d672ea9b0561dacb09da224d098e531e
TinderBox: MacOSX-x86@49-TDF, Branch:master, Time: 2014-07-18_06:13:47
Comment 4 Jorendc 2015-01-13 20:13:52 UTC
Still reproducible, Windows x64 with LibreOffice Version: 4.4.0.2
Build ID: a3603970151a6ae2596acd62b70112f4d376b990
Locale: nl_BE
Comment 5 Xisco Faulí 2015-08-25 15:36:09 UTC
Problem still present in

Version: 5.0.0.5
Build ID: 1b1a90865e348b492231e1c451437d7a15bb262b
Locale: es-ES (es_ES)

on Windows 7 (64-bit)
Comment 6 Timur 2016-02-22 11:16:17 UTC
Looks like inherited.
Comment 7 Justin L 2016-06-11 08:47:46 UTC
submitted potential fix:  https://gerrit.libreoffice.org/26181 tdf#76349 writer: treat single column break as page break
Comment 8 Justin L 2016-06-13 09:40:50 UTC
Created attachment 125636 [details]
patch which converts column-break to page-break (documenting alternative fix)

Before discovering the simpler fix, I spent a week coming up with this almost-working fix which would have converted the column break to a page break. However, it didn't import identically in Word - there was an extra empty paragraph after the page break, and it is a bit of a messy solution.

The column break is read from the file into DomainMapper.cxx's lcl_text() where a break is identified (simply as page or column) and a deferBreak is called.  Before the number of columns has been read from the file, the deferred break is processed by lcl_utext and is inserted as a BreakType_COLUMN_BEFORE.
Comment 9 Commit Notification 2016-06-23 15:08:57 UTC
Justin Luth committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=2721111437706372eaac9bf1d748723196c573ac

tdf#76349 writer: treat single-column break as page break

It will be available in 5.3.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 10 Commit Notification 2016-07-13 07:46:39 UTC
Justin Luth committed a patch related to this issue.
It has been pushed to "libreoffice-5-2":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=5647eb6f8ef5828ce14973a91946d5d7cdfeae30&h=libreoffice-5-2

tdf#76349 writer: treat single-column break as page break

It will be available in 5.2.1.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 11 Commit Notification 2016-08-30 20:01:24 UTC
Justin Luth committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=93d7fc90b57bb08052299c94fa0a28bb8f494a9c

tdf#76349 writer: make 1column-as-page break a compatibility option

It will be available in 5.3.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 12 Commit Notification 2016-08-31 15:39:59 UTC
Justin Luth committed a patch related to this issue.
It has been pushed to "libreoffice-5-2":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=9de59d3c63a27793ed8afe74f19d7e79bcfedead&h=libreoffice-5-2

tdf#76349 writer: make 1column-as-page break a compatibility option

It will be available in 5.2.2.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 13 Commit Notification 2016-09-02 12:38:20 UTC
Justin Luth committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=52b29c60801cf75364fd8275a22e812797cb184d

tdf#76349 SpacingWithoutBorders: enable .doc RT

It will be available in 5.3.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.