Download it now!
Bug 76406 - FILESAVE: xlsx files always exported with comments shown
Summary: FILESAVE: xlsx files always exported with comments shown
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.2.0.4 release
Hardware: Other Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords: regression
: 81080 (view as bug list)
Depends on:
Blocks: 107728
  Show dependency treegraph
 
Reported: 2014-03-20 16:04 UTC by Chris
Modified: 2017-05-09 14:58 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Chris 2014-03-20 16:04:46 UTC
Problem description: xlsx documents with comments always have comments showing. This is identical to bug 46278; however this bug is marked solved.

Steps to reproduce:
1. Save document with comments as xlsx in Libreoffice or Excel
2. Open document in Libreoffice.

Current behavior: All comment will be shown.

Expected behavior: Comments should be only show when you roll the mouse over the cell with the comment. Since there is no easy way to hide all comments, this makes certain spreadsheets very difficult to read.

              
Operating System: Windows 7
Version: 4.2.0.4 release
Comment 1 Andras Timar 2014-03-20 21:29:33 UTC
I confirm the export bug, i.e. when a document is saved from LibreOffice in xlsx format, all comments will be shown on reopen. However, I cannot confirm it with an xlsx saved from Excel 2010.
Comment 2 Chris 2014-03-20 22:16:03 UTC
(In reply to comment #1)
> I confirm the export bug, i.e. when a document is saved from LibreOffice in
> xlsx format, all comments will be shown on reopen. However, I cannot confirm
> it with an xlsx saved from Excel 2010.

My mistake. This appears to only be an export bug. Files saved in Excel 2010 open correctly.
Comment 3 tommy27 2014-07-11 04:52:00 UTC
*** Bug 81080 has been marked as a duplicate of this bug. ***
Comment 4 ign_christian 2014-07-11 05:03:03 UTC
I saw it's fixed in 4.3.0.2 - Ubuntu 12.04 x86 if reproduce from scratch.

But bug is still there in 4.2.5.2, don't know whether fix will be backported to 4.2.x ?
Comment 5 tommy27 2014-07-11 05:14:34 UTC
(In reply to comment #0)
> Problem description: xlsx documents with comments always have comments
> showing. This is identical to bug 46278; however this bug is marked solved.

yes the issue was fixed in LibO 3.6.3 and was working fine till 4.1.5
I start reproducing again the bug in 4.2.0.4 and following releases hence this is a regression.

interestingly those .xlsx saved in LibO will open with all comments shown in LibO but will load correctly (hidden status) in Excel Viewer
Comment 6 tommy27 2014-07-11 05:19:14 UTC
yes, it is FIXED again in 4.3.0.2 under Win7x64.
I set status to RESOLVED WORKSFORME

I add Noel Power (who fixed it in 3.6.3) to CC list.
probably he knows the code and maybe he can help to backport the fix that actually affects the whole 4.2.x codeline
Comment 7 jan 2014-07-11 09:08:39 UTC
Opening the affected spreadsheet in Kingsoft Office also works as it should, saving to xlsx and opening it in Calc also works properly until you save it again in Calc and reopen it - comments will stick around again.

Current Ubuntu 14.04 LTS will have LO 4.2 in official repos through the whole cycle. To get 4.3 in Ubuntu 14.04 LTS one has to either install LO from downloaded executable or via PPA. Since official repos are allways prefered it would be better to backport the fix to 4.2 imho.
Comment 8 Chris 2014-07-11 15:10:29 UTC
I still see the bug in 4.2.5.2 on Win7x64.
(In reply to comment #4)
> I saw it's fixed in 4.3.0.2 - Ubuntu 12.04 x86 if reproduce from scratch.
> 
> But bug is still there in 4.2.5.2, don't know whether fix will be backported
> to 4.2.x ?