Bug Hunting Session
Bug 76534 - Windows Explorer context menu New option doesn't work for OpenDocument files
Summary: Windows Explorer context menu New option doesn't work for OpenDocument files
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
4.1.5.3 release
Hardware: Other Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2014-03-24 02:49 UTC by mikecorbeil
Modified: 2018-07-25 10:57 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description mikecorbeil 2014-03-24 02:49:22 UTC
Problem description:

A full description is provided with the first post of the following thread.

http://ask.libreoffice.org/en/question/31748/how-to-make-win-explorer-context-menu-new-option-work-for-opendocument-files-creation-after-installing-libreoffice-415

Steps to reproduce:
1. Uninstalled Libreoffice (LO) 3.6.5

2. Installed LO 4.2.2, without the Calc and Maths components or applications, so only installing Writer, Draw and Impress.

3. Double-clicked on an existant .odt file to see that LO will start up and load the file, and this worked fine.

4. Tried to create a new and blank .odt file by using the Explorer context menu New option and this failed; doing nothing.

5. Tried, using same method, to create new Impress and Draw files, and this also failed.

6. Tried the other New file options and these all work.

7. Uninstalled LO 4.2.2 and then installed 4.1.5 to see if this would work or have the same problem, and it has the same problem.

8. Uninstalled 4.1.5 and reinstalled 3.6.5, and now the New files options works again, as before, for creating new OD files.

Current behavior:

LO 3.6.5 is working correctly for my needs.

Expected behavior:

For the Explorer context menu New option to work with LO 4.1.5 and 4.2.2.  I regularly create new document files in different directories/folders based on topics, so the New option is definitely helpful.
              
Operating System: Windows XP
Version: 4.1.5.3 release
Comment 1 tommy27 2014-07-12 08:17:56 UTC
is issue still reproducible with latest 4.2.5.2?
Comment 2 Urmas 2014-07-12 11:50:59 UTC
For some reason, ShellNew subkey is created for "HKCR\.od?\<Type.Name.1>" registry key instead of proper "HKCR\.od?".
Comment 3 mikecorbeil 2014-07-16 11:24:14 UTC
(In reply to comment #1)
> is issue still reproducible with latest 4.2.5.2?

I haven't tried 4.2.5.2 yet.  Downloaded 4.2.5 from LibreOffice.org yesterday evening and plan to install and try it sometime either later today or else tomorrow, Friday at the latest.

If the same problem occurs with 4.2.5, then I'll try to make sure to add an update for this reply to you.
Comment 4 mikecorbeil 2014-07-16 11:27:03 UTC
(In reply to comment #2)
> For some reason, ShellNew subkey is created for "HKCR\.od?\<Type.Name.1>"
> registry key instead of proper "HKCR\.od?".

Would that be happening uniquely to me, or is it a common problem?  You didn't mention whether anyone else reported this problem, so I'm assuming that it may possibly be only in my case.
Comment 5 mikecorbeil 2014-07-20 20:04:57 UTC
(In reply to comment #1)
> is issue still reproducible with latest 4.2.5.2?

Yes.  I just installed 4.2.5.2 and the same problem is happening.  New LibreOffice files can't be created using the corresponding options in the New menu or sub-menu of the Windows Explorer right-click/context menu.

I can create a regular text, .txt, file, change the extension to .odt, and then double-click on the file for it to be opened in LO Writer, after which around a third of a page of junk characters needs to be cleared from the file in order to have a clean file.  So there's this work-around, which is simple and easy, but it clearly isn't something LO users should need to do.

The New file options for LO do nothing.  No files are created anyway.  If anything does happen, then it isn't visible to me.  When a user selects to create a new ODT file, f.e., using the main LO window that permits choosing Writer, Impress, Calc, ..., then the default folder for saving the file is always set to the user's Documents folder, so I just checked it to see if the new LO files might've been created there and there's nothing.  So these files evidently aren't being created at all, anywhere.


I'm still using Windows XP SP 3 and don't think this should be the cause of the problem, but it'll take experts with LO code to be able to speak about this.
Comment 6 mikecorbeil 2014-07-20 21:31:25 UTC
(In reply to comment #2)
> For some reason, ShellNew subkey is created for "HKCR\.od?\<Type.Name.1>"
> registry key instead of proper "HKCR\.od?".

I just installed LO 4.2.5.2, tried to create a new .odt file using the New sub-menu of the Windows Explorer right-click/context menu, and nothing happened.  The file wasn't created.

Using regedt32 to check the Windows (XP SP 3) registry about what you say, the following is found (using " | " rather than \ for delimiter and = to indicate key values):

*) HKCR is for HKEY_CLASSES_ROOT in regedt32 for Win XP SP 3, as you most surely know, and what I find is :

HKEY_CLASSES_ROOT | .odt | LibreOffice.WriterDocument.1 | ShellNew | Filename =  C:\Program Files\LibreOffice 4\share\template\shellnew\soffice.odt

*) The other instances of .odt for ShellNew are the following:

HKEY_LOCAL_MACHINE | .odt | LibreOffice.WriterDocument.1 | ShellNew | Filename =  C:\Program Files\LibreOffice 4\share\template\shellnew\soffice.odt

HKEY_USERS | S-1-5-21-2032040097-1977504745-2228826596-1003-{ED1FC765-E35E-4C3D-BF15-2C2B11260CE4}-0 | Software | OpenOffice.org | OpenOffice.org 3.2 |ShellNew | ...

The ... is for the following:

soffice.odg = 1
soffice.odp = 1
soffice.ods = 1
soffice.odt = 1

HKEY_USERS | S-1-5-21-2032040097-1977504745-2228826596-1005-{ED1FC765-E35E-4C3D-BF15-2C2B11260CE4}-0 | Software | The Document Foundation | LibreOffice 3.6 | ShellNew | ...

The ... is the same as shown above.

---------------------

Type.Name isn't found anywhere in my Windows registry, so there's no Type.Name.1.
Comment 7 QA Administrators 2015-09-04 02:49:03 UTC Comment hidden (obsolete)
Comment 8 QA Administrators 2016-09-20 10:28:40 UTC Comment hidden (obsolete)
Comment 9 Mike Kaganski 2018-07-25 10:57:17 UTC
The "New" submenu in Windows works correctly for entries added by LibreOffice in current versions (at least since v.5.1; and just tested with 6.1.0.2); closing WORKSFORME.