Bug Hunting Session
Bug 76833 - FORMCONTROLS: Input Field: Value cannot be added or edited
Summary: FORMCONTROLS: Input Field: Value cannot be added or edited
Status: RESOLVED DUPLICATE of bug 75319
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.2.2.1 release
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords: possibleRegression
Depends on:
Blocks:
 
Reported: 2014-03-31 12:47 UTC by Martin L ü c h e m
Modified: 2015-12-15 10:55 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Martin L ü c h e m 2014-03-31 12:47:19 UTC
Problem description: 
When trying to enter a simple input field I cannot do this because values cannot be edited

Steps to reproduce:
1. Add value for existing input field (out of template)
2. ....
3. ....

Current behavior:
Neither new input fields can be entered nor values in existing input fields can be edited

Expected behavior:
Case 1: Input fields can be added
Case 2: When clicking existign field values can be added or entered

              
Operating System: Windows 7
Version: 4.2.2.1 release
Last worked in: 4.1.5.3 release
Comment 1 sophie 2014-04-14 12:18:36 UTC
Hi, can you describe how you enter the edit field? The behavior has changed since 4.2.x series and now the field is edited in line and no more by clicking on it. Set as needinfo - Sophie
Comment 2 Robert Großkopf 2014-04-19 17:39:28 UTC
There seems to be something broken in creating an inputfield. 
If I try Insert → Fields → Other → Variables → Type → Input field there couldn't be created any field. Every other possibility like Name or Reference is greyed out. You could press the button "Insert" and nothing happens.

It has been also changed how to input new values. Now it works directly by marking the field and writing down. You could also add new values by pressing Ctrl+Shift+F9.

Seems we have to change the title to declare the bug while inserting such a field.

My system: OpenSUSE 12.3 64bit rpm
LO 4.2.4.1 (not working to insert a field)
LO 4.1.6.1 (working to insert a field)
Comment 3 Owen Genat (retired) 2014-10-05 12:53:55 UTC
(In reply to robert from comment #2)
> There seems to be something broken in creating an inputfield. 
> If I try Insert → Fields → Other → Variables → Type → Input field there
> couldn't be created any field. Every other possibility like Name or
> Reference is greyed out. 

Robert, according to the help page:

https://help.libreoffice.org/Writer/Adding_Input_Fields

... it is the Functions tab that is used. I find it is also possible to create a User Field (Variables tab) and then use this as an input field. This would seem to be a duplicate of bug 75319.

*** This bug has been marked as a duplicate of bug 75319 ***
Comment 4 Robinson Tryon (qubit) 2015-12-15 10:55:09 UTC
Migrating Whiteboard tags to Keywords: (possibleRegression)
[NinjaEdit]