Bug Hunting Session
Bug 76844 - Other: File > Wizards > Web Pages crashes LibreOffice 4.2.2.1 (Windows)
Summary: Other: File > Wizards > Web Pages crashes LibreOffice 4.2.2.1 (Windows)
Status: RESOLVED DUPLICATE of bug 92404
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
4.2.2.1 release
Hardware: All Windows (All)
: high blocker
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
: 89213 (view as bug list)
Depends on:
Blocks:
 
Reported: 2014-03-31 15:36 UTC by martinsaffron
Modified: 2015-09-19 07:31 UTC (History)
10 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description martinsaffron 2014-03-31 15:36:52 UTC
Problem description: Using the Web Page Wizard crashes LibreOffice 4.2.2.1 running on Windows 8.1.

Steps to reproduce:
1. Select File > Wizards > Web Pages from the Menu bar
2. Proceed through the next 6 steps in any way
3. Click Preview

Current behavior: All LibreOffice modules freeze

Expected behavior: Document previewed in default browser

              
Operating System: Windows 8
Version: 4.2.2.1 release
Comment 1 sophie 2014-04-14 13:55:47 UTC
Hi, I do not reproduce with Version: 4.2.3.3 Build ID: 882f8a0a489bc99a9e60c7905a60226254cb6ff0 Ubuntu 13.10. The document is loaded in the browser and LibreOffice applications don't freeze - Sophie
Comment 2 immanuelg 2014-07-27 17:22:14 UTC
TESTING
Linux Mint 17
LO 4.2.6.2

Followed the steps and could not reproduce.
Preview displays as link to document in local page on Firefox 31.
Comment 3 Ken Biondi 2014-07-27 18:43:58 UTC
I confirmed this bug in Writer, Impress, Draw, Math, Base and Calc.  LO becomes unresponsive and task manager must be used to close LO.
 
I'm changing status to highest blocker since this bug always causes a freeze.

I tested using:

x86-64
WIN 8
Version: 4.2.5.2
Build ID: 61cb170a04bb1f12e77c884eab9192be736ec5f5
Comment 4 Kevin Suo 2014-08-17 06:05:17 UTC
bug 76845 and bug 76844 may be the same issue. One freezes at step "Finish", one at "Preveiw in browser".
Added as see also.
Comment 5 Björn Michaelsen 2014-08-21 12:21:07 UTC
(This is an automated message.)

LibreOffice development currently prioritizes bugs with the so called MAB (most annoying bugs) -- as this bug has not run through that process (including writing a short rationale for this bug being a candidate and other who are watching the tracker bug silently approving that rationale etc.) its priority is set to high. Note this is effectively no change in the urgency assigned to this bug, as we are currently not making a difference between high and highest and severity is untouched.

You can find out more about MABs and how the process works by contacting libreoffice qa on irc:

 http://webchat.freenode.net/?channels=libreoffice-qa

The QA wiki page also gives you hints on how to get in contact with the team (if IRC fails you, your next best choice is the mailing list):

 https://wiki.documentfoundation.org/QA
Comment 6 Shinji Enoki 2015-01-06 06:05:26 UTC
I was reproduced in the following environments.

LibO: 4.4.0 rc1 (TDF)
OS: Debian wheezy, Windows7

1. Start Writer
2. Select Mene File > Wizards > Web Pages

Crash Writer
Comment 7 Julien Nabet 2015-02-08 11:46:10 UTC
*** Bug 89213 has been marked as a duplicate of this bug. ***
Comment 8 Julien Nabet 2015-02-08 12:45:33 UTC
Xisco: thought you might be interested in this one.

On pc Debian x86-64 with master sources updated yesterday, I don't reproduce this but noticed some logs:
warn:fwk:26373:1:framework/source/fwi/threadhelp/transactionmanager.cxx:257: TransactionManager...: Owner instance not correctly initialized yet. Call was rejected! Normally it's an algorithm error ... wrong use of class!
warn:fwk:26373:1:framework/source/fwi/threadhelp/transactionmanager.cxx:257: TransactionManager...: Owner instance not correctly initialized yet. Call was rejected! Normally it's an algorithm error ... wrong use of class!
warn:legacy.osl:26373:1:xmloff/source/core/xmlerror.cxx:181: An error or a warning has occurred during XML import/export!
Error-Id: 0x10020002
    Flags: 1 WARNING
    Class: 2 FORMAT
    Number: 2
Parameters:
    0: style:font-name-asian
    1: HG Mincho Light J
Exception-Message: 

warn:legacy.osl:26373:1:xmloff/source/core/xmlerror.cxx:181: An error or a warning has occurred during XML import/export!
Error-Id: 0x10020002
    Flags: 1 WARNING
    Class: 2 FORMAT
    Number: 2
Parameters:
    0: style:font-name-complex
    1: Arial Unicode MS
Exception-Message: 

warn:legacy.osl:26373:1:xmloff/source/core/xmlerror.cxx:181: An error or a warning has occurred during XML import/export!
Error-Id: 0x10020002
    Flags: 1 WARNING
    Class: 2 FORMAT
    Number: 2
Parameters:
    0: style:font-name-asian
    1: HG Mincho Light J
Exception-Message: 

warn:legacy.osl:26373:1:xmloff/source/core/xmlerror.cxx:181: An error or a warning has occurred during XML import/export!
Error-Id: 0x10020002
    Flags: 1 WARNING
    Class: 2 FORMAT
    Number: 2
Parameters:
    0: style:font-name-complex
    1: Arial Unicode MS
Exception-Message: 

warn:legacy.osl:26373:1:xmloff/source/core/xmlerror.cxx:181: An error or a warning has occurred during XML import/export!
Error-Id: 0x10020002
    Flags: 1 WARNING
    Class: 2 FORMAT
    Number: 2
Parameters:
    0: style:font-name-asian
    1: HG Mincho Light J
Exception-Message: 

warn:legacy.osl:26373:1:xmloff/source/core/xmlerror.cxx:181: An error or a warning has occurred during XML import/export!
Error-Id: 0x10020002
    Flags: 1 WARNING
    Class: 2 FORMAT
    Number: 2
Parameters:
    0: style:font-name-complex
    1: Arial Unicode MS
Exception-Message: 

warn:legacy.osl:26373:1:xmloff/source/core/xmlerror.cxx:181: An error or a warning has occurred during XML import/export!
Error-Id: 0x10020002
    Flags: 1 WARNING
    Class: 2 FORMAT
    Number: 2
Parameters:
    0: style:font-name-asian
    1: HG Mincho Light J
Exception-Message: 

warn:legacy.osl:26373:1:xmloff/source/core/xmlerror.cxx:181: An error or a warning has occurred during XML import/export!
Error-Id: 0x10020002
    Flags: 1 WARNING
    Class: 2 FORMAT
    Number: 2
Parameters:
    0: style:font-name-complex
    1: Arial Unicode MS
Exception-Message: 

warn:unotools.config:26373:1:unotools/source/config/configitem.cxx:437: ignoring XHierarchicalNameAccess to /org.openoffice.Office.WriterWeb/Content/Display/ShowContentTips Exception: Display/ShowContentTips
warn:unotools.config:26373:1:unotools/source/config/configitem.cxx:437: ignoring XHierarchicalNameAccess to /org.openoffice.Office.WriterWeb/Content/Display/ShowContentTips Exception: Display/ShowContentTips
warn:legacy.tools:26373:1:sfx2/source/doc/objmisc.cxx:1265: Don't close the medium when loading documents!
Comment 9 Julien Nabet 2015-02-08 13:30:26 UTC
Putting a break in framework::TransactionManager::TransactionManager, I noticed that it was called twice.

1)
Breakpoint 3, framework::TransactionManager::TransactionManager (this=0x70dd5d0)
    at /home/julien/compile-libreoffice/libreoffice/framework/source/fwi/threadhelp/transactionmanager.cxx:40
40	    m_aBarrier.open();
(gdb) bt
#0  framework::TransactionManager::TransactionManager (this=0x70dd5d0)
    at /home/julien/compile-libreoffice/libreoffice/framework/source/fwi/threadhelp/transactionmanager.cxx:40
#1  0x00002aaac65f269a in framework::TransactionBase::TransactionBase (this=0x70dd5d0)
    at /home/julien/compile-libreoffice/libreoffice/framework/inc/threadhelp/transactionbase.hxx:35


#2  0x00002aaac65eeb81 in framework::DispatchProvider::DispatchProvider (this=0x70dd5a0, rxContext=uno::Reference to (cppu::ComponentContext *) 0x7664b0, 
    xFrame=uno::Reference to ((anonymous namespace)::Frame *) 0x7a38378) at /home/julien/compile-libreoffice/libreoffice/framework/source/dispatch/dispatchprovider.cxx:67
#3  0x00002aaac66bb6f3 in (anonymous namespace)::Frame::initListeners (this=0x7a38350) at /home/julien/compile-libreoffice/libreoffice/framework/source/services/frame.cxx:523
#4  0x00002aaac66c5baa in com_sun_star_comp_framework_Frame_get_implementation (context=0x7664b0)
    at /home/julien/compile-libreoffice/libreoffice/framework/source/services/frame.cxx:3291


#5  0x00002aaaad920669 in cppuhelper::ServiceManager::Data::Implementation::createInstance (this=0x684d40, context=uno::Reference to (cppu::ComponentContext *) 0x7664b0, 
    singletonRequest=false) at /home/julien/compile-libreoffice/libreoffice/cppuhelper/source/servicemanager.cxx:685




2)
Breakpoint 3, framework::TransactionManager::TransactionManager (this=0x7a383c8)
    at /home/julien/compile-libreoffice/libreoffice/framework/source/fwi/threadhelp/transactionmanager.cxx:40
40	    m_aBarrier.open();
(gdb) bt
#0  framework::TransactionManager::TransactionManager (this=0x7a383c8)
    at /home/julien/compile-libreoffice/libreoffice/framework/source/fwi/threadhelp/transactionmanager.cxx:40
#1  0x00002aaac65f269a in framework::TransactionBase::TransactionBase (this=0x7a383c8)
    at /home/julien/compile-libreoffice/libreoffice/framework/inc/threadhelp/transactionbase.hxx:35


#2  0x00002aaac66bb0f3 in (anonymous namespace)::Frame::Frame (this=0x7a38350, xContext=uno::Reference to (cppu::ComponentContext *) 0x7664b0)
    at /home/julien/compile-libreoffice/libreoffice/framework/source/services/frame.cxx:512
#3  0x00002aaac66c5b6a in com_sun_star_comp_framework_Frame_get_implementation (context=0x7664b0)
    at /home/julien/compile-libreoffice/libreoffice/framework/source/services/frame.cxx:3288



#4  0x00002aaaad920669 in cppuhelper::ServiceManager::Data::Implementation::createInstance (this=0x684d40, context=uno::Reference to (cppu::ComponentContext *) 0x7664b0, 
    singletonRequest=false) at /home/julien/compile-libreoffice/libreoffice/cppuhelper/source/servicemanager.cxx:685

Matus/Stephan: is it normal 2 instances of transactionmanager are created, shouldn't it be a singleton?
Comment 10 Stephan Bergmann 2015-02-09 07:47:59 UTC
(In reply to Julien Nabet from comment #9)
> Matus/Stephan: is it normal 2 instances of transactionmanager are created,
> shouldn't it be a singleton?

framework's Frame service impl derives from TransactionBase which in turn has a non-static data member of type TransactionManager
Comment 11 Julien Nabet 2015-09-19 07:31:35 UTC
Multiselection pb?
If yes, it couldn't be reproduced on Linux because getFiles implementation returned only 1 file in Linux.
See http://nabble.documentfoundation.org/Multiselection-needs-work-tt4153207.html

Don't hesitate to reopen this tracker if you can reproduce this with last LO version 5.0.1 or if you have the pb even with 1 file selected.

*** This bug has been marked as a duplicate of bug 92404 ***