Bug 76887 - VIEWING: can't filter on numeric fields in microsoft access databases
Summary: VIEWING: can't filter on numeric fields in microsoft access databases
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Base (show other bugs)
Version:
(earliest affected)
4.1.5.3 release
Hardware: Other Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-04-01 08:06 UTC by pasqual milvaques
Modified: 2016-01-28 13:57 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
testcase to reproduce the problem (10.65 KB, application/zip)
2014-04-01 08:11 UTC, pasqual milvaques
Details

Note You need to log in before you can comment on or make changes to this bug.
Description pasqual milvaques 2014-04-01 08:06:34 UTC
Opening a Microsoft Access (mdb) database in LibreOffice base works ok but when trying to apply a filter, in a numeric field in a table, it fails to be applied without showing any error. Filtering in standard text fields works correctly 

Using autofilter in a numeric fiels works ok
Comment 1 pasqual milvaques 2014-04-01 08:11:38 UTC
Created attachment 96699 [details]
testcase to reproduce the problem

To test the problem open the testcase_filter.odb file (in a windows machine, the mdb file must be in the same directory as the odb)

In the UI enter in the sample_table table and try to apply a standard filter to the num_field field (for example num_field >= 500), the filter is not applied and the UI shows no change
Comment 2 Julien Nabet 2014-07-22 12:46:04 UTC
On Win7 and LO 4.2.5, I can reproduce this.
Comment 3 Alex Thurgood 2015-01-03 17:39:16 UTC
Adding self to CC if not already on
Comment 4 QA Administrators 2016-01-17 20:04:26 UTC
** Please read this message in its entirety before responding **

To make sure we're focusing on the bugs that affect our users today, LibreOffice QA is asking bug reporters and confirmers to retest open, confirmed bugs which have not been touched for over a year.

There have been thousands of bug fixes and commits since anyone checked on this bug report. During that time, it's possible that the bug has been fixed, or the details of the problem have changed. We'd really appreciate your help in getting confirmation that the bug is still present.

If you have time, please do the following:

Test to see if the bug is still present on a currently supported version of LibreOffice (5.0.4 or later)  https://www.libreoffice.org/download/

If the bug is present, please leave a comment that includes the version of LibreOffice and your operating system, and any changes you see in the bug behavior
 
If the bug is NOT present, please set the bug's Status field to RESOLVED-WORKSFORME and leave a short comment that includes your version of LibreOffice and Operating System

Please DO NOT:

- Update the version field
- Reply via email (please reply directly on the bug tracker)
- Set the bug's Status field to RESOLVED - FIXED (this status has a particular meaning that is not appropriate in this case)

If you want to do more to help you can test to see if your issue is a REGRESSION. To do so: 1. Download and install oldest version of LibreOffice (usually 3.3 unless your bug pertains to a feature added after 3.3)

http://downloadarchive.documentfoundation.org/libreoffice/old/

2. Test your bug 3. Leave a comment with your results. 4a. If the bug was present with 3.3 - set version to "inherited from OOo"; 4b. If the bug was not present in 3.3 - add "regression" to keyword


Feel free to come ask questions or to say hello in our QA chat: http://webchat.freenode.net/?channels=libreoffice-qa

Thank you for your help!

-- The LibreOffice QA Team This NEW Message was generated on: 2016-01-17
Comment 5 pasqual milvaques 2016-01-28 13:57:40 UTC
I have tested that the problem is LibreOffice 5.1.0.2 (Windows 10 (32 bits)) and the bug is not present anymore so it can be marked as closed