Bug 77432 - PDF: exporting impress document to pdf does not embed fonts
Summary: PDF: exporting impress document to pdf does not embed fonts
Status: RESOLVED NOTOURBUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Printing and PDF export (show other bugs)
Version:
(earliest affected)
4.2.2.1 release
Hardware: x86-64 (AMD64) Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-04-14 12:17 UTC by Kurt Seebauer
Modified: 2014-06-29 14:34 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Kurt Seebauer 2014-04-14 12:17:29 UTC
I am trying to export impress (.odp) documents as pdf and make it available online. In Impress Version 3.5.5.3 the pdf export dialog offers an option "embed standard fonts" which works perfectly well. 

In version 4.2.2.1 this option has disappeared from the export dialog, instead i find an option under file -> properties -> font -> "embed fonts in document" which does not work. 

I also tried option PDF/A-1a in the export dialog which also does not seem to help. 

"Not work" means the file opens fine in Adobe Reader, but if you look at it using the embedded pdf viewer of Mozilla Firefox the fonts don't appear. 

As an example try this file:
http://ufm-group.de/images/boersenbrief/lohmer_research_03_2014.pdf
It was created with Impress 3.5.5.3 and works.

Not working file:
http://ufm-group.de/images/boersenbrief/lohmer_research_07_2014_nofonts.pdf
It was created wich Impress 4.2.2.1, PDF/A-1a and "embed fonts in document" option. Firefox shows no text. 

Is this a bug, is it a feature? What can i do to make the documents appear correctly?

Contact me, if you need more detail!
Thanks!
Comment 1 Dominik 2014-05-23 20:45:31 UTC
works for me on LO 4.3 beta (no matter if i set the embed font under file -> properties)

could you please verify this?
Comment 2 pierre-yves samyn 2014-05-25 10:33:47 UTC
Hi

(In reply to comment #0)
> "Not work" means the file opens fine in Adobe Reader, but if you look at it
> using the embedded pdf viewer of Mozilla Firefox the fonts don't appear. 
> ...
> Not working file:
> http://ufm-group.de/images/boersenbrief/lohmer_research_07_2014_nofonts.pdf
> It was created wich Impress 4.2.2.1, PDF/A-1a and "embed fonts in document"
> option. Firefox shows no text. 

I can not reproduce the problem either: Firefox shows the text as adobe reader.

In Adobe Reader File Properties Font lists Arial & TimesNewRoman

Have you tried restarting Firefox with a new profile?

I can not reproduce with other documents.

I set status to NEEDINO.

Regards
Pierre-Yves
Comment 3 Maxim Monastirsky 2014-05-25 14:37:53 UTC
Hi,

(In reply to comment #0)
> In Impress Version 3.5.5.3 the pdf export dialog offers an option
> "embed standard fonts" which works perfectly well. 
> 
> In version 4.2.2.1 this option has disappeared from the export dialog,
Indeed, see http://cgit.freedesktop.org/libreoffice/core/commit/?id=feaebe7f93779d5c91c24c31ff91f756c69e9640 for more info.

> instead i find an option under file -> properties -> font -> "embed fonts in
> document" which does not work. 
That option isn't for pdf export.

> Not working file:
> http://ufm-group.de/images/boersenbrief/lohmer_research_07_2014_nofonts.pdf
> It was created wich Impress 4.2.2.1, PDF/A-1a and "embed fonts in document"
> option. Firefox shows no text. 
I can see the text with Firefox 29 under Windows 7.
Comment 4 Kurt Seebauer 2014-06-29 14:34:29 UTC
OK, Firefox 30/Windows 8.1 shows the same file correctly now. Might have been a problem with the embedded firefox pdf viewer. 

I close the Bug with RESOLVED / NOTOURBUG, ok?