Download it now!
Bug 77523 - Regression: Impress tables problem(s): The height of the last row doesn't adjust to the text content;sometimes the edges are not there where the edges of the table are supposed to be
Summary: Regression: Impress tables problem(s): The height of the last row doesn't adj...
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
4.2.4.1 rc
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-04-16 11:43 UTC by Gerry
Modified: 2015-03-07 14:39 UTC (History)
7 users (show)

See Also:
Crash report or crash signature:


Attachments
table selection bug.png (181.48 KB, image/png)
2014-04-16 11:43 UTC, Gerry
Details
before selecting the table (111.82 KB, image/jpeg)
2014-04-17 21:37 UTC, Pierre C
Details
table selected (seven x64) (127.56 KB, image/jpeg)
2014-04-17 21:38 UTC, Pierre C
Details
table selected (xp) (90.89 KB, image/jpeg)
2014-04-17 21:39 UTC, Pierre C
Details
Table with new row and frame on partial table (9.62 KB, image/jpeg)
2014-04-28 19:19 UTC, Pierre C
Details
table problem 5 (64.93 KB, image/jpeg)
2014-05-04 21:20 UTC, Pierre C
Details
Strange table behavior in 4.3.1.0 dev (139.73 KB, image/png)
2014-07-09 19:20 UTC, Mathis
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Gerry 2014-04-16 11:43:59 UTC
Created attachment 97468 [details]
table selection bug.png

During testing for bug 71423, the testers found out that tables in Impress behave strangely in 4.3 nightly builds.

Problems:
* It is difficult to "grab" the edges (tables handles) of the tables in order to be able to resize or move the tables. One needs to click several times to get the table handles and sometimes it "jumps" back so that the handle are gone again.
* sometimes the edges are not there where the edges of the table are supposed to be (see the screenshot attached).
*  There are situations where it is not possible to select more than the content of one single table cell with the mouse. Only after clicking outside the table and then again inside the table, I was able to select multiple cells.
* Changing font size of all the table changes only some cells
* Adding a row by pressing tab on the last cell works sometimes but not every times.
* All these seem very slow


System: WinXP SP3 in Virtualbox on Ubuntu
Version: 4.3.0.0.alpha0+
Build ID: 087a79db1272858f107656c5ca3c6efb45680986
TinderBox: Win-x86@39, Branch:master, Time: 2014-04-16_01:43:37

P.S. In a nightly build from the 8th of April 2014, I could confirm the bullet points 1, 4, 6 in that build. It seems to be that the problems 2 and 5 were introduced in between 8th of April and 16th of April 2014
Comment 1 Pierre C 2014-04-17 21:36:57 UTC
I've made some tests with the latest 4.2.5+ (17/04/2014)

And I think some of the problems are present (see attachments)

first is the normal tables (after coping/pasting a part of the table, and adding two lines to the table.

Second and third images shows the curious problems  
you can see the blue square on the left top appearing when selecting the table. And the partial frame of the selected table (it seems that the two or three lines added are not taken in account)

tested on seven x64 (first and second) and a vmware XP for the third
Comment 2 Pierre C 2014-04-17 21:37:52 UTC
Created attachment 97536 [details]
before selecting the table
Comment 3 Pierre C 2014-04-17 21:38:26 UTC
Created attachment 97537 [details]
table selected (seven x64)
Comment 4 Pierre C 2014-04-17 21:39:04 UTC
Created attachment 97538 [details]
table selected (xp)
Comment 5 Pierre C 2014-04-17 21:43:37 UTC
Hum That seems serious, same problem occurs with LO 4.2.4.1...

- difficult to select table
- can't change the size of several cell selected (but I can set it to bold)
- curious frame inside the selected table (picture 3)
Comment 6 Pierre C 2014-04-20 13:38:01 UTC
In LO 4.2.4.1

* Adding a row by pressing tab on the last cell works does not work
* sometimes the edges are not there where the edges of the table are supposed to be (see the screenshot attached).
This happens when you add row to the table. The edges are on the original table
* inserting rows doesn't work. until you move the table
* The height of the last row doesn't adjust to the text content. if your text oversize the row, the the text is outside the table.. until you move the table
Comment 7 Pierre C 2014-04-20 13:40:01 UTC
Adding keyword regression, setting to LO 4.3.4.1 rc
Comment 8 Caolán McNamara 2014-04-28 09:24:28 UTC
re comment #6 I believe I saw and fixed that a few days ago http://cgit.freedesktop.org/libreoffice/core/commit/?h=libreoffice-4-2-4&id=b228f0ca9c1966bfd60221c1bca8ae76fcdf10db
Comment 9 Pierre C 2014-04-28 19:19:02 UTC
Created attachment 98134 [details]
Table with new row and frame on partial table
Comment 10 Pierre C 2014-05-04 21:20:05 UTC
Created attachment 98431 [details]
table problem 5
Comment 11 Pierre C 2014-05-04 21:20:43 UTC
Problems are still on 4.2.4.2

https://bugs.freedesktop.org/attachment.cgi?id=98431
Comment 12 Mathis 2014-07-09 19:20:06 UTC
Created attachment 102494 [details]
Strange table behavior in 4.3.1.0 dev

Can confirm this bug still exists in 4.3.1.0 dev downloaded from the nightlies.
Comment 13 Joel Madero 2014-07-22 02:40:29 UTC
This is not a critical bug - lowering to Normal - Medium. For guidance on prioritizing bugs please see: https://wiki.documentfoundation.org/images/0/06/Prioritizing_Bugs_Flowchart.jpg

Also highest is reserved for special purposes.

Please don't change the severity/priroity unless you're aware of QA policies. Thanks
Comment 14 Joel Madero 2014-07-22 03:38:23 UTC
Another note here - please keep to the rule of 1 bug per report as these are really hard to "confirm" (we're confirming multiple issues) and it's nearly impossible to find a developer to tackle 5 things in one report.

This bug should be closed and new ones opened for each issue IMHO
Comment 15 Buovjaga 2014-11-04 11:08:48 UTC
The only things I could reproduce:
* The height of the last row doesn't adjust to the text content. if your text oversize the row, the the text is outside the table.. until you move the table
* sometimes the edges are not there where the edges of the table are supposed to be (see the screenshot attached).

The last one happens after inserting a new row with tab or after adding text so it flows outside the row like in the first problem.

I recommend Pierre or Gerry to test with 4.4 alpha and create separate bugs for the remaining reproducable problems.

Win 7 64-bit Version: 4.4.0.0.alpha1+
Build ID: ad6d94009cf8ea526eb70bf1a07e5c6a21320f83
TinderBox: Win-x86@51-TDF, Branch:MASTER, Time: 2014-11-04_00:06:27
Comment 16 raal 2014-12-22 07:50:20 UTC
Beluga confirmed -> setting to NEW. Changing summary.
Comment 17 Robinson Tryon (qubit) 2015-03-05 18:29:56 UTC
(In reply to Beluga from comment #15)
> The only things I could reproduce:
> ...

Is this a regression? If so, let's add a bibisectRequest tag and try to figure out when it was introduced.
Comment 18 Buovjaga 2015-03-06 11:04:51 UTC
(In reply to Beluga from comment #15)
> The only things I could reproduce:
> * The height of the last row doesn't adjust to the text content. if your
> text oversize the row, the the text is outside the table.. until you move
> the table
> * sometimes the edges are not there where the edges of the table are
> supposed to be (see the screenshot attached).
> 
> The last one happens after inserting a new row with tab or after adding text
> so it flows outside the row like in the first problem.

Not reproduced with 4.4.1. Closing as WFM.

Win 7 Pro 64-bit, LibO Version: 4.4.1.2
Build ID: 45e2de17089c24a1fa810c8f975a7171ba4cd432
Locale: fi_FI
Comment 19 Pierre C 2015-03-07 14:39:46 UTC
Yes right. Works for me too. Good news