Bug 77743 - FILEOPEN: symbols missing in .pptx import
Summary: FILEOPEN: symbols missing in .pptx import
Status: NEW
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
4.2.3.3 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: filter:pptx
Depends on:
Blocks: PPTX
  Show dependency treegraph
 
Reported: 2014-04-21 20:44 UTC by Ofir
Modified: 2019-01-11 12:12 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
pptx showing the issue (29.92 KB, application/vnd.openxmlformats-officedocument.presentationml.presentation)
2014-04-21 20:44 UTC, Ofir
Details
pdf exported from powerpoint showing all the symbols (106.59 KB, application/pdf)
2014-04-21 20:45 UTC, Ofir
Details
pdf exported from LO with three missing symbols (11.69 KB, application/pdf)
2014-04-21 20:45 UTC, Ofir
Details
Another pptx with a missing arrow symbol (28.80 KB, application/vnd.openxmlformats-officedocument.presentationml.presentation)
2016-05-30 17:37 UTC, Ofir
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Ofir 2014-04-21 20:44:56 UTC
Created attachment 97703 [details]
pptx showing the issue

LibreOffice displays rectangles instead of symbols in the attached pptx.

Tested on Ubuntu 14.04.
Comment 1 Ofir 2014-04-21 20:45:19 UTC
Created attachment 97704 [details]
pdf exported from powerpoint showing all the symbols
Comment 2 Ofir 2014-04-21 20:45:37 UTC
Created attachment 97705 [details]
pdf exported from LO with three missing symbols
Comment 3 tommy27 2014-05-10 04:35:59 UTC
tested under Win7x64 with 4.2.3.3 and 4.3.0.0.alpha1+
Build ID: a1dd961c3093f5f7624e4d1f2240e9120fd13f23
TinderBox: Win-x86@39, Branch:master, Time: 2014-05-06_11:47:48

I have better results than you but still not perfect...
I mean, all the symbols are correctly rendered in LibO except the "OK hand" symbol at "B" position which shows up as a rectangle in 4.2.x and as a bullett in 4.3.x

so I set status to NEW and platform to ALL
Comment 4 Ofir 2015-02-06 00:55:05 UTC
Same problem with LO 4.4.0.3 (Ubuntu 14.04)
Comment 5 A (Andy) 2015-04-03 19:09:23 UTC
Reproducible with LO 4.4.1.2, Win 8.1 (result as in comment 3 mentioned)
Comment 6 Yogesh Bharate 2015-04-07 09:41:32 UTC
- This is reproducible on latest build also.
   Build Details:
   Version: 4.5.0.0.alpha0+
   Build ID: 409005c87aadda681705b7cd4decdd6c5b4c8a91
   Locale: en_IN

- This issue is due to the wingding and wingding2 unmapped symbol in OpenSymbol.

- LibreOffice uses OpenSymbol which is  metric-equivalent to Microsoft's windings and wingding2.

- While rendering LibreOffice mapps Symbols of wingdings & wingdings2 in OpenSymbol font.

- If symbol is not present in OpenSymbol font then while rendering LibreOffice put a rectangle instead of symbol.

- This mapping of symbols handles in fontcvt.cxx (/core/unotools/source/misc/fontcvt.cxx)

- This is OpenSymbol font issue, to solved this required more information about the OpenSymbol font.i.e. OpenSymbol character set and its equivalent character Unicode.
Comment 7 Ofir 2015-09-02 16:18:06 UTC Comment hidden (obsolete)
Comment 8 Ofir 2016-05-30 17:37:00 UTC
Created attachment 125395 [details]
Another pptx with a missing arrow symbol
Comment 9 Ofir 2016-05-30 17:39:16 UTC
Reproducible with LO 5.1.3.2 on Windows 7.

The new attached arrow.pptx is missing a symbol on Ubuntu 14.04
Comment 10 Ofir 2016-08-17 09:34:43 UTC
Reproducible with LO 5.2.0.4 on Ubuntu 16.04
Comment 11 Ofir 2017-11-09 23:53:06 UTC Comment hidden (obsolete)
Comment 12 Ofir 2018-03-03 22:35:09 UTC
Reproducible with:

Version: 6.1.0.0.alpha0+
Build ID: 44b4ad7d210097fdaed7dd94c5746b03f43592d3
CPU threads: 1; OS: Linux 4.13; UI render: default; VCL: gtk2; 
TinderBox: Linux-rpm_deb-x86_64@70-TDF, Branch:master, Time: 2018-03-02_23:38:12
Locale: en-US (en_US.UTF-8); Calc: group