Bug Hunting Session
Bug 77755 - Items in Status Bars have different locations between different components.
Summary: Items in Status Bars have different locations between different components.
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: Other All
: medium normal
Assignee: Heiko Tietze
URL:
Whiteboard: target:6.0.0
Keywords:
Depends on:
Blocks: Statusbar
  Show dependency treegraph
 
Reported: 2014-04-22 06:04 UTC by Daniel Hulse
Modified: 2017-11-12 20:53 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
Visual comparison of Writer, Impress, and Draw's status bars. (303.17 KB, image/png)
2014-04-22 06:04 UTC, Daniel Hulse
Details
Moving Draw's status bars to be consistent with Writer's. (51.51 KB, image/png)
2014-04-22 07:47 UTC, Daniel Hulse
Details
Moving Draw's status bars to be consistent with Writer's--2 (51.54 KB, image/png)
2014-04-22 07:52 UTC, Daniel Hulse
Details
If both status bars were changed. (168.84 KB, image/png)
2014-04-22 08:27 UTC, Daniel Hulse
Details
If both status bars were changed. (166.74 KB, image/png)
2014-04-22 21:44 UTC, Daniel Hulse
Details
Situation after the patch (22.06 KB, image/png)
2017-11-10 15:35 UTC, Heiko Tietze
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Daniel Hulse 2014-04-22 06:04:14 UTC
Created attachment 97723 [details]
Visual comparison of Writer, Impress, and Draw's status bars.

LibreOffice Writer and Calc's status bars have a different layout than Draw and Impress. Writer and Calc have page listed on the left corner while Impress and Draw have it in the middle. In addition, Writer and Calc have the page style on the left side, while Draw and Impress have that on the right side. This is inconsistent. Writer's placement of each seems more ergonomic, so it might be best to change Draw and Impress to align with Writer, rather than the other way around.
Comment 1 Cor Nouws 2014-04-22 06:24:34 UTC
Hi Daniel,

At a first glance looks reasonable. Did you match that thought on a analyses of the full contents and functions of the status bar in the various modules?
Comment 2 Adolfo Jayme 2014-04-22 07:06:02 UTC
Both Impress and Draw can display a rather lenghty status message in the left, empty area, when clicking certain objects (“Object <name> selected”, etcetera). If complete consistency between components is /really/ desired, please comment on where to place the text that is currently displayed in the left side, or otherwise what to do with it (maybe dropping it would be fine?).
Comment 3 Daniel Hulse 2014-04-22 07:47:24 UTC
Created attachment 97728 [details]
Moving Draw's status bars to be consistent with Writer's.

I don't really think it's necessary to totally remove that part of the status bar. If the elements are just moved, no space is lost--there would still be plenty of room for that information. Then again, I'm not sure the information displayed is really that important. It might be useful in some cases.
Comment 4 Daniel Hulse 2014-04-22 07:52:24 UTC
Created attachment 97729 [details]
Moving Draw's status bars to be consistent with Writer's--2

Given that writer displays word count in the second space of the status bar, this might be a more consistent design.
Comment 5 Daniel Hulse 2014-04-22 08:27:37 UTC
Created attachment 97730 [details]
If both status bars were changed.

I rather liked the first's placement page next to the style, though. I think it creates a nice separation between items that change depending on where the cursor is placed and items that don't. What if Writer's status bar was changed to match?
Comment 6 Regina Henschel 2014-04-22 13:47:29 UTC
I do not like the idea for this reasons:
Draw and Writer are very different, and therefore it is natural, that they need different content in status bar.
Fields are only similar on a first glance, but actually provide different functions. 
Users are familiar with the current order for several years now, starting with StarOffice about 15years ago.
Changing the layout introduces additional work for documentation, which is done currently by a really small team.

 (In reply to comment #2)
> Both Impress and Draw can display a rather lenghty status message in the
> left, empty area, when clicking certain objects (“Object <name> selected”,
> etcetera). If complete consistency between components is /really/ desired,
> please comment on where to place the text that is currently displayed in the
> left side, or otherwise what to do with it (maybe dropping it would be
> fine?).

Do not remove that field. It is essential for changing shapes in point mode. For example it is the only place to get the angles of an arc.
Comment 7 Daniel Hulse 2014-04-22 21:41:49 UTC
(In reply to comment #6)
> I do not like the idea for this reasons:
> Draw and Writer are very different, and therefore it is natural, that they
> need different content in status bar.
> Fields are only similar on a first glance, but actually provide different
> functions. 

Regina could you say specifically what makes Draw and Impress different enough to merit different status bar layouts? I understand that they have different content, but shouldn't similar content be put in the same place for each?
Comment 8 Daniel Hulse 2014-04-22 21:44:14 UTC
Created attachment 97785 [details]
If both status bars were changed.
Comment 9 Regina Henschel 2014-04-23 00:39:33 UTC
The fields do different things:

"page count field"
Writer: .uno:StatePageNumber; double-click calls Navigator
Draw: .uno:PageStatus; no action, but display of the layer of an object

"page style field"
Writer: .uno:PageStyleName; double-click calls page style dialog; right-click to select page style from list
Draw: .uno:LayoutStatus; double-click calls slide design dialog (That is not the page setup!); right-click to select master page from list.
Comment 10 Daniel Hulse 2014-04-23 01:53:40 UTC
I know they do different things. What I was asking was is specific reasons why those differences mean they should be in different places. After all, just because the slide design and page style dialogues are different doesn't mean they aren't analogous, and I don't see any reason why clicking the slide number in Draw or Impress shouldn't bring up the navigator; it's just another inconsistency that should be fixed.
Comment 11 Cor Nouws 2014-04-23 20:55:29 UTC
Hi Daniel
(In reply to comment #10)
> I know they do different things. What I was asking was is specific reasons
> [...]

I see your point. But I'm quite hesitant to change unless we know for sure that it does not causes pain or issues. (May happen before we realise..)

Your attachment 97785 [details] does not give me reason *at a first glance* to disagree. Sadly I lack time to dive in all details easily. I'll look at the statusbar more often the next days to help make up my mind.

And for the rest... what do others know & think?
Comment 12 Owen Genat (retired) 2014-06-28 10:24:13 UTC
I agree with Daniel (OP). This report is about consistency in location of information rather that what information is displayed or how it is accessed. There is obviously enough space available because the status bar, regardless of component, has the same length. The mockups clearly illustrate what is possible. I think this can be confirmed and set to NEW.
Comment 13 A (Andy) 2015-04-04 21:21:28 UTC
Reproducible with LO 4.4.1.2, Win 8.1

Regarding the Page / Slide Number and Page Style statusbar place I personally would agree with Daniel.
Comment 14 Robinson Tryon (qubit) 2016-08-25 05:38:55 UTC Comment hidden (obsolete)
Comment 15 Heiko Tietze 2017-11-10 15:35:04 UTC
Created attachment 137668 [details]
Situation after the patch

Agree with pushing consistency. The change https://gerrit.libreoffice.org/#/c/44604/ just replaces the two panel sections.
Comment 16 Commit Notification 2017-11-12 20:38:35 UTC
heiko tietze committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=a7f961ddd88df4117de5f7c199881cf75d2905b5

tdf#77755 Consistency at status bars

It will be available in 6.0.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.