Bug 77816 - Draw - Duplicate Function - Does not take fractional angles
Summary: Draw - Duplicate Function - Does not take fractional angles
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Draw (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: x86 (IA32) All
: medium enhancement
Assignee: Laurent BP
QA Contact:
URL:
Whiteboard: target:5.4.0
Keywords:
Depends on:
Blocks: Edit-Duplicate-complexity Draw-UX
  Show dependency treegraph
 
Reported: 2014-04-23 15:21 UTC by Gerhard Mesenich
Modified: 2017-05-02 09:35 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Gerhard Mesenich 2014-04-23 15:21:33 UTC
The Duplicate Function does not take fractional angles. This makes it very difficult to draw regular parts with non-integer divisions.

The Duplicate function should be allowed to take fractional angle degrees as input.

See also:
Bug #77811 -  Draw - Duplicate function overly complex and the example there
Comment 1 Cor Nouws 2014-04-23 15:51:23 UTC
thanks!
See bug 77811 for details
setting UX in CC :)
Comment 2 Cor Nouws 2014-04-23 15:52:29 UTC
*** Bug 77811 has been marked as a duplicate of this bug. ***
Comment 3 Cor Nouws 2014-04-23 15:54:44 UTC
Sorry - added UX to wrong issue (better read before act..)
Comment 4 Commit Notification 2017-05-02 09:04:43 UTC
Laurent Balland-Poirier committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=8b56a5ceed41a1bb0a82af71c90973f50f54e4b8

tdf#77816 Duplicate dlg: enable fractionnal angle

It will be available in 5.4.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.