Bug 78027 - FILEOPEN: Importing of Excel files with non-uniform formated diagram title
Summary: FILEOPEN: Importing of Excel files with non-uniform formated diagram title
Status: NEW
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Chart (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on: 78025
Blocks: OOXML-Chart
  Show dependency treegraph
 
Reported: 2014-04-28 09:00 UTC by Jan
Modified: 2020-01-30 12:09 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
File to import with non-uniform diagram title (11.02 KB, application/vnd.openxmlformats-officedocument.spreadsheetml.sheet)
2014-04-28 09:00 UTC, Jan
Details
graph in Excel 2010 (8.18 KB, image/png)
2014-04-28 12:13 UTC, Jan
Details
Broken graph in Libreoffice (16.47 KB, image/png)
2014-04-28 12:14 UTC, Jan
Details
File compared MSO OO LO64+ (93.29 KB, image/jpeg)
2019-09-20 06:45 UTC, Timur
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jan 2014-04-28 09:00:05 UTC
Problem description:
I import an excel file with an embedded diagram. The title of the chart/diagram has one word formatted in bold. However, in Libreoffice the formatting of the title is gone. Everything is formatted like the first word in the title.

Steps to reproduce:
1. Import attached document
2. Check if the title of diagram is properly formated:
 - "bold_word" should be bold with 18pt font 
 - "italic_word" should be italic with 18pt font
 - "normal_word" should be normal with 18pt font
 - "new_line_with_small_word" should be normal with 11 pt font in next line

Current behavior:
All words are bold with 18pt font in the diagram title

Expected behavior:
Words are formatted like in excel:
 - "bold_word" should be bold with 18pt font 
 - "italic_word" should be italic with 18pt font
 - "normal_word" should be normal with 18pt font
 - "new_line_with_small_word" should be normal with 11 pt font in next line
Comment 1 Jan 2014-04-28 09:00:51 UTC
Created attachment 98115 [details]
File to import with non-uniform diagram title
Comment 2 Jan 2014-04-28 12:13:02 UTC Comment hidden (obsolete)
Comment 3 Jan 2014-04-28 12:14:33 UTC Comment hidden (obsolete)
Comment 4 Jan 2014-04-28 12:15:16 UTC Comment hidden (obsolete)
Comment 5 Jan 2014-04-29 08:33:45 UTC Comment hidden (obsolete)
Comment 6 Jacques Guilleron 2014-04-29 14:46:48 UTC
Hi Jan,

As said previously in bug 78025, this will be solved when we'll have richer formating in LO. Confirm this behaviour for Windows 7 Home Premium.

I put Status to NEW.

Have a nice day,

Jacques
Comment 7 QA Administrators 2015-06-08 14:43:14 UTC Comment hidden (obsolete)
Comment 8 Jan 2015-06-08 15:24:02 UTC Comment hidden (obsolete)
Comment 9 QA Administrators 2016-09-20 10:02:13 UTC Comment hidden (obsolete)
Comment 10 vihsa 2017-05-31 13:29:58 UTC
only numbers are visible, embedded diagram is not visible on lo viewer.
version: 5.5.0.0.alpha0+ / build id : ec79f34 / android 5.1
Comment 11 QA Administrators 2018-06-01 02:16:01 UTC Comment hidden (obsolete)
Comment 12 Jan 2018-06-01 11:23:21 UTC
The bug still exists in LO 6.0:

Version: 6.0.4.2
Build ID: 1:6.0.4~rc2-0ubuntu0.16.04.1
CPU threads: 4; OS: Linux 4.13; UI render: default; VCL: gtk2; 
Locale: de-DE (de_DE.UTF-8); Calc: group
Comment 13 Timur 2019-09-20 06:45:23 UTC
Created attachment 154309 [details]
File compared MSO OO LO64+

Repro 6.4+. 
Another example attachment 102146 [details] from bug 80816 and bug 127589.