Bug Hunting Session
Bug 78033 - Smart bar for finding tools, features and help
Summary: Smart bar for finding tools, features and help
Status: RESOLVED DUPLICATE of bug 91874
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-04-28 13:41 UTC by rh_libre
Modified: 2016-06-11 12:35 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description rh_libre 2014-04-28 13:41:08 UTC
WHAT, WHY, WHAT IS SIMILAR, ENHANCEMENT, HOW NOT TO DO IT :D

WHAT?
Implement a smart text box to allow people to find functions in LibreOffice or tutorials and help without hunting through the menus.

WHY?
To improve usability and productivity and to help users discover functions in various LibreOffice applications.

MAKE IT FAMILIAR: WHAT IS SIMILAR?
(i) The Smart address bar in most web browsers allows the user to start typing and see items from their browsing history, bookmarks or a smart auto-suggested web search. If they don’t find it, they can use a web search to do so. (e.g. Chrome, Firefox smart bars)
(ii) Windows 7’s Start Menu will search for installed programs, documents, other files, emails, control panel items etc.

POTENTIAL ENHANCEMENTS?
• If no results come up, offer a web-search based on, for example, LibreOffice Writer + search term which might throw up tutorials which use a different form of words than is used in the feature or function’s name or description.
• Allow the user to pin favourite functions next to the smart box (icon + mouse-over tooltip) and/or display recently found functions. Only power users will find the Customize menu options.
• Context-aware results – e.g. if the cursor is in Writer table and the user starts typing ‘COL’ they might want things to do with Background COLOR or Font COLOR or table COLUMN-width. If in non-table areas, they might be interested in Font COLOR or COLUMNS text layout. If in a multi-column area they might want to insert a COLUMN-break.
• Indicate where to find the feature via the pull-down menu structure.
• Make common suggestions based on cursor context all the time without requiring input. E.g. if selecting text in a table, display “type here or see suggested functions” and when cursor is there, offer select cell, select current row, select current column, select whole table. 

HOW NOT TO DO IT: Don’t implement this as an annoying animated paper clip that appears in front of the text you’re typing!!!
Comment 1 tommy27 2014-05-04 00:21:08 UTC
enhancement request. set status to NEW
Comment 2 V Stuart Foote 2016-06-11 12:35:53 UTC

*** This bug has been marked as a duplicate of bug 91874 ***