Bug Hunting Session
Bug 78111 - UI: "Freakout"-behaviour and freeze during resize of docked sidebar
Summary: UI: "Freakout"-behaviour and freeze during resize of docked sidebar
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
4.2.3.3 release
Hardware: All Linux (All)
: medium normal
Assignee: Maxim Monastirsky
URL:
Whiteboard: target:5.1.0 target:5.0.2 target:4.4.6
Keywords:
: 89298 89480 93134 93265 93330 93680 93700 93722 (view as bug list)
Depends on:
Blocks: Sidebar-UI-UX
  Show dependency treegraph
 
Reported: 2014-04-30 12:11 UTC by Alex
Modified: 2016-10-24 14:41 UTC (History)
13 users (show)

See Also:
Crash report or crash signature:


Attachments
Libreoffice "freaking out" (as the original reporter called it) (1.18 MB, video/x-matroska)
2015-06-19 23:44 UTC, Bernhard Rieder
Details
Example of Libreoffice "freaking out" (3.00 MB, video/mp4)
2015-08-11 15:12 UTC, Antanas
Details
Sidebar freaking out with graphics (5.57 MB, video/mp4)
2015-08-11 17:40 UTC, Antanas
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Alex 2014-04-30 12:11:00 UTC
If I try to re-size the sidebar it starts to "freakout". That means it's with increases and decreases as fast as hyperspeed.

In this case all control is lost. Impress can't be closed, even gnome does not respond anymore. Only way out of it: shutdown the whole system.

It happens every time, so on my machine it is reproducible. 

I noticed that after a short time the system fan goes crazy and the power consumption rises. Seems that the width calculation eats up a lot of resources.

My screen resolution is 1600x900, maybe it matters.
Comment 1 tommy27 2014-05-02 13:34:53 UTC
please give exact informations about your Linux distribution and version
Comment 2 Alex 2014-05-02 17:40:38 UTC
System Specs:

Intel Haswell Mobile CPU
Intel Core i5-4200U
Arch Linux 64-bit 

Linux Kernel26 3.14.2

Desktop Environment: Gnome 3.12.1
Comment 3 Yousuf Philips (jay) (retired) 2014-09-30 06:03:01 UTC
Hi Alex,

Can you check if this problem still arises for you in any of the latest releases, like 4.2.6 or 4.3.2.
Comment 4 Alex 2014-10-03 15:18:42 UTC
Sorry. Unfortunately this Setup is not running anymore, so I can't check how it works now.

Maybe I've a ISO Backup of that System and can try it in an VM.
Comment 5 QA Administrators 2015-04-01 14:47:44 UTC Comment hidden (obsolete)
Comment 6 QA Administrators 2015-05-06 14:22:10 UTC Comment hidden (obsolete)
Comment 7 Bernhard Rieder 2015-06-17 07:04:36 UTC
Hello,

I can confirm this bug on my system (debian testing aka stretch) but I have noticed it since quite some time.

Current LO version is 4.4.4-rc1

The problem, as already described, seems to be related to resizing the sidebar. When the sidebar gets wider, it decides that there is place for one more item in one line. However, when performing the action, the check fails (either because of size restrictions or because the grouping of items which must stay together, I don't know) an it is decided that the icon has to be moved down. Then the size check decides that there is enough room to move the item back to the previous line and the whole cycle starts again.

I use KDE (kwin) and a linux 4.1-rc7 kernel, but I do not think that is related to the issue.

However, I have played around a little and found out that the problem only occurs, when the sidebar is docked. When the sidebar is floating then I can resize it without troubles.

However, the system stays "responsive" so I can at least open up a terminal window and kill libreoffice writer manually.

Best regards,
Bernhard
Comment 8 Bernhard Rieder 2015-06-17 07:07:21 UTC
PS: I can reproduce the bug on all my systems (which run in a similar setup)
Comment 9 Yousuf Philips (jay) (retired) 2015-06-17 09:40:48 UTC
Hi Bernhard,

Can you provide a screencast of this, so we can better understand what you are seeing.
Comment 10 Bernhard Rieder 2015-06-19 23:44:04 UTC
Created attachment 116666 [details]
Libreoffice "freaking out" (as the original reporter called it)
Comment 11 Bernhard Rieder 2015-06-19 23:46:18 UTC
I added a screencast of the problem. Only way to get out is "kill -9 <PID>".  :(
Sorry it took so long I forgot to enable email notifications for this bug.

Best Regards,
Bernhard
Comment 12 Bernhard Rieder 2015-06-20 00:08:53 UTC
I installed 5.0.0-b3 from debian experimental, and guess what: 

The problem seems to be gone in Libreoffice Write 5.0.0-b3 which makes me very happy :)
In 4.4 it was always reproducible but I cannot cause 5.0.0-b3 to "freak out".

Best Regards,
Bernhard
Comment 13 tommy27 2015-06-20 05:10:30 UTC
nice to hear that. I set status to RESOLVED WORKSFORME
Comment 14 Bernhard Rieder 2015-06-29 16:54:07 UTC
Sorry,

I think this one should be reopened. It seems my "small" monitor at home prevented me from resizing the sidebar. However, today I accidentally resized the sidebar and it was back again (ugly and mean as before).  :(

Same as before. LO version is 5.0.0-rc1
However the application is not impress but calc. I try if I can change that as well as the status.

Best Regards,
Bernhard
Comment 15 tommy27 2015-06-29 17:03:26 UTC
try LibO 5.0.0 RC2
Comment 16 Antanas 2015-07-06 11:06:55 UTC
The bug still present in dev build LibreOffice 5.0.0.2 a26d58f11b99b6aeddf7f7884effea188cc6e512
Conditions:
1. UI languge: Lithuanian (at least one, excluding English (US))
2. Sidebar is docked
3. Working on LO Writer document 
4. Ih the sidebar Styles section is expanded

Ubuntu 14.04.2 LTS x86_64 GNU/Linux
Comment 17 Maxim Monastirsky 2015-08-05 22:56:20 UTC
*** Bug 93134 has been marked as a duplicate of this bug. ***
Comment 18 Maxim Monastirsky 2015-08-05 22:57:52 UTC
*** Bug 89480 has been marked as a duplicate of this bug. ***
Comment 19 Rūdolfs 2015-08-06 11:13:35 UTC
This is "Me too" comment.
Libreoffice version: 5.0.0.5
Build: 437e4abdf9e72fd0a6e6f8697a0e659bc77f9b10
Locale: lv-LV (lv_LV.utf8)

OS: Fedora 22 64bit.
Video card (lspci): Intel Corporation Xeon E3-1200 v3/4th Gen Core Processor Integrated Graphics Controller (rev 06)
Driver: included with Fedora (Intel® Haswell Desktop)
Desktop environment: GNOME 3.16.2

Interestingly, this problem does NOT happen on LO 4.4.4.3-6.fc22 build (the one that ships with fedora).
Comment 20 Yousuf Philips (jay) (retired) 2015-08-06 15:48:03 UTC
CCing Rishabh as he is working on the sidebar.
Comment 21 Maxim Monastirsky 2015-08-08 18:38:46 UTC
*** Bug 93265 has been marked as a duplicate of this bug. ***
Comment 22 Maxim Monastirsky 2015-08-08 18:53:08 UTC
It can be reproduced always by creating a new style with a very long name (I tried with 50 characters), and then trying to resize the sidebar.
Comment 23 Luc 2015-08-08 19:59:52 UTC
I added a paragraph style of 50+ chars long name to the test document as in https://bugs.documentfoundation.org/show_bug.cgi?id=93265
the bug did NOT occur.

I checked the styles in my large document (logbook), there the longest paragraph style name is "Titel illustratieregister", which is far less then 50 chars.

@Maxim: I cannot confirm your observation.
Comment 24 Maxim Monastirsky 2015-08-08 20:24:31 UTC
(In reply to Luc from comment #23)
> I added a paragraph style of 50+ chars long name to the test document as in
> https://bugs.documentfoundation.org/show_bug.cgi?id=93265
> the bug did NOT occur.
Does this new style listed in the styles combobox when you open it? You must have it there to reproduce.

> I checked the styles in my large document (logbook), there the longest
> paragraph style name is "Titel illustratieregister", which is far less then
> 50 chars.
I didn't say that you must have it to reproduce the bug. What I said is that it's an additional way of reproducing.
Comment 25 Maxim Monastirsky 2015-08-08 20:26:27 UTC
(In reply to Luc from comment #23)
> the bug did NOT occur.
Also - 50 chars might be not enough in your environment. Try with more - let's say 100.
Comment 26 Yousuf Philips (jay) (retired) 2015-08-09 01:44:09 UTC
I can reproduce it with master when the style section is open and i try to resize it with attachment 117768 [details], but if the section is closed it wont happen. The styles drop down is allowed to get as large as its internal preview content which causes this to show up (bug 93290).

But this bug was opened before the style section was added to the sidebar in 5.0, so something else is also causing this freak out as well. Bernhard Rieder's freakout video (attachment 116666 [details]) is done with 4.4 and looking at the video, i would assume it was related to how large the font text in the labels and drop down menus were in the sidebar.

Version: 5.1.0.0.alpha1+
Build ID: 25534a62b2ba398c6298c6b9e521f20de1087540
TinderBox: Linux-rpm_deb-x86_64@70-TDF, Branch:master, Time: 2015-08-07_14:13:33
Locale: en-US (en_US.UTF-8)
Comment 27 Commit Notification 2015-08-10 23:29:17 UTC
Maxim Monastirsky committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=e98cf0c63d6c48ca7c1db87d7413d5c419690c76

Related: tdf#78111 Try to guard against too wide panel layouts

It will be available in 5.1.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 28 Antanas 2015-08-11 11:50:42 UTC
*** Bug 89298 has been marked as a duplicate of this bug. ***
Comment 29 Maxim Monastirsky 2015-08-11 12:01:58 UTC
Adding Bug 93290 back to 'See Also'. The commit there fixed one of the freeze cases mentioned here (in comment 22, maybe other too).
Comment 30 Yousuf Philips (jay) (retired) 2015-08-11 14:47:16 UTC
(In reply to Antanas from comment #28)
> *** Bug 89298 has been marked as a duplicate of this bug. ***

Hi Antanas,

Can you post a screencast of the behaviour you are noticing? Some linux screencast apps are simplescreenrecorder, kazam, or gnome 3's screencast app.
Comment 31 Antanas 2015-08-11 15:10:38 UTC
(In reply to Yousuf (Jay) Philips from comment #30)
> (In reply to Antanas from comment #28)
> > *** Bug 89298 has been marked as a duplicate of this bug. ***
> 
> Hi Antanas,
> 
> Can you post a screencast of the behaviour you are noticing? Some linux
> screencast apps are simplescreenrecorder, kazam, or gnome 3's screencast app.

PLease review my screencast attached.
Comment 32 Antanas 2015-08-11 15:12:57 UTC
Created attachment 117833 [details]
Example of Libreoffice "freaking out"
Comment 33 Yousuf Philips (jay) (retired) 2015-08-11 15:51:51 UTC
(In reply to Antanas from comment #32)
> Created attachment 117833 [details]
> Example of Libreoffice "freaking out"

This screencast is likely due to the styles drop down, which maxim fixed in bug 93290. You stated in your duplicate bug that it was happening in 4.4.0.3 and when a picture was selected and the graphic section was open. Does this still happen?
Comment 34 Antanas 2015-08-11 17:39:46 UTC
(In reply to Yousuf (Jay) Philips from comment #33)
> (In reply to Antanas from comment #32)
> > Created attachment 117833 [details]
> > Example of Libreoffice "freaking out"
> 
> This screencast is likely due to the styles drop down, which maxim fixed in
> bug 93290. You stated in your duplicate bug that it was happening in 4.4.0.3
> and when a picture was selected and the graphic section was open. Does this
> still happen?

Yes, it is (see additional screencast)
Comment 35 Antanas 2015-08-11 17:40:50 UTC
Created attachment 117838 [details]
Sidebar freaking out with graphics
Comment 36 Maxim Monastirsky 2015-08-11 18:29:24 UTC
@Antanas: Thank you for the last screencast. I'm able to reproduce it with Lithuanian UI language, but not with English. The reason is that the strings of the "color mode" combobox in Lithuanian are longer than in English (and indeed if I change the code and put some long strings there, I'm able to reproduce also with English).

The good news is that it seems to be fixed by the commit of comment 27 (so I'll consider backporting it to 5-0), i.e. it won't freeze anymore, but you still won't be able to resize the sidebar. I'll see what can I do to allow resizing the sidebar as well.
Comment 37 Commit Notification 2015-08-12 13:04:07 UTC
Maxim Monastirsky committed a patch related to this issue.
It has been pushed to "libreoffice-5-0":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=b137ea11db280dec3e38a306f9daf7209eacf18e&h=libreoffice-5-0

Related: tdf#78111 Try to guard against too wide panel layouts

It will be available in 5.0.2.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 38 Maxim Monastirsky 2015-08-12 14:42:06 UTC
*** Bug 93330 has been marked as a duplicate of this bug. ***
Comment 39 Commit Notification 2015-08-13 10:03:41 UTC
Maxim Monastirsky committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=d2f218f54369c6d7fb38d0b701aa86fdf5aae843

tdf#78111 Sane preferred width for the color mode combobox

It will be available in 5.1.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 40 Maxim Monastirsky 2015-08-13 10:14:44 UTC
With these commits in place (the last one is also pending for 5-0), I think we can close this bug. For any additional problems in this area, please open new bugs.
Comment 41 Commit Notification 2015-08-13 11:22:42 UTC
Maxim Monastirsky committed a patch related to this issue.
It has been pushed to "libreoffice-5-0":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=4c537dd82b24926bf7b4ed75763af5befcce6702&h=libreoffice-5-0

tdf#78111 Sane preferred width for the color mode combobox

It will be available in 5.0.2.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 42 Commit Notification 2015-08-17 12:31:00 UTC
Maxim Monastirsky committed a patch related to this issue.
It has been pushed to "libreoffice-4-4":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=aec11c5204fb0687c0997c597e6b9526246df1a5&h=libreoffice-4-4

tdf#78111 Sane preferred width for the color mode combobox

It will be available in 4.4.6.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 43 Maxim Monastirsky 2015-08-26 13:17:06 UTC
*** Bug 93680 has been marked as a duplicate of this bug. ***
Comment 44 Maxim Monastirsky 2015-08-27 07:23:48 UTC
*** Bug 93700 has been marked as a duplicate of this bug. ***
Comment 45 Maxim Monastirsky 2015-08-27 21:45:01 UTC
*** Bug 93722 has been marked as a duplicate of this bug. ***