Bug 78252 - PRINTING: Printing to file defective
Summary: PRINTING: Printing to file defective
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
4.2.3.3 release
Hardware: Other Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2014-05-04 13:32 UTC by Peter Hiscocks
Modified: 2015-02-03 19:02 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
print-test.pdf (13.09 KB, application/pdf)
2014-05-16 21:11 UTC, Peter Hiscocks
Details
print-test.odp (18.38 KB, application/vnd.oasis.opendocument.presentation)
2014-05-16 21:11 UTC, Peter Hiscocks
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Peter Hiscocks 2014-05-04 13:32:36 UTC
Problem description: 

Steps to reproduce:
1. Choose print. Enable print to file. Click OK
2. Progress bar appears. Printing is *extremely* slow.
3. No file selector dialog appears. Assume current working directory.
4. No new file appears in the current directory.

Current behavior: Does not print to file.

Expected behavior: Should print to a file.

              
Operating System: Linux (Other)
Version: 4.2.3.3 release
Comment 1 Cyril 2014-05-04 14:00:34 UTC
Bug not reproduced under Ubuntu Studio 14.04 x86_64 and LO Version: 4.2.3.3 Build ID: 420m0(Build:3), French localization.

Steps I followed:
a. Launch LO Impress
b. Enter a title and a text
c. File - Print, option tab, chose "Print to file"
d. Click "Print to file" button
e. Enter file name
f. Check that filename.pdf is created and opens correctly.

So, no problem for me with this same release.
Comment 2 Jorendc 2014-05-16 20:14:04 UTC
Can you please attach a sample document which you can reproduce this issue?

Thanks!
Kind regards,
Joren
Comment 3 Peter Hiscocks 2014-05-16 21:11:25 UTC
Created attachment 99178 [details]
print-test.pdf

Thanks for getting back to me. I'm running LibreOffice 4.2.3.3 under Linux
Mint. I attach the printed document and the document file. In slide sorter
and edit mode, the .eps drawing shows up. In full screen mode it does not
show up.

When printing, the .eps drawing does not show up in the file.

Also, printing is painfully slow (and this is a fast computer, with a
solid state disk), it takes about 1 minute per page.

Regards -
Peter


> https://bugs.freedesktop.org/show_bug.cgi?id=78252
>
> Jorendc <jorendc@libreoffice.org> changed:
>
>            What    |Removed                     |Added
> ----------------------------------------------------------------------------
>              Status|UNCONFIRMED                 |NEEDINFO
>                  CC|                            |jorendc@libreoffice.org
>      Ever confirmed|0                           |1
>
> --- Comment #2 from Jorendc <jorendc@libreoffice.org> ---
> Can you please attach a sample document which you can reproduce this
> issue?
>
> Thanks!
> Kind regards,
> Joren
>
> --
> You are receiving this mail because:
> You reported the bug.
>
Comment 4 Peter Hiscocks 2014-05-16 21:11:25 UTC
Created attachment 99179 [details]
print-test.odp
Comment 5 Jorendc 2014-05-16 21:22:42 UTC
(In reply to comment #3)
> Created attachment 99178 [details]
> print-test.pdf
> 
> Thanks for getting back to me. I'm running LibreOffice 4.2.3.3 under Linux
> Mint. I attach the printed document and the document file. In slide sorter
> and edit mode, the .eps drawing shows up. In full screen mode it does not
> show up.
Should be fixed as stated in bug 62038 (will be fixed in upcomming 4.2.5).
You can use the LibreOffice PPA (https://launchpad.net/~libreoffice/+archive/ppa) for LibreOffice 4.2 to stay up to date.

> 
> When printing, the .eps drawing does not show up in the file.

Should be fixed also, see bug 75216 which is marked as dupe of bug 64161.

Can you please retest when 4.2.5 is released (or use an early build of it) which you can download here: http://dev-builds.libreoffice.org/daily/libreoffice-4-2/.

> Also, printing is painfully slow (and this is a fast computer, with a
> solid state disk), it takes about 1 minute per page.
Maybe this is related to previous mentioned bug reports and is fixed by them?

Kind regards,
Joren

PS: please do not reply on the emails you receive, it creates a lot of noise. Please reply in the bug report itself (https://bugs.freedesktop.org/show_bug.cgi?id=78252).
Comment 6 QA Administrators 2015-01-10 18:06:14 UTC
Dear Bug Submitter,

This bug has been in NEEDINFO status with no change for at least 6 months. Please provide the requested information as soon as possible and mark the bug as UNCONFIRMED. Due to regular bug tracker maintenance, if the bug is still in NEEDINFO status with no change in 30 days the QA team will close the bug as INVALID due to lack of needed information.

For more information about our NEEDINFO policy please read the wiki located here: 
https://wiki.documentfoundation.org/QA/FDO/NEEDINFO

If you have already provided the requested information, please mark the bug as UNCONFIRMED so that the QA team knows that the bug is ready to be confirmed.


Thank you for helping us make LibreOffice even better for everyone!


Warm Regards,
QA Team

Message generated on: 10/01/2015
Comment 7 Peter Hiscocks 2015-01-10 19:23:36 UTC
That is now working, so you can cancel this bug report. Thanks for the help.

Now, if the Canon Scanner can be made to work (subject of another bug report) , I would be a very happy camper.

Regards -
Peter
Comment 8 Alex Thurgood 2015-02-03 19:02:07 UTC
As per comment 7, this is now WFM