Bug Hunting Session
Bug 78324 - Implement NUMBERTEXT in LibreOffice
Summary: Implement NUMBERTEXT in LibreOffice
Status: RESOLVED DUPLICATE of bug 117171
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: Other All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-05-06 07:04 UTC by Mikeyy - L10n HR
Modified: 2018-05-29 16:14 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
HR-LATIN numbertext implementation (6.26 KB, patch)
2014-08-16 10:08 UTC, Mikeyy - L10n HR
Details
NUMBERTEXT extension with added HR language (70.89 KB, application/vnd.openofficeorg.extension)
2014-09-18 09:12 UTC, Mikeyy - L10n HR
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Mikeyy - L10n HR 2014-05-06 07:04:43 UTC
Implement transfer of numbers into words ( 100 = one hundred ) for more languages.
http://extensions.libreoffice.org/extension-center/numbertext-1

I see this was planned in old OO, (https://issues.apache.org/ooo/show_bug.cgi?id=103746) but never achived.

I would also like to localize it for croatian (HR) language.
Comment 1 Mikeyy - L10n HR 2014-05-06 07:07:49 UTC
So it's all in one place, specification:
http://www.numbertext.org/numbertext.pdf
Comment 2 tommy27 2014-05-06 08:09:21 UTC
enhancement request. status NEW
Comment 3 Mikeyy - L10n HR 2014-05-06 08:20:43 UTC
Adding author of extension to cc. Not sure if those emails are valid or not, but it's on members list for this bugzilla.
Comment 4 Luuk 2014-05-06 18:05:55 UTC
Just to give some 'more' information:

How to convert a numeric value into English words in Excel
see: http://support.microsoft.com/kb/213360

There is an excel macro, which covers doing this in English.
Comment 5 László Németh 2014-05-07 07:43:43 UTC
Mihovil, numbertext extension is part of the configuration of LibreOffice, see --enable-ext-numbertext parameter:

./autogen.sh --help | grep -i numbertext
  --enable-ext-numbertext Enable the Numbertext extension

Simply install the libreoffice-extensions-numbertext package on Linux distributions with default Numbertext support. For other platforms, you can use directly the LibreOffice extension: https://extensions.libreoffice.org/extension-center/numbertext-1

To develop the Croatian module, I suggest to modify the Serbian module. Unfortunately, Serbian description has no money section, but you may check and modify the Slovenian's or Slovakian's one (maybe we will be able to extend the Serbian module, too). You can use the Numbertext IDE to test or develop the Croatian rules:

http://numbertext.org/Soros.html

Please, attach here or send me the result to include it in the next Numbertext release. If you have any questions, feel free to ask. Hvala in advance: :)
Comment 6 Mikeyy - L10n HR 2014-08-16 10:08:25 UTC
Created attachment 104726 [details]
HR-LATIN numbertext implementation

I sent this some time ago to your email, but since mails get lost I'm archiving this here so it doesn't get lost when time comes to implement it.

I used serbian cyrilic as base for numbers and fixed a bug they had. It was hard to find for non coder, but eventually I managed it. It showed thousands incorectly for numbers larger then 1.000.000 if I remember correctly (was 2-3 months ago).
If you want to fix their code also, just compare mine with their code and it will pop up.

For currency I used russian as base since our languages have same plural rules.
Anyway, I upgraded that also with feminine versions for numbers ending with 1 and 2 since they didn't have it.
As far as I can tell, I covered every possible aspect.

Lines 134 - 160 cover uses of currency signs/texts before/after numbers (100,00 € or €100,00). When I used it on online test, it worked perfectly. But I tried installing numbertext extension and I see it isn't working with currency signs.
If you think it doesn't have any use for formula, you can remove it.

Hopefully this can one day be added to your extension and made part of default LibreOffice installation. Many people don't know extensions even exist.

Best regards,
Mihovil
Comment 7 Mikeyy - L10n HR 2014-09-18 09:12:30 UTC
Created attachment 106490 [details]
NUMBERTEXT extension with added HR language

Since I can't wait for implementation of this in already available extension or as part of LibreOffice, I edited existing extension with HR (croatian) translation and data. I'm using this personaly, and few people who asked me how to convert numbers to text, but it's maybe useful for someone else also.
Comment 8 László Németh 2018-05-29 16:14:16 UTC
@Mihovil, I've integrated your work with Numbertext, thanks for it. See also in the recent extension http://www.afterthedeadline.com/api.slp

*** This bug has been marked as a duplicate of bug 117171 ***