Download it now!
Bug 78456 - FILEOPEN: Marker colors are not applied to charts with line type 'none' when opening XLSX
Summary: FILEOPEN: Marker colors are not applied to charts with line type 'none' when ...
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Chart (show other bugs)
Version:
(earliest affected)
4.2.3.3 release
Hardware: All Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: OOXML-Chart
  Show dependency treegraph
 
Reported: 2014-05-08 20:43 UTC by ebucha2
Modified: 2015-04-26 04:33 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Sample spreadsheet (12.89 KB, application/vnd.openxmlformats-officedocument.spreadsheetml.sheet)
2014-05-08 20:43 UTC, ebucha2
Details
LibreOffice behavior and dialog (171.26 KB, image/png)
2014-05-08 20:44 UTC, ebucha2
Details
Excel (correct) behavior and dialog (55.83 KB, image/png)
2014-05-08 20:45 UTC, ebucha2
Details

Note You need to log in before you can comment on or make changes to this bug.
Description ebucha2 2014-05-08 20:43:50 UTC
Created attachment 98705 [details]
Sample spreadsheet

Screenshots of dialogues and problem are attached.

When opening an XLSX file that includes a scatter or line chart whose line type is set to 'none', LO does not apply the series' marker colors.  This is related to LO's lack of independent marker formatting as described in bug 75822 .  

This issue should be resolved when marker formatting is added in 4.3.  An interim fix for 4.2.x releases would be to apply the marker color to the line color which is already present.  This line color then propagates to the markers.

I have confirmed the bug in LO 3.5.7.2 (Linux) and 4.1.4-4.2.4 (Windows).
Comment 1 ebucha2 2014-05-08 20:44:36 UTC
Created attachment 98706 [details]
LibreOffice behavior and dialog
Comment 2 ebucha2 2014-05-08 20:45:07 UTC
Created attachment 98707 [details]
Excel (correct) behavior and dialog
Comment 3 tommy27 2014-05-09 12:10:44 UTC
I confirm issue with LibO 4.2.3.3 and 4.3.0.0alpha1+(*)

(*)Build ID: 657004ae5c9f4a07b2cdafbb21bc8657842d4d74
TinderBox: Win-x86@39, Branch:master, Time: 2014-05-08_00:35:12
Comment 4 Markus Mohrhard 2015-04-26 04:33:15 UTC
Seems to be fixed in master.