Bug 78467 - FORMATTING: Vertical Alignment of text is invalid
Summary: FORMATTING: Vertical Alignment of text is invalid
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.1.6.2 release
Hardware: x86 (IA32) Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2014-05-09 03:20 UTC by Hideki Suzuki
Modified: 2016-04-11 15:04 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Color RED text in .doc file is vertical alignment invalid. (25.50 KB, application/msword)
2014-05-09 03:20 UTC, Hideki Suzuki
Details
LibO 4.2 vs Word 2000 (262.29 KB, image/png)
2014-05-29 01:35 UTC, Yousuf Philips (jay) (retired)
Details
Screenshot LibO 4.2.5.1 vs Word2013 (179.71 KB, image/jpeg)
2014-06-05 10:42 UTC, Hideki Suzuki
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Hideki Suzuki 2014-05-09 03:20:10 UTC
Created attachment 98724 [details]
Color RED text in .doc file is vertical alignment invalid.

Problem description: 
Vertical Alignment of text in Tabel is invalid by toolbutton.
Some text(in Word2003 .doc file) is valid but some text is invalid  by toolbutton.
And after I cleared the formatting , then toolbutton becames valid.

Steps to reproduce:
1. Open word2003 .doc file
2. Vertical formatting of Text in table is not aligned. Some text is good.

Current behavior:
・Vertical Alignment is invalid by toolbutton or menu.
・Horizontal Alignment is valid.
・After I cleared the formatting , then toolbutton becames valid.

Expected behavior:
1.When opening Word2003 .doc file, text alignment is valid.
2.Vertical Alignment of text in Tabel becames valid by toolbutton.

              
Operating System: Windows 7
Version: 4.2.3.3 release
Comment 1 Yousuf Philips (jay) (retired) 2014-05-29 01:34:34 UTC
Confirmed in Windows XP. The document has the cell has vertical alignment set to center, but LibO isnt centering it.
Comment 2 Yousuf Philips (jay) (retired) 2014-05-29 01:35:10 UTC
Created attachment 100065 [details]
LibO 4.2 vs Word 2000
Comment 3 Yousuf Philips (jay) (retired) 2014-05-29 01:35:41 UTC
Forgot to mention that it was tested in 4.1.6, 4.2.4 and 4.3 beta.
Comment 4 Hideki Suzuki 2014-06-05 03:37:13 UTC
4.1.6.2 and 4.2.5.1, bug is left.
Comment 5 Yousuf Philips (jay) (retired) 2014-06-05 04:53:04 UTC
please send screenshot.
Comment 6 Hideki Suzuki 2014-06-05 10:42:27 UTC
Created attachment 100453 [details]
Screenshot LibO 4.2.5.1 vs Word2013
Comment 7 Yousuf Philips (jay) (retired) 2014-06-05 18:39:19 UTC
(In reply to comment #4)
> 4.1.6.2 and 4.2.5.1, bug is left.

I didnt understand what you meant by "bug is left" as i dont see any text on the left in your screenshot.
Comment 8 D N Bebb 2015-02-21 15:30:12 UTC
I just wanted to leave feedback, not report bugs.
About 8 years ago I downloaded Open Office, but found it unworkable because in Writer I was unable to vertically align text. This feature is essential for letter writing if the letter is less than one page, so I bought MS Office XP.
Now I have Windows 8.1 my MS Office will not work properly. I downloaded Libreoffice and guess what, I still cannot easily vertically centre text. Do I really have to buy MS office 2007? I notice from my research I'm not the only person wanting this feature.
All the Best
nebb
Comment 9 Yousuf Philips (jay) (retired) 2015-02-21 22:32:18 UTC
Hi Nebb,

This bug was about cells contents not being vertically aligned when importing from a .doc file. You should be able to easy set vertical alignment of a cell in Writer if you have the right sidebar open or alternatively enable the 'Center Vertically' button in the formatting toolbar.
Comment 10 Mark Hung 2016-04-11 11:45:27 UTC
Hi , 

This seems to be duplicate of tdf#87889. You can either upgrade to LibreOffice5.1 or turn off document grid from page setting.
Comment 11 Hideki Suzuki 2016-04-11 15:04:45 UTC
This problem is fixed in LibreOffice5.1.
I confirmed in LibreOffice5.1.2.2(Japanese),Windows7 Service Pack1.
Thank you very much.