Bug Hunting Session
Bug 78554 - SVG: Text from SVG no longer displayed in LibreOffice
Summary: SVG: Text from SVG no longer displayed in LibreOffice
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Draw (show other bugs)
Version:
(earliest affected)
4.2.4.2 release
Hardware: Other All
: highest major
Assignee: Jorendc
URL:
Whiteboard: BSA target:4.4.0 target:4.3.1 target:...
Keywords: bibisected, regression
: 78672 79856 80291 80298 80344 80799 84335 (view as bug list)
Depends on:
Blocks: mab4.2
  Show dependency treegraph
 
Reported: 2014-05-11 12:27 UTC by Shimi Chen
Modified: 2015-12-17 08:04 UTC (History)
15 users (show)

See Also:
Crash report or crash signature:


Attachments
An SVG file that is incorrectly imported. (19.55 KB, image/svg+xml)
2014-05-11 12:27 UTC, Shimi Chen
Details
shows the problem in 4.2.4.2 (49.57 KB, image/png)
2014-06-02 13:48 UTC, TinoMo
Details
screen shots with results in 4301 and 4252 (208.04 KB, image/png)
2014-06-22 09:34 UTC, Cor Nouws
Details
Screenshot Win 8.1 x64 Writer v.4.2.6.3 (253.48 KB, image/png)
2014-09-11 14:14 UTC, Mario
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Shimi Chen 2014-05-11 12:27:07 UTC
Created attachment 98842 [details]
An SVG file that is incorrectly imported.

Importing the attached SVG file used to show it properly in LibreOffice.
After the upgrade to 4.2.4.2, there is a regression and text is not displayed after the import.

On the left hand side you can see how the original SVG should look like and on the right the way it is imported on 4.2.4.2:
http://i.imgur.com/0UuD4Ae.png

It worked fine on previous versions.
Operating System: Linux (Other)
Version: 4.2.4.2 rc
Last worked in: 4.2.3.3 release
Comment 1 Julien Nabet 2014-05-11 15:47:40 UTC
On pc Debian x86-64 with master sources updated today, I can reproduce this.
I noticed that when using "File/Open", it's OK (or almost)
(could be expected since http://nabble.documentfoundation.org/About-Svgreader-td4107050.html)
Comment 2 Cor Nouws 2014-05-11 16:14:40 UTC
relation to bug 78557 ?
Comment 3 Antanas 2014-05-12 19:42:37 UTC
I confirm the issue. 
I was working on the ODT file with nicely inserted SVGs (created with UMLet) on LO 4.2.3.3. 
After upgrade to LO 4.2.4.2. most SVG elements (not only text) are gone.
Comment 4 Cor Nouws 2014-05-19 06:46:58 UTC
*** Bug 78871 has been marked as a duplicate of this bug. ***
Comment 5 TinoMo 2014-06-02 13:48:20 UTC
Created attachment 100313 [details]
shows the problem in 4.2.4.2
Comment 6 TinoMo 2014-06-02 13:50:54 UTC
I have the same issue. After upgrade from 4.2.3.3 to 4.2.4.2 all text from my imported svg files is missing.
Comment 7 Xisco Faulí 2014-06-04 15:26:37 UTC
bibisected:

0acca754077bf74469c3e1a3c7eabbc3da795266 is the first bad commit
commit 0acca754077bf74469c3e1a3c7eabbc3da795266
Author: Bjoern Michaelsen <bjoern.michaelsen@canonical.com>
Date:   Mon May 12 12:04:53 2014 +0000

    source-hash-5e651d4084df7662b56ea980934c0428ba31b062
    
    commit 5e651d4084df7662b56ea980934c0428ba31b062
    Author:     Caolán McNamara <caolanm@redhat.com>
    AuthorDate: Tue Apr 15 21:08:13 2014 +0100
    Commit:     Caolán McNamara <caolanm@redhat.com>
    CommitDate: Wed Apr 16 11:23:13 2014 +0100
    
        coverity#1202948 Uninitialized pointer field
    
        Change-Id: I2764b1f9c3d50cf7ff7bd2c552a3dec93509b245

:100644 100644 42123dfbed90154f94f2f1dc8eacf21ed9bf155e 0d2db29f9ae8626eca4aa470157737cc2fffcde0 M	autogen.log
:100644 100644 0c1402c4f181927b2de7b580b596a19c454ff44b 76dfad2a19c6025ab1ff32510e73930f97ae063f M	ccache.log
:100644 100644 3c2e4c5380217c309eb8ca87b2e009760a2e4e9c c60fabab11f976674ac5611f37cba9ef49405589 M	commitmsg
:100644 100644 3b4121c32f82a582e7375c90656c26d59b1d9e61 645384f6ca01eb832351e51b21a3e68e798177f0 M	make.log
:040000 040000 e411e8188872ccf6a50816da7de0ce184071ca16 c66ac4ae3cd31ba3fa723f1ef8376310723747ec M	opt

# bad: [423a84c4f7068853974887d98442bc2a2d0cc91b] source-hash-c15927f20d4727c3b8de68497b6949e72f9e6e9e
# good: [65fd30f5cb4cdd37995a33420ed8273c0a29bf00] source-hash-d6cde02dbce8c28c6af836e2dc1120f8a6ef9932
git bisect start 'latest' 'oldest'
# good: [e02439a3d6297a1f5334fa558ddec5ef4212c574] source-hash-6b8393474974d2af7a2cb3c47b3d5c081b550bdb
git bisect good e02439a3d6297a1f5334fa558ddec5ef4212c574
# good: [4850941efe43ae800be5c76e1102ab80ac2c085d] source-hash-980a6e552502f02f12c15bfb1c9f8e6269499f4b
git bisect good 4850941efe43ae800be5c76e1102ab80ac2c085d
# good: [a900e72b6357882284c5955bdf939bf14269f5fb] source-hash-dd1050b182260a26a1d0ba6d0ef3a6fecc3f4e07
git bisect good a900e72b6357882284c5955bdf939bf14269f5fb
# skip: [e80660c5a1d812cd04586dae1f22767fc3778c4a] source-hash-07c60c8ee2d1465544a6a39e57bc06b3690b8dfb
git bisect skip e80660c5a1d812cd04586dae1f22767fc3778c4a
# good: [df9bcaed2faa2a8d11b19f877cdff3a12a887278] source-hash-6ba9692d8bbe3e3c245aca9a7c928e81178d05f1
git bisect good df9bcaed2faa2a8d11b19f877cdff3a12a887278
# bad: [741197a13a361480f59eeb3bd1401f984f49f1c0] source-hash-9a61470eb1fa161cba70f2e9c4ea8817dc7f617e
git bisect bad 741197a13a361480f59eeb3bd1401f984f49f1c0
# skip: [60da347518798811f7adbfbf1eb07d59cd9f08bf] source-hash-28fc951233a58fb4d8515ed4380140aaee0afd32
git bisect skip 60da347518798811f7adbfbf1eb07d59cd9f08bf
# bad: [0acca754077bf74469c3e1a3c7eabbc3da795266] source-hash-5e651d4084df7662b56ea980934c0428ba31b062
git bisect bad 0acca754077bf74469c3e1a3c7eabbc3da795266
# good: [465e2be02951f9645beb3024506a5212907caf5f] source-hash-674801eb4af21c9ae83c122499f15fa4f4785b0f
git bisect good 465e2be02951f9645beb3024506a5212907caf5f
# first bad commit: [0acca754077bf74469c3e1a3c7eabbc3da795266] source-hash-5e651d4084df7662b56ea980934c0428ba31b062
Comment 8 Xisco Faulí 2014-06-04 16:07:36 UTC
This issue was introduced by 3b7472b284131c09d91b69f26d5d26d54648f939.
Reverting the commit fixes the problem. I'll try to contact the developer
Comment 9 Julien Nabet 2014-06-04 16:46:48 UTC
Xisco: following your last comment, I don't understand why bibisect didn't indicate this patch.

Tomaz: any idea?
Comment 10 Tomaz Vajngerl 2014-06-04 18:45:17 UTC
Meh.. this was supposed to workaround a infinite loop bug with some SVG files. Reverting this commit would not be wise.. so looks like I need to fix this issue.
Comment 11 Xisco Faulí 2014-06-05 08:58:53 UTC
Juliet, bibisect is correct and the commit is in the range 674801eb4af21c9ae83c122499f15fa4f4785b0f..5e651d4084df7662b56ea980934c0428ba31b062

Tomaz, I reverted it just to verify this was the problematic commit. I don't intend to revert it in master or so.
Comment 12 Julien Nabet 2014-06-05 09:12:34 UTC
Xisco: thanks for the feedback. The display is quite confusing I thought that Caolan's commit was wrong when reading.
(BTW, it's "Julien" not "Juliet" which is a girl name)
Comment 13 Christopher Yeleighton 2014-06-21 09:19:54 UTC
Fixed in 4.2.5.2
Comment 14 Cor Nouws 2014-06-22 08:56:47 UTC
*** Bug 80344 has been marked as a duplicate of this bug. ***
Comment 15 Cor Nouws 2014-06-22 09:34:34 UTC
Created attachment 101520 [details]
screen shots with results in 4301 and 4252

Are we sure this is fixed ??
Attached how is shows if I paste the originally filed svg graphic in Writer in 4301 and 4252 ..
Comment 16 Cor Nouws 2014-06-22 09:34:59 UTC
see previous comment
Comment 17 berff 2014-06-22 10:54:25 UTC
Confirmed with LibreOffice Draw 3.3.0 (as mentioned here: https://bugs.freedesktop.org/show_bug.cgi?id=79650) as well as with 4.3.0rc1 on Linux x86-64. So this looks like it is inherited from OOo. 

See an similar issue I reported here:
https://bugs.freedesktop.org/show_bug.cgi?id=80339
Comment 18 Cor Nouws 2014-06-22 12:23:17 UTC
(In reply to comment #17)

> See an similar issue I reported here:
> https://bugs.freedesktop.org/show_bug.cgi?id=80339

thanks Berff, one of the (I guess) many to fix svg-issues.
Comment 19 Alex 2014-06-22 13:29:52 UTC
*** Bug 80298 has been marked as a duplicate of this bug. ***
Comment 20 Alex 2014-06-22 13:31:25 UTC
from https://bugs.freedesktop.org/show_bug.cgi?id=80298

You can find this bug also in windows version

Since Libre Office 4.2.4 writer shows and prints inserted svg images wrong. All text disappears. Version 4.2.3.3 works fine though.

By making some experiments it seems that the problem (of win version at least) is connected to 
..\program\svgiolo.dll
If you replace it with the one from LiO 4.2.3.3 everything starts to work fine.
Comment 21 Yousuf Philips (jay) (retired) 2014-06-22 16:07:39 UTC
*** Bug 80291 has been marked as a duplicate of this bug. ***
Comment 22 Yousuf Philips (jay) (retired) 2014-06-22 16:16:53 UTC
Decided to merge bug 80291 with this, as both Joel's and Xisco's bibisect resulted in finding the same commit, though this bug is about Drawing, which has quite poor SVG support, and bug 80291 is about Writer and embedding an SVG, which has better SVG support.

(In reply to comment #13)
> Fixed in 4.2.5.2

Bug 80291 still isnt fixed with 4.2.5.2.

(In reply to comment #17)
> See an similar issue I reported here:
> https://bugs.freedesktop.org/show_bug.cgi?id=80339

Bug 80339 is regarding visible text that is in the wrong location.
Comment 23 Julien Nabet 2014-06-29 10:57:07 UTC
On pc Debian x86-64 with master sources updated yesterday, I can see the text now.
I wonder if it could be thanks to http://cgit.freedesktop.org/libreoffice/core/commit/?id=533c6cb6bad6ef0432e8eebbfd4daf90ef71f3b4
Comment 24 Julien Nabet 2014-06-29 11:02:13 UTC
Argh! Forget about my previous comment, I had used file/open instead of insert image. Bug is still here :(
Comment 25 Yousuf Philips (jay) (retired) 2014-07-04 00:28:12 UTC
*** Bug 80799 has been marked as a duplicate of this bug. ***
Comment 26 Commit Notification 2014-07-14 16:18:21 UTC
Joren De Cuyper committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=f6df52aa3aad9c7650b6ca051d9a28c4ccb6a060

fdo#78554 - SVG: Text from SVG no longer displayed in LibreOffice



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 27 Commit Notification 2014-07-15 14:32:54 UTC
Joren De Cuyper committed a patch related to this issue.
It has been pushed to "libreoffice-4-3":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=eae269a60a0a571c4752a4b2a94ba728bb41c460&h=libreoffice-4-3

fdo#78554 - SVG: Text from SVG no longer displayed in LibreOffice


It will be available in LibreOffice 4.3.1.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 28 Commit Notification 2014-07-15 14:34:44 UTC
Joren De Cuyper committed a patch related to this issue.
It has been pushed to "libreoffice-4-2":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=763e3855caacbfc4818e70464bca348de10fbc3d&h=libreoffice-4-2

fdo#78554 - SVG: Text from SVG no longer displayed in LibreOffice


It will be available in LibreOffice 4.2.7.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 29 Xisco Faulí 2014-07-16 08:28:10 UTC
*** Bug 78672 has been marked as a duplicate of this bug. ***
Comment 30 Xisco Faulí 2014-07-16 08:45:47 UTC
*** Bug 79856 has been marked as a duplicate of this bug. ***
Comment 31 Alex 2014-07-17 20:00:32 UTC
(In reply to comment #28)
> Joren De Cuyper committed a patch related to this issue.
> It has been pushed to "libreoffice-4-2":
> 
> http://cgit.freedesktop.org/libreoffice/core/commit/
> ?id=763e3855caacbfc4818e70464bca348de10fbc3d&h=libreoffice-4-2
> 
> fdo#78554 - SVG: Text from SVG no longer displayed in LibreOffice
> 
> 
> It will be available in LibreOffice 4.2.7.
> 
> The patch should be included in the daily builds available at
> http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
> information about daily builds can be found at:
> http://wiki.documentfoundation.org/Testing_Daily_Builds
> Affected users are encouraged to test the fix and report feedback.

Seems to be working in daily builds of 4.2.7 and 4.3.1
Comment 32 klaus.welch 2014-09-02 11:41:36 UTC
For my setup (RHEL5.6, LO4.3.1.2) text does not disappear anymore.
=> issue seems fixed.

But https://bugs.freedesktop.org/show_bug.cgi?id=82520 still exists
=> sdraw -> svg-export -> swriter -> svg-import is still an unusable flow :-(
Comment 33 Mario 2014-09-11 14:14:45 UTC
Created attachment 106138 [details]
Screenshot Win 8.1 x64 Writer v.4.2.6.3
Comment 34 Mario 2014-09-11 14:16:59 UTC
I've created the svg using draw, then added them to writer, see ss https://bugs.freedesktop.org/attachment.cgi?id=106138

Is this issue really fixed?
Comment 35 Tomaz Vajngerl 2014-09-11 14:24:11 UTC
Do you not see "It will be available in LibreOffice 4.2.7." in comments #27
Comment 36 Tomaz Vajngerl 2014-09-25 20:23:02 UTC
*** Bug 84335 has been marked as a duplicate of this bug. ***
Comment 37 Robinson Tryon (qubit) 2015-12-17 08:04:34 UTC
Migrating Whiteboard tags to Keywords: (bibisected)
[NinjaEdit]