Bug 78657 - FILESAVE: When saving a DOCX that has a picture with a hyperlink on it - the hyperlink is lost
Summary: FILESAVE: When saving a DOCX that has a picture with a hyperlink on it - the ...
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.3.0.0.alpha1
Hardware: Other All
: medium normal
Assignee: Tünde Tóth
URL:
Whiteboard: BSA target:4.3.0 target:6.4.0 target:...
Keywords: filter:docx
: 123629 126438 (view as bug list)
Depends on:
Blocks: DOCX DOCX-Hyperlink
  Show dependency treegraph
 
Reported: 2014-05-13 12:43 UTC by Adam CloudOn
Modified: 2019-07-17 12:31 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
DOCX containing a picture with a hyperlink on it (40.35 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2014-05-13 12:43 UTC, Adam CloudOn
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Adam CloudOn 2014-05-13 12:43:49 UTC
Created attachment 98974 [details]
DOCX containing a picture with a hyperlink on it

Problem description: 
LO opens a DOCX that contains a picture that has a 
hyperlink attached to it. Then LO saves back to a 
new DOCX. In new DOCX - the picture lost the 
hyperlink that was attached to it.

Steps to reproduce:
1. Load the attached DOCX in LO
2. Save as NEW.DOCX
3. Open NEW.DOCX in MS-Word
3. The NEW.DOCX has a picture with no hyperlink

Current behavior:
LO exports the picture without the hyperlink

Expected behavior:
LO should export the picture with the hyperlink
              
Operating System: All
Version: 4.3.0.0.alpha1
Comment 1 Commit Notification 2014-05-13 14:31:31 UTC
Miklos Vajna committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=701f3dcb8d647304c56e7c437cc942b908123bc3

fdo#78657 writerfilter: tokenize a:hlinkClick



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 2 Jorendc 2014-05-16 19:53:23 UTC
Repro, tested using Version: 4.3.0.0.alpha1+
Build ID: 48eccfb812284f43ba24c3be3903537ce954944d
TinderBox: Win-x86@39, Branch:master, Time: 2014-05-16_00:35:19

Kind regards,
Joren
Comment 3 Xisco Faulí 2015-08-24 15:01:45 UTC
Problem still present in

Version: 5.0.0.5
Build ID: 1b1a90865e348b492231e1c451437d7a15bb262b
Locale: es-ES (es_ES)

on Windows 7 (64-bit)
Comment 4 pietro.pangallo 2016-06-16 09:25:21 UTC
Problem still present in:
Version: 5.3.0.0.alpha0+
Build ID: a8bd44573b75d1399257d6f5d052611439607189
CPU Threads: 2; OS Version: Linux 4.1; UI Render: default; 
TinderBox: Linux-rpm_deb-x86_64@70-TDF, Branch:master, Time: 2016-06-13_23:46:49
Locale: it-IT (it_IT.UTF-8)
OS: openSUSE Leap 42.1 (x86_64)
Comment 5 Maxim 2016-09-15 14:55:07 UTC
Problem still present in

Version: 5.2.1.2
Build ID: 31dd62db80d4e60af04904455ec9c9219178d620
CPU Threads: 2; OS Version: Linux 3.8; UI Render: default; 
Locale: en-US (en_US.utf8)

  Operating system:          Linux
  Operating system name:     Slackware
  Operating system version:  14.0
  Kernel version:            3.8.2
  Hardware platform:         i686
Comment 6 QA Administrators 2017-12-10 16:41:03 UTC Comment hidden (obsolete)
Comment 7 Gabor Kelemen 2019-05-31 16:01:01 UTC
*** Bug 123629 has been marked as a duplicate of this bug. ***
Comment 8 Commit Notification 2019-06-26 09:04:10 UTC
Tünde Tóth committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/+/100f43ab871bedda6b427645cbfc2c8083da98b5%5E%21

tdf#78657 DOCX export: fix hyperlink inserted to image

It will be available in 6.4.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 9 Xisco Faulí 2019-06-28 12:02:23 UTC
Verified in

Version: 6.4.0.0.alpha0+
Build ID: a294457eb95e60028539b6783abac78b56561fe2
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); UI-Language: en-US
Calc: threaded

@Tünde Tóth, thanks for fixing this issue!!
Comment 10 Commit Notification 2019-06-28 13:55:43 UTC
Tünde Tóth committed a patch related to this issue.
It has been pushed to "libreoffice-6-3":

https://git.libreoffice.org/core/+/0151b1fe4ebb62a25dcb885a1b8d8c6540b16ee6%5E%21

tdf#78657 DOCX export: fix hyperlink inserted to image

It will be available in 6.3.0.1.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 11 Regina Henschel 2019-07-17 12:31:36 UTC
*** Bug 126438 has been marked as a duplicate of this bug. ***