Download it now!
Bug 78749 - [FILEOPEN]: DOCX import filter loses the frame’s (object’s) background bitmap
Summary: [FILEOPEN]: DOCX import filter loses the frame’s (object’s) background bitmap
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.6.7.2 release
Hardware: Other All
: medium major
Assignee: Attila Bakos (NISZ)
URL:
Whiteboard: target:7.0.0 target:6.4.4
Keywords: filter:docx
: 95366 (view as bug list)
Depends on:
Blocks: DOCX-Frames
  Show dependency treegraph
 
Reported: 2014-05-15 17:59 UTC by ape
Modified: 2020-09-02 16:46 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:


Attachments
File for example (22.33 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2014-05-15 17:59 UTC, ape
Details
docx opened - MSO-2007 vs LibreOffice (354.32 KB, image/png)
2014-05-15 18:10 UTC, ape
Details
The sample file in 7.0 master (487.17 KB, image/png)
2020-04-24 08:51 UTC, Attila Bakos (NISZ)
Details

Note You need to log in before you can comment on or make changes to this bug.
Description ape 2014-05-15 17:59:48 UTC
Created attachment 99108 [details]
File for example

Open the attached file using programs LibreOfficeDev-4.3.0 or LibreOffice-3.6.7\4.2.4.
'LibreOfficeDev-4.3.0' and old programs are losing the frame’s (object’s) background bitmap. It’s the loss of data.
Comment 1 ape 2014-05-15 18:10:42 UTC
Created attachment 99113 [details]
docx opened - MSO-2007 vs LibreOffice
Comment 2 Jorendc 2014-05-15 18:35:30 UTC
version number is the oldest version which can reproduce this behavior -> marking as bug of 3.6.7

Reproducible, tested using Mac OSX 10.9 with LibreOffice Version: 4.3.0.0.alpha1+
Build ID: cc4a3f1a88afff114311bddf462ca4bc00a485c7
TinderBox: MacOSX-x86@49-TDF, Branch:master, Time: 2014-05-12_09:05:53

Kind regards,
Joren
Comment 3 ape 2014-05-16 07:54:21 UTC
The history of the file 'blank_edit_406.odt' (attachment 99093 [details]):
 The file 'blank_edit.doc' (attachment 99125 [details]) has been opened by 'LibreOffice 4.0.6' and then was saved as the ODT format.
Comment 4 ape 2014-05-16 11:11:57 UTC
I replaced the background JPEG image on the PNG format image, which is used by LibreOffice to create ODT files. But this change not gives result. Frame’s background image remained invisible.
Comment 5 QA Administrators 2015-06-08 14:41:33 UTC Comment hidden (obsolete)
Comment 6 Buovjaga 2015-06-21 17:08:04 UTC
Confirmed.

Win 7 Pro 64-bit Version: 5.1.0.0.alpha1+
Build ID: 3ecef8cedb215e49237a11607197edc91639bfcd
TinderBox: Win-x86@62-merge-TDF, Branch:MASTER, Time: 2015-06-19_23:16:58
Locale: fi-FI (fi_FI)
Comment 7 QA Administrators 2016-09-20 10:09:54 UTC Comment hidden (obsolete)
Comment 8 Commit Notification 2020-04-20 08:56:55 UTC
Attila Bakos committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/9283cd9e13cd3e0dd7d6b831d930128931862a40

tdf#78749 DOCX: import VML background image

It will be available in 7.0.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 9 Attila Bakos (NISZ) 2020-04-24 08:51:11 UTC
Created attachment 159892 [details]
The sample file in 7.0 master
Comment 10 Xisco Faulí 2020-04-28 09:55:03 UTC
Verified in

Version: 7.0.0.0.alpha0+
Build ID: 4ba1909f12b49f020195b5e767045340717ce6df
CPU threads: 4; OS: Linux 4.19; UI render: default; VCL: gtk3; 
Locale: en-US (en_US.UTF-8); UI-Language: en-US
Calc: threaded

@Attila Bakos, thanks for fixing this issue!
Comment 11 Commit Notification 2020-04-28 09:58:19 UTC
Attila Bakos committed a patch related to this issue.
It has been pushed to "libreoffice-6-4":

https://git.libreoffice.org/core/commit/7e7b828468b17eab752dbe8368a9e84ebbf3d84f

tdf#78749 DOCX: import VML background image

It will be available in 6.4.4.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 12 NISZ LibreOffice Team 2020-09-02 16:46:39 UTC
*** Bug 95366 has been marked as a duplicate of this bug. ***