Download it now!
Bug 78779 - PDF: Bookmarks not exported as described
Summary: PDF: Bookmarks not exported as described
Status: RESOLVED NOTABUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Printing and PDF export (show other bugs)
Version:
(earliest affected)
4.0.6.2 release
Hardware: Other All
: medium minor
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords: bibisectRequest, filter:pdf, regression
: 102152 (view as bug list)
Depends on:
Blocks: PDF-Export Bookmarks
  Show dependency treegraph
 
Reported: 2014-05-16 10:53 UTC by Alan
Modified: 2017-11-23 13:46 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
Document illustrates the problem (2.93 MB, application/vnd.oasis.opendocument.text)
2014-05-17 07:40 UTC, Alan
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Alan 2014-05-16 10:53:47 UTC
Problem description: Bookmarks are not exported to the PDF

Steps to reproduce:
1. Create a document in WORD with at least two heading levels in section headings and import to Writer
2. Create a table of contents 
3. Insert a bookmark on one of the second tier headings
4. Insert a hyperlink from the table of contents entry to the bookmark
5. Export to PDF
6. Check the bookmarks pane - the second tier bookmark does not appear though the manual says it should.

Current behavior: The bookmark is missing in the bookmarks pane

Expected behavior: The bookmarkl should be visible as stated in the manual: "Export bookmarks 
Selects to export bookmarks of Writer documents as PDF bookmarks. Bookmarks are created for all outline paragraphs (Tools - Outline Numbering) and for all table of contents entries for which you did assign hyperlinks in the source document."

              
Operating System: Windows (other)
Version: 4.2.4.2 release
Comment 1 Jorendc 2014-05-16 21:08:42 UTC
Please attach a sample document which we can export as PDF so we can reproduce this behavior. This saves much time. Note the fact we are volunteers and handle as much bugs as possible, in a correct way. If we have to create all the bug documents ourself, we lose a lot of valuable time.

Thanks for your time.

Kind regards,
Joren
Comment 2 Alan 2014-05-17 07:40:15 UTC
Created attachment 99202 [details]
Document illustrates the problem

This is an ODT created from my original WORD with a hyperlink on the table of contents entry "Configuration". Export to PDF. When you open the PDF and look at the bookmarks pane this is not shown.
Comment 3 Jorendc 2014-05-17 08:23:23 UTC
Thanks for your extra information.

Reproducible, tested using Windows 8.1 with LibreOffice 4.2.4.2.

Kind regards,
Joren
Comment 4 QA Administrators 2015-09-04 02:48:20 UTC Comment hidden (obsolete)
Comment 5 Buovjaga 2015-11-19 08:47:50 UTC
Still repro.

Win 7 Pro 64-bit Version: 5.1.0.0.alpha1+
Build ID: 66d2b72667792cb18b25805387824d636e2a455c
TinderBox: Win-x86@39, Branch:master, Time: 2015-11-18_02:35:53
Locale: fi-FI (fi_FI)
Comment 6 Xisco Faulí 2016-09-29 11:57:15 UTC
*** Bug 102152 has been marked as a duplicate of this bug. ***
Comment 7 Yousuf Philips (jay) (retired) 2016-10-04 21:29:14 UTC
As mentioned in my duplicate bug, this regression started in 4.0.
Comment 8 Cor Nouws 2017-11-23 13:35:34 UTC
I do not understand the problem.


(In reply to Alan from comment #0)

> Current behavior: The bookmark is missing in the bookmarks pane
> 
> Expected behavior: The bookmarkl should be visible as stated in the manual:
> "Export bookmarks 
> Selects to export bookmarks of Writer documents as PDF bookmarks. Bookmarks
> are created for all outline paragraphs (Tools - Outline Numbering) and for
> all table of contents entries for which you did assign hyperlinks in the
> source document."

The quote from 'the manual' says Headings and TOC lines with hyperlinks are exported as PDF. Not that bookmarks are exported.
What do I miss?
Comment 9 Cor Nouws 2017-11-23 13:36:29 UTC
(In reply to Xisco Faulí from comment #6)
> *** Bug 102152 has been marked as a duplicate of this bug. ***

This bug is: "Setting "bookmarks and page" pdf export option not working"
Nothing to do with this bug??
Comment 10 Buovjaga 2017-11-23 13:46:41 UTC
Right, there appears to have been a misunderstanding. Closing.