Bug 78834 - UI: untranslated UI elements in save, open, export window
Summary: UI: untranslated UI elements in save, open, export window
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Localization (show other bugs)
Version:
(earliest affected)
4.2.4.2 release
Hardware: Other Mac OS X (All)
: medium normal
Assignee: Andras Timar
URL:
Whiteboard: BSA target:5.0.0 target:4.4.4
Keywords: possibleRegression
: 75527 77425 80766 80976 (view as bug list)
Depends on:
Blocks:
 
Reported: 2014-05-17 17:40 UTC by bugzilla
Modified: 2015-12-15 22:11 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
Save window in German localization (95.75 KB, image/png)
2014-05-17 17:40 UTC, bugzilla
Details
Open window in German localization (44.60 KB, image/png)
2014-05-17 17:41 UTC, bugzilla
Details
Export window in German localization (36.50 KB, image/png)
2014-05-17 17:41 UTC, bugzilla
Details
Save window in Japanese localization (101.49 KB, image/png)
2014-05-17 17:42 UTC, bugzilla
Details

Note You need to log in before you can comment on or make changes to this bug.
Description bugzilla 2014-05-17 17:40:03 UTC
Created attachment 99227 [details]
Save window in German localization

Problem description: Since version 4.2 of LibreOffice some elements of the save, open or export window are not translated into the chosen location. I have checked it only on Mac OS X 10.9 and 10.6 and only with the German, French, Japanese and Polish localization. Other localization may also be affected. I have not looked into other systems, so Windows and Linux may or may not be affected.

Steps to reproduce:
1. Open LibreOffice with an installed location different than English
2. Save a document
3. Check if e.g. the Save-button is translated

Current behavior: Some UI elements are in English language instead of the language of the localization.

Expected behavior: All UI elements should be translated

              
Operating System: Mac OS X
Version: 4.2.4.2 release
Last worked in: 4.1.6.2 release
Comment 1 bugzilla 2014-05-17 17:41:13 UTC
Created attachment 99228 [details]
Open window in German localization
Comment 2 bugzilla 2014-05-17 17:41:38 UTC
Created attachment 99229 [details]
Export window in German localization
Comment 3 bugzilla 2014-05-17 17:42:17 UTC
Created attachment 99230 [details]
Save window in Japanese localization
Comment 4 bugzilla 2014-05-17 17:45:04 UTC
Printing window elements are also affected and also described in Bug 77425.
Comment 5 Claude R Perrin 2014-05-17 18:51:52 UTC
*** Bug 77425 has been marked as a duplicate of this bug. ***
Comment 6 Andras Timar 2015-05-03 19:34:47 UTC
Localization on OS X is handled on purely a per-application basis. For every application localization is chosen at startup based on the available .lproj directories and the user's current localization rankings as set in the Language and Region pane of System preferences. But LibreOffice uses its own localization system, and does not have .lproj directories at all.

In my test environment I set Hungarian as preferred language. LibreOffice started in Hungarian. The buttons in File - Open/Export/Save dialogs were in English. Then I created an empty folder called hu.lproj in LibreOffice.app/Contents/Resources. Next time the buttons in File - Open/Export/Save dialogs were in Hungarian. So, to solve tdf#78834, we need to install empty lproj bundles for all supported languages.
Comment 7 Commit Notification 2015-05-08 11:30:47 UTC
Andras Timar committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=2df138b483f60ffdcd3b62c8c2884d2f5cc076af

tdf#78834 enable localized system dialogs on OS X

It will be available in 5.0.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 8 Adolfo Jayme 2015-05-08 13:18:34 UTC
*** Bug 80766 has been marked as a duplicate of this bug. ***
Comment 9 Adolfo Jayme 2015-05-08 13:21:10 UTC
*** Bug 80976 has been marked as a duplicate of this bug. ***
Comment 10 Commit Notification 2015-05-08 15:51:45 UTC
Andras Timar committed a patch related to this issue.
It has been pushed to "libreoffice-4-4":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=b4d2b39cb9e46cb0b09d5c1f3d3dadfeb16c30d2&h=libreoffice-4-4

tdf#78834 enable localized system dialogs on OS X

It will be available in 4.4.4.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 11 Andras Timar 2015-08-03 10:45:17 UTC
*** Bug 75527 has been marked as a duplicate of this bug. ***
Comment 12 Robinson Tryon (qubit) 2015-12-15 22:11:14 UTC
Migrating Whiteboard tags to Keywords: (PossibleRegression)
[NinjaEdit]