Bug 78845 - UI Icon Create New Folder in dialog File Save (As) closes dialog and doesn't show the needed dialog
Summary: UI Icon Create New Folder in dialog File Save (As) closes dialog and doesn't ...
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
4.3.0.0.alpha0+ Master
Hardware: x86 (IA32) All
: high critical
Assignee: Maxim Monastirsky
URL:
Whiteboard: target:4.4.0 target:4.3.1
Keywords: regression
: 80550 80860 81928 82303 82345 82409 82556 82941 83503 83599 (view as bug list)
Depends on:
Blocks: mab4.3
  Show dependency treegraph
 
Reported: 2014-05-18 03:31 UTC by Richard_416282
Modified: 2015-02-19 15:22 UTC (History)
14 users (show)

See Also:
Crash report or crash signature:


Attachments
Screen Capture - SAVEAS with 3 Icons in Upper Right (49.77 KB, image/jpeg)
2014-05-18 03:31 UTC, Richard_416282
Details
LO FILESAVE SaveAs Windows7 default Screen (86.54 KB, image/png)
2014-05-18 03:40 UTC, Richard_416282
Details
LO FILESAVE SaveAs 4.3 Alpha with 3 Icons in Upper Right (49.77 KB, image/jpeg)
2014-05-18 03:43 UTC, Richard_416282
Details
Tools_Options_General_BeforeChange (27.73 KB, image/jpeg)
2014-05-22 14:22 UTC, Richard_416282
Details
Tools_Options_General_AfterChange (51.75 KB, image/jpeg)
2014-05-22 14:23 UTC, Richard_416282
Details
Reversion_Capture (57.21 KB, image/jpeg)
2014-05-22 14:25 UTC, Richard_416282
Details
Tools_Options_General_AfterChange_Reversion2 (54.34 KB, image/jpeg)
2014-05-22 14:31 UTC, Richard_416282
Details
Tools_Options_General_AfterChange_Reversion3 (54.34 KB, image/jpeg)
2014-05-22 14:32 UTC, Richard_416282
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Richard_416282 2014-05-18 03:31:54 UTC
Created attachment 99255 [details]
Screen Capture - SAVEAS with 3 Icons in Upper Right

After Launching Writer from the Taskbar in Windows 7, with a user profile, attempt to do a 'SaveAs' and create a 'NEW FOLDER', prior to doing a SaveAs, when clicking the 'NewFolder' Icon, the 'SaveAs' window exits, but no 'New Folder' window opens up.

Expectation is to function as it has in the past, where a user could create a new subfolder in any writable directory, then perform the save to the new folder.

Clicking the 3rd Icon to the Upper Right Causes the 'SaveAs' screen to exit, without a NewFolder Dialogue being launched. (Does Not happen on 4.2.4.2 for Windows x64 on WOW using IA64 CPU)
Comment 1 Richard_416282 2014-05-18 03:33:50 UTC
Changed Version to 4.3.0.0.alpaha0Plus (or better) and OS as Windows(Any)
Comment 2 Richard_416282 2014-05-18 03:40:06 UTC
Created attachment 99257 [details]
LO FILESAVE SaveAs Windows7 default Screen

Version 4.2.4.2 Screen Capture Image
Comment 3 Richard_416282 2014-05-18 03:41:57 UTC
Comment on attachment 99255 [details]
Screen Capture - SAVEAS with 3 Icons in Upper Right

Image not uploaded correct. See 3rd Attachment.
Comment 4 Richard_416282 2014-05-18 03:43:49 UTC
Created attachment 99258 [details]
LO FILESAVE SaveAs 4.3 Alpha with 3 Icons in Upper Right

Image upload?
Comment 5 Cor Nouws 2014-05-18 10:18:12 UTC
Thanks for reporting Richard. I confirm this on Linux.
(And remove some uppercase from the issues summary ;) )
Cheers,
Cor
Comment 6 Maxim Monastirsky 2014-05-19 14:24:46 UTC
I can't reproduce this with master (48fb7d096a73ad3dbaa7763b6b760693ee069632) under Fedora 20. Clicking the 3rd button opens a dialog, that allows to give a name to the new folder. Tested using the generic file dialog.

@Richard: The 4.3 screenshot that you provided is from a very old version. Since 2014-03-04 the first button has a text "Servers..." [1], but your screenshot doesn't have that. Could you go to Help->About and tell us the date of this build (or the Build-ID)? Also could you please download a recent build, and report us whether you problem solved there?

Download link: (For Windows pick one of the Win-* folders)
http://dev-builds.libreoffice.org/daily/master/

Thanks!

@Cor: Which build and DE did you use to reproduce the bug?

[1] http://cgit.freedesktop.org/libreoffice/core/commit/?id=b455abb0138a3f296e0d9a833c0d3c205295d78a
Comment 7 Richard_416282 2014-05-21 02:38:05 UTC
Build ID: d88bf2aa5648caa01edaf2252166d0724fad0a49
TinderBox: Win-x86@39, Branch:master, Time: 2014-01-04_10:00:57

Saved as C:\Program Files(x86)\LibreOfficeDev4\...

Version 4.3.0.0.alpha0+

This release supplied by tinderbox.

working under Intel-DualCore CPU. OS is Win7Home.
Comment 8 Richard_416282 2014-05-22 14:20:50 UTC
Steps Taken;


A) Download Newer Version of 4.3.0.0.alpha.1+

B) Install New Version in separate "Program File" space (Change Default = LO dev4), save as LOdev43

C) Verify Changes did nothing special to document handling, notice, "Save As" dialogue reverted to "Windows.. SaveAs" 

D) Attempt Windows.. SaveAs.. 'NewFolder".
-- Works as designed, creates a "NewFolder", poplulates the name "NewFolder" in the folder box. (Normal Operation).

--notice missing "Connect to Server" button not in windows dialoge.

-- Check "help.. Document.. SaveAs"

-- Option to use "OpenOffice Dialogue", not set.

D.1) Set "Tools.. Options .. General.. "Use OpenOffice Dialogues" checkbox.

D.2) Restart System.

E) Verify if "SaveAs " displays dialogue. Yes.

F) Verify if "NewFolder" button functions. 
-- Opens NewFolder Dialoge, with cursor at input field, and BlankSpace is filled in with AutoDefault of "Folder". (Windows uses "NewFolder").

G) Check if "Folder" is generated, Yes.

Perform same "Uncheck box, Reset System, Set Checkbox on Stable "4.2.." version, Opens "NewFolder" Dialogue and AutoCompletes blank field with "Folder", as part of Dialogue.

See Pictures Attached.

Yeah.... 4.3.0.0.alpha1+ seems to have bug fixed or was bug in registry in first place? Now OK.
Comment 9 Richard_416282 2014-05-22 14:22:26 UTC
Created attachment 99585 [details]
Tools_Options_General_BeforeChange
Comment 10 Richard_416282 2014-05-22 14:23:42 UTC
Created attachment 99586 [details]
Tools_Options_General_AfterChange
Comment 11 Richard_416282 2014-05-22 14:25:11 UTC
Created attachment 99587 [details]
Reversion_Capture
Comment 12 Richard_416282 2014-05-22 14:27:58 UTC
Comment on attachment 99587 [details]
Reversion_Capture

This Screen Capture shows the results of the "Windows " SaveAs Function after reversion to Uncheck "Use OpenOffice Dialogue" in Tools..Options..General.. back to default (use windows Dialogue).
Comment 13 Richard_416282 2014-05-22 14:31:20 UTC
Created attachment 99588 [details]
Tools_Options_General_AfterChange_Reversion2

After Reset "tools..options.. Use OpenOffice Dialogues" by using a  checkmark, and a Re-Boot.
Comment 14 Richard_416282 2014-05-22 14:32:16 UTC
Created attachment 99589 [details]
Tools_Options_General_AfterChange_Reversion3

Works... As it should.
Comment 15 Richard_416282 2014-05-22 14:39:48 UTC
By Resetting the "Tools.. Options.. UseOpenOffice Dialogues" in the "General Features section of Options, this re-set the paramater, that, may not have been migrated across version upgrades .. (MySpeculations).

Could be new Code in 4.3.0.0.alpaha1+ that is not in 4.3.0.0.alpaha0+?

Not sure.

But is now working and Opens up a little window (at least its not hiddden under another window) that asks the name of the new folder.

Appears to be fixed.
(4.2 may not have had the problem)

May have been an install issue during the installation of the 4.3.0.0.alpha0 version from December 2013.
Comment 16 Urmas 2014-06-09 05:06:18 UTC
Still doesn't work in 4.4 master in Windows.
Comment 17 Bugcruncher 2014-06-18 17:59:20 UTC
Still a problem with WIN7 Version 4.3.0.0.beta2 Build-ID: a06aa316117a6ff0f05c697c82831c227812d810 CALC
Comment 18 Urmas 2014-06-26 14:00:59 UTC
*** Bug 80550 has been marked as a duplicate of this bug. ***
Comment 19 Cor Nouws 2014-07-03 21:45:30 UTC
*** Bug 80860 has been marked as a duplicate of this bug. ***
Comment 20 ribotb 2014-07-12 09:51:08 UTC
I confirm this bug with 
Version: 4.3.0.2
Build ID: 14ed55896fdfcb93ff437b85c4f3e1923d2b1409

under Win 7 / x86

Bernard
Comment 21 Maxim Monastirsky 2014-07-31 20:18:44 UTC
*** Bug 81928 has been marked as a duplicate of this bug. ***
Comment 22 Bugcruncher 2014-08-01 04:59:38 UTC
Still in Release
"Version: 4.3.0.4 Build-ID: 62ad5818884a2fc2e5780dd45466868d41009ec0"! Holy crap, this one is really annoying!
Comment 23 Cor Nouws 2014-08-08 17:16:14 UTC
*** Bug 82345 has been marked as a duplicate of this bug. ***
Comment 24 Jean-Baptiste Faure 2014-08-08 17:45:46 UTC
Under Ubuntu 14.04 and LO 4.3.2.0.0+, reproducible only if I use the LibreOffice filepicker instead of the Gnome filepicker (the filepicker of the system).

Best regards. JBF
Comment 25 Commit Notification 2014-08-10 09:15:07 UTC
Maxim Monastirsky committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=b73ee73da55c5a00acc9adffc825157dd5b375e6

fdo#78845 Packaging of fpicker ui files



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 26 Maxim Monastirsky 2014-08-10 09:18:20 UTC
*** Bug 82409 has been marked as a duplicate of this bug. ***
Comment 27 Maxim Monastirsky 2014-08-10 09:22:10 UTC
*** Bug 82303 has been marked as a duplicate of this bug. ***
Comment 28 Cor Nouws 2014-08-10 09:54:10 UTC
thanks Maxim!
Cor
Comment 29 Commit Notification 2014-08-11 05:47:10 UTC
Maxim Monastirsky committed a patch related to this issue.
It has been pushed to "libreoffice-4-3":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=24884b2007a7dc48fa13bd3fd32d36109536403c&h=libreoffice-4-3

fdo#78845 Packaging of fpicker ui files


It will be available in LibreOffice 4.3.2.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 30 Commit Notification 2014-08-11 15:59:38 UTC
Maxim Monastirsky committed a patch related to this issue.
It has been pushed to "libreoffice-4-3-1":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=c6beff5dc531890bd8758115f792a9ef0440ff08&h=libreoffice-4-3-1

fdo#78845 Packaging of fpicker ui files


It will be available already in LibreOffice 4.3.1.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 31 Maxim Monastirsky 2014-08-13 11:59:00 UTC
*** Bug 82556 has been marked as a duplicate of this bug. ***
Comment 32 sophie 2014-08-13 12:26:28 UTC
Hi, confirmed it's fixed with Version: 4.4.0.0.alpha0+
Build ID: 13d4f7b800a9f35717ed91f330b38513e0db4bc6
TinderBox: Linux-rpm_deb-x86_64@46-TDF, Branch:master, Time: 2014-08-12_16:26:55
Thanks :) Sophie
Comment 33 Maxim Monastirsky 2014-08-22 10:58:26 UTC
*** Bug 82941 has been marked as a duplicate of this bug. ***
Comment 34 Maxim Monastirsky 2014-09-04 14:26:13 UTC
*** Bug 83503 has been marked as a duplicate of this bug. ***
Comment 35 Adolfo Jayme 2014-09-08 05:28:27 UTC
*** Bug 83599 has been marked as a duplicate of this bug. ***