Download it now!
Bug 78906 - FILEOPEN: LO crashes while opening the file
Summary: FILEOPEN: LO crashes while opening the file
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.3.0.0.alpha1
Hardware: Other Linux (All)
: medium normal
Assignee: Umesh Kadam
URL:
Whiteboard: BSA target:4.3.2 target:4.4.0.0.beta2...
Keywords:
: 82484 84760 (view as bug list)
Depends on:
Blocks:
 
Reported: 2014-05-19 11:57 UTC by Umesh Kadam
Modified: 2014-12-18 13:00 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
File contains formula in a box (15.51 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2014-05-19 11:57 UTC, Umesh Kadam
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Umesh Kadam 2014-05-19 11:57:55 UTC
Created attachment 99332 [details]
File contains formula in a box

Problem description: 

Steps to reproduce:
1. Try opening the file in LO

Current behavior:
LO crashes while opening the file

Expected behavior:
LO should be able to open and save the file without any errors.
              
Operating System: Ubuntu
Version: 4.3.0.0.alpha1
Comment 1 Joel Madero 2014-05-20 04:09:21 UTC
Please test again with a later master - I just opened it fine with 4.3 built a few days ago.

Ubuntu 14.04 x64

marking as NEEDINFO - http://dev-builds.libreoffice.org/daily/master/

You can get a new daily there, try with a fresh profile: https://wiki.documentfoundation.org/UserProfile

If you can still reproduce, mark as UNCONFIRMED again and I'll get additional tests. If it's resolved, mark the bug as RESOLVED -> WORKSFORME. Thanks!
Comment 2 Umesh Kadam 2014-05-26 10:22:39 UTC
Joel Madero : I re-tested this issue on Ubuntu 12.04 and 14.04 on build id : 9444a1ffccadcc41d5e3f7519d870392dcbaf19d. The document fails to open.

While on Windows build ( mentioned below ) the document opens and I am able to RT as well.

Version: 4.4.0.0.alpha0+
Build ID: dc91ebed1a3b0ef900b1bb5cf203c6a9aeb83016
TinderBox: Win-x86@42, Branch:master, Time: 2014-05-26_01:38:23
Comment 3 Commit Notification 2014-06-05 09:21:51 UTC
Umesh Kadam committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=14ce4b337232f8fb21cc67e7a2844a7de81dfc4c

fdo#78906 : File crashes while opening.



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 4 Julien Nabet 2014-08-12 16:49:24 UTC
*** Bug 82484 has been marked as a duplicate of this bug. ***
Comment 5 Julien Nabet 2014-08-12 16:59:59 UTC
Since there's a dup, I cherry-picked the fix and sent it for review for 4.3:
https://gerrit.libreoffice.org/#/c/10897/
Comment 6 Commit Notification 2014-08-13 10:37:02 UTC
Umesh Kadam committed a patch related to this issue.
It has been pushed to "libreoffice-4-3":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=fbb9bdef45d3a013b5027acc1ceb7faa77f531a4&h=libreoffice-4-3

fdo#78906 (+dup fdo#82484): File crashes while opening.


It will be available in LibreOffice 4.3.2.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 7 Caolán McNamara 2014-10-09 13:20:25 UTC
*** Bug 84760 has been marked as a duplicate of this bug. ***
Comment 8 Commit Notification 2014-11-30 20:43:07 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-4-4":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=bff0fe902686d8c126a73e1d2c914f5d65c6ffaf&h=libreoffice-4-4

mirror fixes for fdo#78906 and deb#766788 into icu

It will be available in 4.4.0.0.beta2.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 9 Commit Notification 2014-12-02 12:07:53 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-4-2":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=4c30e379abe0ebe1cbf302c553120b1be966ec3e&h=libreoffice-4-2

mirror fixes for fdo#78906 and deb#766788 into icu

It will be available in 4.2.9.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 10 Commit Notification 2014-12-02 12:39:11 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-4-3":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=66dbae0932041d10a8662d388f1fb003b5b35bd8&h=libreoffice-4-3

mirror fixes for fdo#78906 and deb#766788 into icu

It will be available in 4.3.6.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 11 Commit Notification 2014-12-03 15:31:58 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-4-2-8":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=8594604107f1727303f57294c4c8c8a8dc5d2265&h=libreoffice-4-2-8

mirror fixes for fdo#78906 and deb#766788 into icu

It will be available in 4.2.8.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 12 Commit Notification 2014-12-04 14:01:11 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-4-3-5":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=f076fa33a4d301d7ee762a7195c76bfd68801e09&h=libreoffice-4-3-5

mirror fixes for fdo#78906 and deb#766788 into icu

It will be available in 4.3.5.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.