Bug 79022 - Please bundle Source Serif Pro
Summary: Please bundle Source Serif Pro
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: ux-advise (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: Other All
: medium enhancement
Assignee: Heiko Tietze
URL:
Whiteboard: target:6.2.0
Keywords:
: 91150 (view as bug list)
Depends on:
Blocks: Fonts-Bundled
  Show dependency treegraph
 
Reported: 2014-05-21 16:30 UTC by Adolfo Jayme
Modified: 2018-09-03 07:06 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Adolfo Jayme 2014-05-21 16:30:33 UTC
Info:     http://blog.typekit.com/2014/05/20/source-serif-pro/
Test:     http://adobe.github.io/source-serif-pro/
Download: http://sourceforge.net/projects/sourceserifpro.adobe/files/

It is a superb companion to Source Sans/Code (both of which we already ship) that has just been released. It is available under the SIL Open Font license, and looks great under Windows.
Comment 1 V Stuart Foote 2014-05-21 17:02:49 UTC
Setting new -- enhancement.

Likely that this will be picked up quickly in the FOSS world, so LibreOffice will have to handle content using the font across its components. In the scheme of things the additional size will be off set by compatibility. So I'd say add it.
Comment 2 Francisco 2014-05-21 23:30:17 UTC
I think that the released version of this typeface is nice, I like it. But... there is *no* italic/slanted version. In my opinion, as a user, I disagree at leaset until somebody release an italic version.
Comment 3 Urmas 2014-05-22 07:02:05 UTC
Source Sans/Serif should not be included _at all_ as they contain no Cyrillic characters.
Comment 4 Tor Lillqvist 2014-05-22 07:03:03 UTC
Or else!?
Comment 5 Tin Man 2014-05-22 09:26:26 UTC
Agreed that it should be added in the future, but I would hold off until it has italic variants.
Comment 6 Stefan Knorr (astron) 2014-05-22 15:30:44 UTC
The consensus seems to be that the font is nice, but not ready => setting to WONTFIX for the moment.

Re-open this when the font has grown a true italics variant.
Comment 7 Adolfo Jayme 2015-05-08 13:03:08 UTC
*** Bug 91150 has been marked as a duplicate of this bug. ***
Comment 8 Yousuf Philips (jay) (retired) 2016-02-14 13:48:01 UTC
The status of the italic variant can be found at this github issue.

https://github.com/adobe-fonts/source-serif-pro/issues/2
Comment 9 Yousuf Philips (jay) (retired) 2018-08-18 19:53:58 UTC
Italic version release yesterday and as the source family wasnt removed with bug 103080, then we could add it to complete the family or remove the family.
Comment 10 Heiko Tietze 2018-08-19 08:17:34 UTC
We should discuss Source Serif Pro again.
Comment 11 Tomaz Vajngerl 2018-08-21 14:21:36 UTC
We already have SourceCodePro and SourceSansPro. SourceSerifPro is highly needed to have a complete font family.
Comment 12 Heiko Tietze 2018-08-22 18:32:00 UTC
So let's do. Taking the task.
Comment 13 Commit Notification 2018-09-03 07:05:13 UTC
heiko tietze committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=3ff21b52de4047a03c4fcd82daff8aff588aebc3

tdf#79022 - Please bundle Source Serif Pro

It will be available in 6.2.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 14 Heiko Tietze 2018-09-03 07:06:45 UTC
With the Serif variant the request should be done. Reopen in case there is something missing.