Bug 79122 - Other: The program can't start
Summary: Other: The program can't start
Status: RESOLVED NOTOURBUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Installation (show other bugs)
Version:
(earliest affected)
4.3.0.0.beta1
Hardware: Other Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords: possibleRegression
: 79241 (view as bug list)
Depends on:
Blocks:
 
Reported: 2014-05-23 14:08 UTC by gitzu
Modified: 2015-12-15 10:55 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
The screen capture with the error (87.88 KB, image/jpeg)
2014-05-23 14:08 UTC, gitzu
Details
Libre Office now start correctly....But trying open a file with calc produce this error (Screen capture message) (84.77 KB, image/jpeg)
2014-05-26 05:45 UTC, gitzu
Details
File opened that produce the new error message (592.50 KB, application/vnd.ms-excel)
2014-05-26 05:53 UTC, gitzu
Details
Confirm false positive in Avast (149.44 KB, image/jpeg)
2014-05-26 20:48 UTC, gitzu
Details
Perhaps another different bug, with specific open file in calc (84.94 KB, image/jpeg)
2014-05-26 20:50 UTC, gitzu
Details

Note You need to log in before you can comment on or make changes to this bug.
Description gitzu 2014-05-23 14:08:13 UTC
Created attachment 99637 [details]
The screen capture with the error

Problem description: 

Steps to reproduce:
Install LibreOfficeDev_4.3.0.0.beta1_Win_x86.msi
Doble click to "C:\Program Files\LibreOfficeDev 4\program\soffice.exe" or simply call to direct access

Current behavior:
The messsage basegfxlo.dll is missing and program can't start.

Expected behavior:
LibreOficce start at doble click in direct access.
              
Operating System: Windows 7
Version: 4.3.0.0.beta1
Last worked in: 4.2.4.2 release
Comment 1 GerardF 2014-05-23 17:24:53 UTC
Related to Avast.

Avast put basegfxlo.dll and nsplugin.exe in quarantine.
(suspicion of Win32:Evo-gen)
Comment 2 Julien Nabet 2014-05-24 21:57:59 UTC
Did you download LO from official website? (http://www.libreoffice.org/download/libreoffice-fresh/)
Comment 3 gitzu 2014-05-25 15:53:33 UTC
Hi there....

I follow instruction from:
https://wiki.documentfoundation.org/BugHunting_Session_4.3.0

Quick Start :
* Download: http://dev-builds.libreoffice.org/pre-releases/
* Test what you want
* Found a bug? Mention at irc / write an issue
Simple as that - all help greatly appreciated !
-----------------------------------------------
Then the installer is from:
http://dev-builds.libreoffice.org/pre-releases/win/x86/LibreOfficeDev_4.3.0.0.beta1_Win_x86.msi  

Regards...
Comment 4 Julien Nabet 2014-05-25 16:51:37 UTC
Thank you gitzu for your feedback, I put it back to NEW.

(Just by curiosity, with last updates of Avast, does it still put them in quarantine?)
Comment 5 gitzu 2014-05-26 05:45:11 UTC
Created attachment 99823 [details]
Libre Office now start correctly....But trying open a file with calc produce this error (Screen capture message)
Comment 6 gitzu 2014-05-26 05:53:36 UTC
Created attachment 99825 [details]
File opened that produce the  new error message

In the load of document Calc now show the message in previous attachment (clipboard1.jpg)
Comment 7 gitzu 2014-05-26 06:04:57 UTC
Comment on attachment 99823 [details]
Libre Office now start correctly....But trying open a file with calc produce this error (Screen capture message)

Libre Office now start correctly....But trying to open a file with Calc produce this error (Screen capture message)
Comment 8 Julien Nabet 2014-05-26 19:24:23 UTC
On pc Debian x86-64 with 4.2 sources updated some days ago, I don't reproduce the problem.
At the opening, LO proposed me to update links to other files, answering yes or no leads to no crash.

Given the problem you had with Avast, could you give a try to a raw reinstall, I mean:
- uninstall completely LO
- remove any remnant LO directories (backup your LO directory profile if needed)
- clean your Windows registry with a free tool (eg: ccleaner)
- install LO again.
?
Comment 9 Julien Nabet 2014-05-26 20:06:52 UTC
*** Bug 79241 has been marked as a duplicate of this bug. ***
Comment 10 gitzu 2014-05-26 20:48:56 UTC
Created attachment 99894 [details]
Confirm false positive in Avast
Comment 11 gitzu 2014-05-26 20:50:13 UTC
Created attachment 99896 [details]
Perhaps another different bug, with specific open file in calc
Comment 12 gitzu 2014-05-26 20:53:01 UTC
(In reply to comment #8)
> On pc Debian x86-64 with 4.2 sources updated some days ago, I don't
> reproduce the problem.
> At the opening, LO proposed me to update links to other files, answering yes
> or no leads to no crash.
> 
> Given the problem you had with Avast, could you give a try to a raw
> reinstall, I mean:
> - uninstall completely LO
> - remove any remnant LO directories (backup your LO directory profile if
> needed)
> - clean your Windows registry with a free tool (eg: ccleaner)
> - install LO again.
> ?

Dear Julien Nabet,

Really there are two problems:
1. With avast there are a false positive, confirmed, (You can see new attachment). Posible solution: inform Avast about false positive.

2. New problem, perhaps another different bug: 
Running wihtout avast, i'ts ok, but tryging to open file "18_aspectos_demograficos.xls" in previos attachment give some error messages (Not in 4.2 version, only en 4.3  (LibreOfficeDev_4.3.0.0.beta1_Win_x86). I tried in two diferents PCs.
LO gave me two differents error messages: one previosly shown in an attachement, and this new in "LO-perhapsOtherBug.jpg" attachnment
Comment 13 Julien Nabet 2014-05-28 20:14:09 UTC
Gitzu: so let's consider this tracker as the bug nĀ°1 (False positive from Avast). Feel free to contact Avast about it.
For the second one, please create a new bugtracker.
Comment 14 Robinson Tryon (qubit) 2015-12-15 10:55:13 UTC
Migrating Whiteboard tags to Keywords: (possibleRegression)
[NinjaEdit]