Bug 79143 - VIEWING: display of TIFF file copy/pasted into text
Summary: VIEWING: display of TIFF file copy/pasted into text
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: graphics stack (show other bugs)
Version:
(earliest affected)
4.2.0.4 release
Hardware: Other Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords: bibisected, bisected, regression
Depends on:
Blocks: Images-TIFF
  Show dependency treegraph
 
Reported: 2014-05-23 17:03 UTC by marymacgregor24
Modified: 2019-06-29 01:40 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
sample of TIFF files - see explanation above (12.09 KB, application/vnd.oasis.opendocument.text)
2014-05-23 17:03 UTC, marymacgregor24
Details
screenshot (332.94 KB, image/jpeg)
2014-05-24 10:09 UTC, tommy27
Details

Note You need to log in before you can comment on or make changes to this bug.
Description marymacgregor24 2014-05-23 17:03:59 UTC
Created attachment 99665 [details]
sample of TIFF files - see explanation above

Problem description: 
I am compiling a catalogue of knitting patterns...a collection of TIFF files each showing dots in squares, and do this by copy/paste into my writer document. THis worked fine in version 4.1.2.3. This afternoon I upgraded to version 4.2.4.2 and then when I opened the document, I couldn't see the squares, but just points delimiting the corners of the squares. The dots in the squares are fine.
So I posted this on ask-a-question, and Pedro answered and suggested I uninstalled this latest version and tried version 4.1.6.2 instead, which I have done, and it's displaying the squares OK again. 
So I'm thinking it's a problem of display in your new 4.2. Otherwise, can you tell me what to change so that it displays OK? Thanks.
Hope this helps.
Sample document is attached for info.
Steps to reproduce:
1. ....
2. ....
3. ....

Current behavior:

Expected behavior:

              
Operating System: Windows 7
Version: 4.2.4.2 release
Last worked in: 4.1.6.2 release
Comment 1 tommy27 2014-05-24 10:09:31 UTC
Created attachment 99697 [details]
screenshot

confirmed under Win7x64 using 4.2.0.4, 4.2.4.2 and 4.3beta1
works fine with 4.1.6.2 hence regression
Comment 2 Andras Timar 2014-05-24 17:50:55 UTC
Yet another regression caused by 2e51675 Resolves: #i123500# unified Graphic processing to use GraphicPrimitive2D.
Comment 3 Michael Stahl (CIB) 2014-05-30 13:40:39 UTC
this could be similar, maybe duplicate to bug 79334: badly scaled image
Comment 4 Robinson Tryon (qubit) 2015-12-13 11:16:13 UTC Comment hidden (obsolete)
Comment 5 Xisco Faulí 2016-09-26 15:03:10 UTC
Adding Cc: to Armin Le Grand
Comment 6 Xisco Faulí 2017-09-29 08:51:04 UTC Comment hidden (obsolete)
Comment 7 V Stuart Foote 2019-06-29 01:33:58 UTC
This was fixed at somepoint, the TIFF are being correctly formed on opening attachment 99665 [details] with 6.2.4.2; or when extracting the TIFF and inserting to other modules.