Bug 79172 - 4.3Beta1 missing the "beta" string on its splash screen
Summary: 4.3Beta1 missing the "beta" string on its splash screen
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
4.3.0.0.beta1
Hardware: All All
: medium minor
Assignee: Not Assigned
URL: https://gerrit.libreoffice.org/10313/
Whiteboard: target:4.4.0
Keywords:
Depends on:
Blocks:
 
Reported: 2014-05-24 09:36 UTC by Martin Srebotnjak
Modified: 2014-08-21 16:38 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Martin Srebotnjak 2014-05-24 09:36:54 UTC
Beta1 version of 4.3.0 is missing the "beta" declaration on the splash screen.
Comment 1 V Stuart Foote 2014-05-24 15:49:33 UTC
@Miles,

Thanks for posting. But nothing is 'missing'; rather, the developmental, alpha, beta and release candidates are simply not flagged that way in the StartCenter with the timed release development of the project.

Each build cycle is clearly labeled in the Help -> About menu panel with Version and Build ID, here for example:
Version: 4.3.0.0.beta1
Build ID: 2e39c7e59c8fc8b16a54c3d981dceef27fb0c07f 

Also identified as a development version with LibreOfficeDev in the Window container.
Comment 2 Martin Srebotnjak 2014-05-24 18:27:19 UTC
Wait, I remember using alpha version that displayed "beta" on the splash screen (we are talking about the splash screen, not the start center here). So alpha has "beta" on splash screen, and beta has nothing there, that is expected behaviour?
Comment 3 V Stuart Foote 2014-05-24 18:56:56 UTC
Sure you are not thinking about the recent AOO 4.1.0 release cycle?

Pretty sure LibreOffice has never used a "Beta" marking of any form on the splash screen or the start center--just not necessary.
Comment 4 Martin Srebotnjak 2014-05-24 19:44:30 UTC
Please, check first.
I just downloaded a daily build for OS X from here:
http://dev-builds.libreoffice.org/daily/libreoffice-4-3/MacOSX-x86@49-TDF/current/
On the splash screen in the upper right corner there is big "beta" word. So daily build has "beta" written on splash screen, and the official beta does not. Is that normal?
I cannot printscreen this as the splash screen stays only a few seconds and my fingers are just not fast enought.
This is a bug - the behaviour is not consistent nor logical.
Comment 5 Adolfo Jayme 2014-05-24 19:47:57 UTC
I can confirm that LibreOffice alpha builds are labeled "beta" and beta builds have the release branding.
Comment 6 V Stuart Foote 2014-05-24 23:27:27 UTC
Difference is the TB builds using 
http://opengrok.libreoffice.org/xref/core/icon-themes/galaxy/brand_dev/intro.png

and the TDF build using
http://opengrok.libreoffice.org/xref/core/icon-themes/galaxy/brand/intro.png

Would say Resolved Wontfix -- but will leave that for Christian to comment.
Comment 7 Martin Srebotnjak 2014-05-25 11:09:55 UTC
What is resolved?
Saying "I won't fix it" resolves a bug?

I understand that goes for things that are designed features, but this clearly is a bug, and if you do not want to fix it maybe someone else will, so please leave it open.
Comment 8 Christian Lohmaier 2014-05-25 11:15:14 UTC
for beta1 a wontfix, as I won't respin the builds for that.

There is no beta-style TDF branded artwork yet.
Beta2 can have one, although I don't see it as critical enough to redo beta1.
Comment 9 Adolfo Jayme 2014-08-07 08:06:04 UTC
I’ve submitted a branch to fix the wrong branding (cf. comment 5) since July 14; once that somebody actually cares to push it (!), I think we can close this. I don’t see the need to add more branding images.
Comment 10 retired 2014-08-17 07:38:02 UTC
I don’t think this is about branding imagery, but rather

a) the info string e.g. shown in OS X finder when selecting the LibreOffice.app under „Version“ 
b) the „About“ window of LO itself

Both should correctly display alpha, beta, RC ideally.
Comment 11 Adolfo Jayme 2014-08-17 17:56:46 UTC
@Foss: that’s not the scope of this bug report. Read comment 0 again.
Comment 12 Commit Notification 2014-08-21 14:27:52 UTC
Adolfo Jayme Barrientos committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=7aac7d175605e1bb94c3967c294ed7f915a5603a

Resolves: fdo#79172 dev builds were misleadingly labeled 'beta'



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 13 Adolfo Jayme 2014-08-21 16:38:32 UTC
So we have a new splash screen image for *development builds*. If labels for beta and RC are really desired, these should be requested in a new bug report.